•   
  • 1
  • 205
  • 206
  • 207(current)
  • 208
  • 209
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
New LibreELEC.tv Krypton build #1124: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.10 #1 Thu Nov 24 21:08:34 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Nov 19 2016 19:49:42
Copyright (c) 2012 Broadcom
version af95a294891b6ca0d369ffb1cabcc3f6c53489ca (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161124210732-#1124-g405c39f [Build #1124]

# Kodi version
(17.0-BETA6 Git:17.0-beta5-e92818a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (405c39f6, changelog) and tip of XBMC master (30d4d28b, changelog) with the following modifications: Build Highlights:
  1. Bump systemd 232
  2. Bump Python 2.7.12
  3. [PVR] fix recordings window subfolder listings (@grisia please test and confirm, thanks)
Build Details:
  1. LibreELEC.tv:
    • timezone-data: convert to new tzdata and tzcode packages (PR:940, 1 commit, 3 files changed)
    • repository.kodinerds: fix icons (PR:984, 1 commit, 3 files changed)
    • libopenmpt: fix leftover from version bump (PR:983, 1 commit, 1 file changed)
    • scripts/create_addon: copy fanart to buildfolder too (PR:985, 1 commit, 1 file changed)
  2. XBMC:
    • fixed: use correct type for time parameter in UPnPPlayer (PR:10977, 1 commit, 2 files changed)
    • Speed up startup time for movies in split rar archives. (PR:9925, 1 commit, 1 file changed)
    • use debug logging for missing textures (PR:10547, 1 commit, 1 file changed)
  3. kodi-theme-Estuary:
  4. pvr.iptvsimple:
    • Increase logging, parse M3U files lacking EXTM3U marker. (PR:83, 1 commit, 2 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:958: Python: update to 2.7.12
    • Added: [env] PR:980: systemd: update to 232
    • Added: [pkg] PR:10982: [PVR] fix recordings window subfolder listings
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-23, 17:30)hanspeter Wrote:
(2016-11-23, 17:02)arndtw Wrote:
(2016-11-21, 23:32)hanspeter Wrote: This one freezes (ssh and serial-console dead, log stops), with random colored noise on the screen, not reproducable, sometimes while playing video, sometimes while idle with black screensaver on; happened six or seven times in the last 18h...

Anyone else seeing this...? The screen looks really like random memory is spilling into the screen, guess this is somehow related to the new bootcode?

I have the same problem with #1121 #1122 and #1120 on Rpi3

config.txt is untouched beside the keys for hardware decoding.

thank god, at least i'm not crazy Wink. Let's try to find similaritys in our system. I'm on a RPi2, so it's not a SoC-Version specific thing.

advancedsettings.xml

Code:
<advancedsettings>
        <cache>
                <buffermode>1</buffermode>
                <memorysize>41943040</memorysize>
                <readfactor>10.0</readfactor>
        </cache>
        <pvr>
                <minvideocachelevel>0</minvideocachelevel>
                <minaudiocachelevel>0</minaudiocachelevel>
                <cacheindvdplayer>false</cacheindvdplayer>
                <numericchannelswitchtimeout>500</numericchannelswitchtimeout>
        </pvr>
        <videolibrary>
                <recentlyaddeditems>250</recentlyaddeditems>
        </videolibrary>
        <splash>false</splash>
        <cputempcommand>sed -e 's/\([0-9]*\)[0-9]\{3\}.*/\1 C/' /sys/class/thermal/thermal_zone0/temp</cputempcommand>
        <omx>
                <omxdecodestartwithvalidframe>1</omxdecodestartwithvalidframe>
        </omx>
</advancedsettings>

installed addons:

Code:
metadata.album.universal                  repository.emby.kodi                      script.module.autocompletion
metadata.artists.universal                repository.robwebset                      script.module.beautifulsoup
metadata.common.fanart.tv                 resource.images.moviegenreicons.coloured  script.module.kodi65
metadata.common.imdb.com                  resource.images.musicgenreicons.text      script.module.requests
metadata.common.musicbrainz.org           resource.images.recordlabels.white        script.module.routing
metadata.themoviedb.org                   resource.images.studios.coloured          script.module.simplejson
plugin.program.autocompletion             resource.images.studios.white             script.module.youtube.dl
plugin.video.emby                         resource.images.weatherfanart.multi       script.openweathermap.maps
plugin.video.emby.movies                  resource.images.weathericons.animated     script.tvtunes
plugin.video.emby.musicvideos             script.extendedinfo                       script.videoextras
plugin.video.emby.tvshows                 script.globalsearch                       virtual.rpi-tools
plugin.video.youtube                      script.image.resource.select              weather.openweathermap.extended
repository.beta.emby.kodi                 script.module.addon.signals               webinterface.chorus
anything that sound familliar?

My kodi.old.log is 21Mb after 90 minutes and mainly consists of the following messages when it crashes;

Code:
23:17:58.933 T:1535968160   DEBUG: ProcessPacket - audio:11 video:0
23:17:58.987 T:1535968160   DEBUG: Previous line repeats 2 times.
23:17:58.987 T:1535968160   DEBUG: ProcessPacket - audio:10 video:0
23:17:59.090 T:1535968160   DEBUG: Previous line repeats 12 times.
23:17:59.090 T:1535968160   DEBUG: ProcessPacket - audio:9 video:0
23:17:59.090 T:1535968160   DEBUG: ProcessPacket - audio:10 video:0
23:17:59.091 T:1535968160   DEBUG: Previous line repeats 2 times.
23:17:59.091 T:1535968160   DEBUG: ProcessPacket - audio:11 video:0
23:17:59.138 T:1535968160   DEBUG: Previous line repeats 1 times.
23:17:59.139 T:1535968160   DEBUG: ProcessPacket - audio:10 video:0

I have very few addons but I do run 'virtual.rpi-tools' too for a little script that controls the fan in my case. I don't run a custom advancedsettings.xml.
I've noticed recently that libreelec is unable to automatically switch on/off the 3D mode on my LG TV when attempting to play any 3D file (ISO, MVC, HTAB, or HSBS).

Here is my log file.

https://paste.ubuntu.com/23529844/
(2016-11-24, 19:53)MrSliff Wrote: Hello, together.

First i have to appreciate your work, Millhouse. Very nice Kodi Distibution. Big Grin

I have a little problem since the last 5 or 6 Builds:

I have a playlist with some Online Radio Channels in it, its played automatically when i come home. So problems with this. But there's one Radio channel which causes Kodi to crash, when its played.

Can you upload your crashlog and post the link?

I don't have a crash on RPi3 (or X86 NUC), however Kodi does freeze for a very, very long time before playing this stream (ssh is not affected).

I did get it to play once on RPi3 but it took a long time before I heard audio, during which Kodi remained completely frozen and unresponsive (didn't even respond to JSON requests). I haven't been able to reproduce playback on RPi3 apart from this once.

Here is the log of an i5 Skylake NUC playing this stream from favourites (ffmpeg and libcurl component logging enabled): http://sprunge.us/MPPi - this takes 5 minutes with frozen kodi before audio is heard.

On the NUC, Kodi is frozen at 23:45:58.416, then springs into life at 23:50:52.288 when it finally starts playing audio.

I went back through the builds and the stream will play normally with #1115, but not with #1116. As there are no obvious Kodi differences this might be a compiler issue (ffmpeg and gcc-6.2?)

Edit: Forced crashhlog ("kill -SIGSEGV $(pidof kodi.bin)") from RPi3 after two minutes frozen: http://sprunge.us/XfAF
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-25, 02:48)Milhouse Wrote:
(2016-11-24, 19:53)MrSliff Wrote: Hello, together.

First i have to appreciate your work, Millhouse. Very nice Kodi Distibution. Big Grin

I have a little problem since the last 5 or 6 Builds:

I have a playlist with some Online Radio Channels in it, its played automatically when i come home. So problems with this. But there's one Radio channel which causes Kodi to crash, when its played.

Can you upload your crashlog and post the link?

I don't have a crash on RPi3 (or X86 NUC), however Kodi does freeze for a very, very long time before playing this stream (ssh is not affected).

I did get it to play once on RPi3 but it took a long time before I heard audio, during which Kodi remained completely frozen and unresponsive (didn't even respond to JSON requests). I haven't been able to reproduce playback on RPi3 apart from this once.


Edit: Forced crashhlog ("kill -SIGSEGV $(pidof kodi.bin)") from RPi3 after two minutes frozen: http://sprunge.us/XfAF

Same problem here, just tried it again with that Stream Milhouse. It freezes. So with the above command in ssh i get a forced crashlog?

Gonna try it this evening (German time). Where will i find the crash log?

BTW: I have a RPi2

Edit:

Found this in your crashlog, just overflew it:

00:52:09.846 T:1784619936 WARNING: CreateLoader - unsupported protocol(playmedia("http) in playmedia("http://relay1.hirschmilch.de:7100/chillout.tbn

Maybe thats the problem?
(2016-11-25, 06:54)MrSliff Wrote: Same problem here, just tried it again with that Stream Milhouse. It freezes.

So it's not currently crashing as originally claimed? Just want to be clear on that, as it's a rather important point.

(2016-11-25, 06:54)MrSliff Wrote: So with the above command in ssh i get a forced crashlog?

Yes:
Code:
kill -SIGSEGV $(pidof kodi.bin)
will crash kodi.bin, and you should then have a crashlog that you can upload.

(2016-11-25, 06:54)MrSliff Wrote: Where will i find the crash log?

See note #4 in the first post. Upload the crashlog to a pastebin site, then paste the link here.

(2016-11-25, 06:54)MrSliff Wrote: Edit:

Found this in your crashlog, just overflew it:

00:52:09.846 T:1784619936 WARNING: CreateLoader - unsupported protocol(playmedia("http) in playmedia("http://relay1.hirschmilch.de:7100/chillout.tbn

Maybe thats the problem?

No, that warning is related to the new skin and should not have any bearing on this issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
OKay, thanks.

And yeah it looks like its crashing, but actually just freezes the UI and it takes time to start the stream.

Its jut this stream, the others work fine.

Edit:

Another question: Am i able to change the main background to a wallpaper of my choice in the new skin version? Didnt find an option in the settings.
(2016-11-25, 08:02)MrSliff Wrote: Another question: Am i able to change the main background to a wallpaper of my choice in the new skin version? Didnt find an option in the settings.

Not sure - I only see "Choose skin fanart pack" but presumably that isn't what you want. Try posting in the Estuary forum if nobody replies. It may be that it isn't yet implemented (for instance, Weather is currently missing but being worked on).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Okay, thanks for that!

Im going to ask there.
(2016-11-25, 00:00)bmonster Wrote:
(2016-11-24, 23:47)Milhouse Wrote:
(2016-11-24, 19:43)SpokV Wrote: For some reason I get screen resolution with big icons and fonts and it looks scaled out.

Can you post a screen shot? It might be how it's supposed to look...

I think thats how it was made as Milhouse suggests, it is pretty big..

Well, in my opinion it is useless. Is there away to stick to the old version while still upgrading the libreelec image?
(2016-11-25, 11:07)SpokV Wrote: Is there away to stick to the old version while still upgrading the libreelec image?

You can boot #1122 and
Code:
cp -r /usr/share/kodi/addons/skin.estuary /storage/.kodi/addons/skin.estuaryV1/

then edit "/storage/.kodi/addons/skin.estuaryV1/addon.xml" and change

from:
Code:
<addon id="skin.estuary" version="1.9.1" name="Estuary" provider-name="phil65, Piers">
to:
Code:
<addon id="skin.estuaryV1" version="1.9.1" name="Estuary (V1)" provider-name="phil65, Piers">

Restart Kodi. Select "Estuary (V1)" as your new skin.

Of course this old skin won't work forever, so if you have issues with the new Estuary then you should voice them in the right place (the Estuary sub-forum), or find an alternative third-party skin (perhaps Confluence).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-25, 01:34)jarvismeier Wrote: I've noticed recently that libreelec is unable to automatically switch on/off the 3D mode on my LG TV when attempting to play any 3D file (ISO, MVC, HTAB, or HSBS).

Do you have "adjust display refresh rate to match video" enabled (you must for 3D mode switching to work).

What is this?
Code:
17:28:56.445 T:1450963872  NOTICE: [service.lgtv.remote 0.1.20] Stereoscopic mode has changed to TAB
17:28:56.446 T:1450963872   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.KeyError'>
                                            Error Contents: ('',)
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/service.lgtv.remote/default.py", line 158, in onPlayBackStarted
                                                self.sendCommand(__mode3D_on__[self.lg_protocol], self.lg_seq_3D_on)
                                            KeyError: ('',)
                                            -->End of Python script error report<--

It doesn't seem to be working properly (report it to service.lgtv.remote maintainer).
But it shouldn't be necessary on a Pi - it handles 3D switching itself.
(2016-11-25, 12:11)Milhouse Wrote:
(2016-11-25, 11:07)SpokV Wrote: Is there away to stick to the old version while still upgrading the libreelec image?

You can boot #1122 and
Code:
cp -r /usr/share/kodi/addons/skin.estuary /storage/.kodi/addons/skin.estuaryV1/

then edit "/storage/.kodi/addons/skin.estuaryV1/addon.xml" and change

from:
Code:
<addon id="skin.estuary" version="1.9.1" name="Estuary" provider-name="phil65, Piers">
to:
Code:
<addon id="skin.estuaryV1" version="1.9.1" name="Estuary (V1)" provider-name="phil65, Piers">

Restart Kodi. Select "Estuary (V1)" as your new skin.

Of course this old skin won't work forever, so if you have issues with the new Estuary then you should voice them in the right place (the Estuary sub-forum), or find an alternative third-party skin (perhaps Confluence).

Many thanks Milhouse. I will....
@grisia if you have the chance, could you please test build 1124 and report back whether the pvr recordings subfolder issues are solved?
(2016-11-25, 11:07)SpokV Wrote:
(2016-11-25, 00:00)bmonster Wrote:
(2016-11-24, 23:47)Milhouse Wrote: Can you post a screen shot? It might be how it's supposed to look...

I think thats how it was made as Milhouse suggests, it is pretty big..

Well, in my opinion it is useless. Is there away to stick to the old version while still upgrading the libreelec image?

I ended up moving to estuary mod, as i don't think the dev is planning on updating it to v2..
They should put v1 in the repository as an option, its a lovely skin and a shame to completely abandon it.
  •   
  • 1
  • 205
  • 206
  • 207(current)
  • 208
  • 209
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319