•   
  • 1
  • 209
  • 210
  • 211(current)
  • 212
  • 213
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-11-27, 17:07)doldi Wrote: If i watch dvd's with multichannel sound there is always silence on start - i have to reset my HDMI Switch to get sound a with builds #1120 and higher.

There are no changes related to audio or passthrough on #1120, so it seems unlikely that is the build that causes the issue.
Are you sure the failure isn't just random?
(2016-11-27, 20:53)Hoopla Wrote: I am not sure that this has been discussed, but the interface seems to be sluggish when switching out of videos. It takes a few seconds to load the thumbnails interface (it used to be immediate in openelec). I am using a raspberry pi 3 so hardware speed shouldn't be an issue.

Is this with the same skin (e.g. using Confluence)? Obviously a different skin may require more work, and Estuary is a heavier skin than Confluence.

If it is different with the same skin, then identifying the first build that had the slowdown would be useful.
Any news about the recent higher temps? My RPi3 also reaches 75C without overclocking, just watching PVR with remote TVHeadend.
Temp symbol keeps flashing on my screen even without the RPi3 case...
(2016-11-26, 13:11)doldi Wrote: settings/Skin/config ->Thema : chance curial or flat - RPi will rebot after shown a grey baar instead mouse-
arrow...

Yes, I can reproduce issue with mouse pointer when switching themes. I know what the issue is, need to find a fix.
(2016-11-28, 00:24)rudrood Wrote: Any news about the recent higher temps? My RPi3 also reaches 75C without overclocking, just watching PVR with remote TVHeadend.
Temp symbol keeps flashing on my screen even without the RPi3 case...

If the higher temps are a recent change then identifying the first build with the issue would be useful.
I'm not aware of any change.

What is the format of video you are watching? If it is MPEG-2 do you have the hardware codec licence?
(2016-11-27, 14:03)herrmeier01 Wrote: On #1126 with a fresh install I'm not able to install VDR addon. There is a compatibility issue.
An upgraded system which has VDR installed doesn't have this problem when updating the VDR addon

The error when installing service.multimedia.vdr-addon is this:
Code:
22:05:16.702 T:1489195936   DEBUG: CAddonInstallJob[pvr.vdr.vnsi]: requires xbmc.pvr version 5.2.0 which is not available
22:05:16.703 T:1489195936   ERROR: CAddonInstallJob[service.multimedia.vdr-addon]: The dependency on xbmc.pvr version 5.2.0 could not be satisfied.

There's an out of date version of pvr.vdr.vnsi (version 2.6.7) available online in the LE repo (created for Kodi 17 beta 5) that has a dependency on xbmc.pvr 5.2.0 (which isn't available in the latest build).

The version of pvr.vdr.vnsi I include in the latest build (v999.2.6.9) is disabled by default, but has the correct dependency on xbmc.pvr 5.2.1 (this is provided by the latest build).

While the local pvr.vdr.vnsi add-on is disabled the installation of service.multimedia.vdr-addon will fail because the online pvr.vdr.vnsi add-on is incompatible.

Maybe this behaviour is correct - I really don't know. After all, the installed local add-on is disabled so perhaps it makes sense for Kodi to "prefer" the alternative online add-on instead. Or maybe it doesn't. I'm undecided.

Anyway, the solution is to enable the local and already installed pvr.vdr.vnsi client add-on (version 999.2.6.9), and THEN install service.multimedia.vdr-addon from zip. This way the dependencies will be correctly satisfied during installation of service.multimedia.vdr-addon.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #1127: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.11 #1 Sun Nov 27 23:38:38 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Nov 26 2016 13:28:47
Copyright (c) 2012 Broadcom
version 6f567a4db96231f764d5a9a5b11b153009d13d5b (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161127233733-#1127-g7eafbcc [Build #1127]

# Kodi version
(17.0-BETA6 Git:17.0-beta5-e92818a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (7eafbcca, changelog) and tip of XBMC master (eb835b89, changelog) with the following modifications: Build Highlights:
  1. New 4.8.11 kernel
  2. ffmpeg: update to 3.1.6-Krypton-Beta6
  3. inpustream.adaptive replaces both inputstream.mpd and inputstream.smoothstream add-ons
    peak3d Wrote:This addon superseeds inputstream.mpd and inputstream.smoothstream.

    The reason is, that only parsing and some minor other parts differ, ~95% of mpd and smoothstream share the same code.
    This change may temporarily break addons that depend on inputstream.mpd or inputstream.smoothstream - such add-ons will need to be updated to make use of inputstream.adaptive.

    The version of inputsteam.adaptive used in these builds does not currently support WideVine decryption - as and when this is available the inputstream.adaptive add-on will be updated.
Build Details:
  1. LibreELEC.tv:
    • linux: update to linux-4.8.11 (PR:991, 4 commits, 32 files changed)
  2. XBMC:
    • cmake: make external, shared ffmpeg default (PR:10479, 3 commits, 3 files changed)
    • [cmake] allow using an existing Texturepacker binary (PR:10988, 1 commit, 2 files changed)
    • VideoPlayer: rtmp fixes (PR:10998, 1 commit, 1 file changed)
    • [PVR] Fullscreen video: On up/down and no channel info is currently s… (PR:10995, 1 commit, 1 file changed)
    • [PVR] Reintroduce filename sort for PVR recordings (PR:10999, 1 commit, 1 file changed)
    • [PVR][guiinfo] Fix listitem hastimerschedule (PR:11001, 1 commit, 1 file changed)
    • [Estouchy] update to match the new look of the default skin (PR:10991, 1 commit, 64 files changed)
    • aml: Do not force default output device for passtrough (PR:10942, 1 commit, 1 file changed)
  3. kodi-theme-Estuary:
    • widget work and cleanup (PR:128, 3 commits, 4 files changed)
    • add mute icon to TopBarOverlay (PR:130, 1 commit, 1 file changed)
    • streamline context menu (PR:131, 1 commit, 1 file changed)
    • Use adaptive height for music osd settings (PR:134, 1 commit, 1 file changed)
    • hide seekbar in case sliderdialog is active (35c362b5)
    • another try to fix PVR OSD issues (8be55e80)
    • mute icon into time sublabel (65f75147)
    • better spacing (2662cc3b)
    • pvr work (96d32a8b)
    • showinfo only for livetv (501e8659)
    • font tweak, add missing font to arial fontset (6de17200)
    • fixedlist focusposition/movement (4a87a6f7)
    • improve timer window list labels (2ecea349)
    • cleanup post/prefixing (d6a23d48)
    • pvr overlay: also check for videowindow (83afdc54)
    • home menu wrapping (5c0e9de5)
  4. pvr.mythtv:
    • 4.9.2 (PR:77, 2 commits, 6 files changed)
  5. kernel 4.8.y:
    • New commits in this build:
      • config: Add ABX80X RTC driver and overlay (5de1385d)
      • config: Add AK4554 audio codec driver (429efdba)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: ffmpeg: update to 3.1.6-Krypton-Beta6
    • Added: [env] patch: Add kodi binary addons (pvr, adsp, other)
    • Added: [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
    • Added: [env] PR:994: kodi-binary-addons: inputstream.adaptive replaces inputstream.mpd and inputstream.smoothstream
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-11-28, 00:23)popcornmix Wrote:
(2016-11-27, 20:53)Hoopla Wrote: I am not sure that this has been discussed, but the interface seems to be sluggish when switching out of videos. It takes a few seconds to load the thumbnails interface (it used to be immediate in openelec). I am using a raspberry pi 3 so hardware speed shouldn't be an issue.

Is this with the same skin (e.g. using Confluence)? Obviously a different skin may require more work, and Estuary is a heavier skin than Confluence.

If it is different with the same skin, then identifying the first build that had the slowdown would be useful.

Yeah, Estuary is the skin. But even in older versions of libreelec it used to be quicker.

Looks like it started in#0906
(2016-11-27, 23:56)popcornmix Wrote:
(2016-11-27, 23:03)hanspeter Wrote: Didnt have a crash with anyting below 1024, it's running stable on #1126 and total_mem=1023.

That may be interesting. It may suggest the arm is accessing memory in 1008M-1009M range
which would fail when total_mem=1024, but would be okay with total_mem=1023 (1007M-1008M is okay)
which does narrow the possibilities down a little.

Anyone else experiencing the crashing, I'd be interested if total_mem=1023 is also good for you.

Set total mem=1023.. will report back in 24hr
(2016-11-28, 00:24)rudrood Wrote: Any news about the recent higher temps? My RPi3 also reaches 75C without overclocking, just watching PVR with remote TVHeadend.
Temp symbol keeps flashing on my screen even without the RPi3 case...

I've had high temp issues with my RPi3 on latest builds also... I've never overclocked and never needed heat sinks and never got the high temps before recent builds. I do not have the time to go on installing builds to identify, but my best guess is this started happening to me somewhere between builds #1119 - #1124
(2016-11-28, 00:12)popcornmix Wrote:
(2016-11-27, 17:07)doldi Wrote: If i watch dvd's with multichannel sound there is always silence on start - i have to reset my HDMI Switch to get sound a with builds #1120 and higher.

There are no changes related to audio or passthrough on #1120, so it seems unlikely that is the build that causes the issue.
Are you sure the failure isn't just random?

i'm sure.- after update to a new build i make always a new start (not reboot) - testet about a long time at this weekend.
Indeed all builds with "miss the "next chapter button over progress bar" have/had this "feature" ;-)
(2016-11-28, 07:13)loggio Wrote:
(2016-11-28, 00:24)rudrood Wrote: Any news about the recent higher temps? My RPi3 also reaches 75C without overclocking, just watching PVR with remote TVHeadend.
Temp symbol keeps flashing on my screen even without the RPi3 case...

I've had high temp issues with my RPi3 on latest builds also... I've never overclocked and never needed heat sinks and never got the high temps before recent builds. I do not have the time to go on installing builds to identify, but my best guess is this started happening to me somewhere between builds #1119 - #1124

Same here. after updating to #1124 the issue started. I also had the temp symbol
Went back to #1119 because of the memory crashes and the temps dropped back to about 65 degrees which are still a bit too high for my taste
(2016-11-28, 10:23)dsenseb Wrote: Same here. after updating to #1124 the issue started. I also had the temp symbol
Went back to #1119 because of the memory crashes and the temps dropped back to about 65 degrees which are still a bit too high for my taste

Are you saying #1123 has high cpu and #1122 does not have high cpu?
The memory crashes on older builds can be avoided with total_mem=1008 (or possibly even 1023).
(2016-11-28, 00:44)Milhouse Wrote:
(2016-11-27, 14:03)herrmeier01 Wrote: On #1126 with a fresh install I'm not able to install VDR addon. There is a compatibility issue.
An upgraded system which has VDR installed doesn't have this problem when updating the VDR addon

The error when installing service.multimedia.vdr-addon is this:
Code:
22:05:16.702 T:1489195936   DEBUG: CAddonInstallJob[pvr.vdr.vnsi]: requires xbmc.pvr version 5.2.0 which is not available
22:05:16.703 T:1489195936   ERROR: CAddonInstallJob[service.multimedia.vdr-addon]: The dependency on xbmc.pvr version 5.2.0 could not be satisfied.

There's an out of date version of pvr.vdr.vnsi (version 2.6.7) available online in the LE repo (created for Kodi 17 beta 5) that has a dependency on xbmc.pvr 5.2.0 (which isn't available in the latest build).

The version of pvr.vdr.vnsi I include in the latest build (v999.2.6.9) is disabled by default, but has the correct dependency on xbmc.pvr 5.2.1 (this is provided by the latest build).

While the local pvr.vdr.vnsi add-on is disabled the installation of service.multimedia.vdr-addon will fail because the online pvr.vdr.vnsi add-on is incompatible.

Maybe this behaviour is correct - I really don't know. After all, the installed local add-on is disabled so perhaps it makes sense for Kodi to "prefer" the alternative online add-on instead. Or maybe it doesn't. I'm undecided.

Anyway, the solution is to enable the local and already installed pvr.vdr.vnsi client add-on (version 999.2.6.9), and THEN install service.multimedia.vdr-addon from zip. This way the dependencies will be correctly satisfied during installation of service.multimedia.vdr-addon.

Thanks a lot. I was able to install it again with your help. Unfortunately VDR addon higher than 8.0.100 still don't work with scrambled TV. I had to downgrade 8.0.103 to 8.0.100 because i have to use my smart card for watching TV. But I think I'm the only one who use this feature in beta testing branch and this topic is not welcome at this forum.
@Milhouse do you have plans to publish a ..x build again with the 4.9rc6 kernel? I had very good experience with it. I'm not sure but my feeling was that this build was a little bit smoother than the build with the 4.8 kernel.
I'm able to copy just the kernel.img file over the latest build but I'm not sure if some dependencies will make problems.
  •   
  • 1
  • 209
  • 210
  • 211(current)
  • 212
  • 213
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319