•   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-07-09, 22:04)Milhouse Wrote:
(2016-07-09, 21:45)pyrodex Wrote:
(2016-07-08, 23:53)Milhouse Wrote: New LibreELEC.tv Krypton build #0708: Generic
  • Revert "vdpau: refcount decoder with surfaces given to ffmpeg, align with vaa…" (PR:10092, 1 commit, 2 files changed)

Milhouse,

I noticed with builds after #703, seems to not exhibit this issue, that with an AMD APU (A6-3500) I noticed over time when watching shows there is tremendous LAG or stutter down the road. I saw this commit was reverted mentioned in the quote hoping it would fix the issue since #703 but no luck. I will try to get a debug log once the wife is done watching her shows but wanted to know if anyone else here experience the issue.

My RPI2/RPI3's aren't affected by the same issue and are running #708 perfectly fine.

I'm trying to parse your comment... are you saying you have a problem with builds after #0703 (ie. the problem starts with build #0704)? Or does the problem start with #0703?

PR10092 is reverting PR10075 which first appeared in build #0707 - the latter PR introduced a significant memory leak, which should now no longer be present. Since you say (if I'm reading your post correctly) that the lag/stutter problem started with #0704 (or maybe #0703) then I'm not sure I see any connection between the two PRs (PR10075 and PR10092), unless I've misunderstood your post. Smile

The obvious change in #0704 is the switch to kernel 4.7-rc6. If however you're saying the problem started with #0703, then the obvious change is ffmpeg 3.1.1.

Can you state the issue clearly, and when it first started. A debug log would be very useful.

Sorry #703 is stable for me, I jumped from #703 to #707 and then noticed the issue. I can try going up in builds if you want or is there a specific number before 707 you want me to test?
HTPC(s): All running LibreELEC
  • AMD 2200G APU on Gigabyte AB350N-Gaming WIFI-CF
  • RPI3 x2 | RPI2 x2
NAS: FreeNAS (Latest Stable) | NFS/CIFS
(2016-07-09, 22:22)pyrodex Wrote: Sorry #703 is stable for me, I jumped from #703 to #707 and then noticed the issue. I can try going up in builds if you want or is there a specific number before 707 you want me to test?

In that case #0708 should be good again, as that reverts the change added in #0707 (assuming the problem starts with #0707, and is due to PR10075, which would now seem unlikely if you continue to have this problem in #0708).

What you also have is a new kernel in #0704, so trying #0704, #0705 and #0706 in turn until you reproduce the problem will help focus attention on the first build that has this lag/stutter problem.

Once we know the first build when the lag/stutter starts it should be possible to start making more educated guesses. A debug log from the latest build #0708 may also help shed some light on what is causing the lag/stutter.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0709: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc6 #1 SMP Sat Jul 9 21:13:04 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160709211042-#0709-gf78c95e [Build #0709]

Based on tip of LibreELEC.tv master (f78c95ef, changelog) and tip of XBMC master (8bd8cf48, changelog) with the following modifications: Build Highlights:
  1. Bump mesa 12.0.1
  2. Update Intel CPU firmware
Build Details:
  1. LibreELEC.tv:
    • update mesa to 12.0.1 (PR:527, 1 commit, 1 file changed)
    • update cpu-firmware to latest release (PR:528, 1 commit, 1 file changed)
  2. XBMC:
    • [cmake/android] Install librtmp (PR:10094, 1 commit, 1 file changed)
    • fix test suite by declaring a deleter for CDataCacheCore (PR:10090, 1 commit, 3 files changed)
    • Freebsd cmake (PR:10087, 7 commits, 8 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:526: Cpu temperature readings for devices with aml_thermal interface
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@MadMeddler here my latest build https://mega.nz/#!55wyhQyT!xZ8Sc1PO9KZYl...aOxFKp9tqs (based on great Milhouse work and with changes for CherryTrail )
Millhouse, thank you, it looks and runs good.
(2016-07-10, 05:21)piotrasd Wrote: @MadMeddler here my latest build https://mega.nz/#!55wyhQyT!xZ8Sc1PO9KZYl...aOxFKp9tqs (based on great Milhouse work and with changes for CherryTrail )

piotrasd

It looks like your build has broken the LAN adapter (though the audio over HDMI has worked a treat). I haven't tried the 0709 Milhouse build as yet for comparison.
"it looks like" is not an error description ;-)

Please post logs or it will get insanely hard for piotrasd to keep his builds up and running.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@MadMeddler please send me dmsg, lsusb i lspci from working buid.
I disabled most device in kernel, most z8300 miniPC has no PCI, so example i disabled whole tree of tuners DVB on PCIE, and many other stuff.
Let me know on PM what do you need (with logs)
@piotrasd: If you plan to get that stuff back in upstream, you should have as minimal changes as possible.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@fritsch i just made version for my devices so i have very minimal kernel etc.
but now when i see Milhouse go into kernel 4.7 i will prepare second one for users with BT/CHT devices with default kernel config from LE

UPDATE:
here latest version with default LE linux config
https://mega.nz/#!E85HARaC!1kaed31FR4Otw...SX3LKRpNBg
PS. default password "le"
@fritsch - Apologies, you're quite right - poor reporting on my part. I will do better.

@piotrasd - Any idea how I can get your update onto my box, given no LAN connectivity and the WiFi dongle I have isn't being recognised either. I've tried using a USB stick and using FileManager to copy the file to .update without success (no sign of the USB stick being recognised). Is there a mechanism for dropping to a command prompt to try an manually mount the USB stick?

Once I can do any of that I can try and provide some logs etc, also I'd like to be able to copy my Kodi config off the box - just in case I need to revert back to the original LE image.
copy on USB connect to BOX and from SSH copy to /storage/.update Wink
or from FileManager in kodi - but in setting you must Enable show hiden files
Ah, but I can't SSH because I have no network :-)

I can add the destination (/storage/.update), but I can't add the source - it doesn't seem to recognise any USB sticks I present to the box.

Don't worry, I'll wipe and start again - not the end of the world.
New LibreELEC.tv Krypton build #0710: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc6 #1 SMP Sun Jul 10 21:59:53 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160710215831-#0710-g1cfefd3 [Build #0710]

Based on tip of LibreELEC.tv master (1cfefd35, changelog) and tip of XBMC master (a6a8c5bb, changelog) with the following modifications: Build Highlights:
  1. Minors
Build Details:
  1. LibreELEC.tv:
    • libssh: change url (PR:531, 1 commit, 1 file changed)
    • projects/imx6: update Linux kernel, libcec and Kodi Krypton (PR:533, 1 commit, 16 files changed)
    • distro-tool: Change default target after server move from web01 to web03 (PR:532, 1 commit, 1 file changed)
    • amremote update to latest d4f6458 (PR:529, 1 commit, 1 file changed)
  2. XBMC:
    • [depends] build curl without librtmp support (PR:10086, 1 commit, 1 file changed)
    • VideoPlayer: update selectionstreams when stream parameters changes (PR:10097, 1 commit, 1 file changed)
    • Duplicate include removed (PR:10099, 2 commits, 1 file changed)
  3. xbmc/master (FernetMenta):
    • Commits no longer in build:
      • VideoPlayer: fix setting pixel format for ffmpeg (7fc748e1)
      • change gui info from Player_Process.xxx to Player.Process(%s) (af42298b)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-07-10, 17:46)piotrasd Wrote: ...

UPDATE:
here latest version with default LE linux config
...

piotrasd

Thanks for the update. I've finally gotten around to updating from the Milhouse #0703 to your Dev build from yesterday and everything seems to be working fine. I have audio, Ethernet and USB sticks all showing up as I'd hoped.
  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111