•   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
please anyone upload /sys/class/drm/card0/error
(2016-04-29, 15:01)sunnyfunny Wrote:
(2016-04-29, 13:32)b0mb Wrote: here is my log of GUI crash that happens with all builds after 21.04.

http://sprunge.us/WZEU

Same Problem on my NUC3700

@millhouse

can you switch back to Kernel which is used in builds before 21.04?

No, better to fix the problems by moving forwards than backwards.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-04-29, 07:14)fritsch Wrote:
Quote:[ 2.057769] Hardware name: Shuttle Inc. XH61V/FH61V, BIOS 1.05 05/03/2013
[ 2.057771] Workqueue: events output_poll_execute
[ 2.057773] 0000000000000000 ffffffff812b6f16 ffff880119f57b98 0000000000000000
[ 2.057774] ffffffff8103a756 0000000000000000 ffff880119f57bf0 0000000000000000
[ 2.057775] 000000000000003c ffff8800d0c54e08 0000000000000001 ffffffff8103a7b5
[ 2.057775] Call Trace:
[ 2.057778] [<ffffffff812b6f16>] ? dump_stack+0x5a/0x6f
[ 2.057780] [<ffffffff8103a756>] ? __warn+0xc8/0xe1
[ 2.057781] [<ffffffff8103a7b5>] ? warn_slowpath_fmt+0x46/0x4e
[ 2.057783] [<ffffffff81848087>] ? _raw_spin_lock_irqsave+0xe/0x29
[ 2.057784] [<ffffffff81378fed>] ? drm_wait_one_vblank+0x123/0x13c
[ 2.057786] [<ffffffff810636ce>] ? wake_up_atomic_t+0x1f/0x1f
[ 2.057788] [<ffffffff814e01e7>] ? ironlake_crtc_enable+0xac9/0xb90
[ 2.057789] [<ffffffff814c56d7>] ? hsw_write64+0x5/0x5
[ 2.057790] [<ffffffff814dddbb>] ? intel_atomic_commit+0x5c2/0x101c
[ 2.057792] [<ffffffff8138ae6c>] ? drm_atomic_check_only+0x273/0x52a
[ 2.057794] [<ffffffff8137127d>] ? restore_fbdev_mode+0x109/0x223
[ 2.057795] [<ffffffff81372a3d>] ? drm_fb_helper_restore_fbdev_mode_unlocked+0x2b/0x5e
[ 2.057796] [<ffffffff81372aa6>] ? drm_fb_helper_set_par+0x36/0x41
[ 2.057797] [<ffffffff81372a0a>] ? drm_fb_helper_hotplug_event+0xab/0xb3
[ 2.057798] [<ffffffff81368cc1>] ? output_poll_execute+0x12b/0x15a
[ 2.057800] [<ffffffff8104b188>] ? process_one_work+0x139/0x1d4
[ 2.057801] [<ffffffff8104b6d3>] ? worker_thread+0x1d3/0x29e
[ 2.057802] [<ffffffff8104b500>] ? rescuer_thread+0x2b6/0x2b6
[ 2.057803] [<ffffffff8104f1ff>] ? kthread+0x95/0x9d
[ 2.057804] [<ffffffff81848382>] ? ret_from_fork+0x22/0x40
[ 2.057805] [<ffffffff8104f16a>] ? init_completion+0x1d/0x1d
[ 2.057808] ---[ end trace 8421c749f3f31a64 ]---

Kernel bug with your hardware. Post your Xorg.0.log please.

Here is Xorg.0.log - http://pastebin.com/thaAyeCg

Please let me know if you need anything else!
ESXi 5.5 | VMs : [unRAID] [PLEX] [SAB] [CP] [Sonarr] [uTorrent] [MySQL] [Apache] [Mythbuntu]
(2016-04-26, 01:46)Milhouse Wrote:
(2016-04-25, 22:01)M4tt0 Wrote: Unfortunately, no success with any of the above builds. Am using a Logitech K400r wireless USB keyboard. Never had issues with that so far...

Now that you mention *USB* keyboard (rather than just "keyboard", which I assumed to mean on-screen keyboard - my bad), has this ever worked correctly with any earlier version of OpenELEC?

As far as I'm aware, OpenELEC has very limited OS localisation support, and this limited support hasn't really changed in LibreELEC.

There is a localisation change in Kodi in #0418 (PR9550, which isn't actually working as intended due to *ELEC's limited localisation support), but this change shouldn't have any effect on your USB keyboard.

@Milhouse: Gee, probably tested 10 different version until I arrived at the result.

The "wrong keyboard layout" problem for my external USB keyboard started with your OpenELEC (that is correct: OPEN) tesbuild 7.0 #1119. Debug log

All of your earlier OE builds in the "old" thread have another problem though. My USB keyboard does not work AT ALL. Debug log of latest version with this sympton here (OE 7.0 #1117).

This is contrasting my experience with my working production system which runs on the same HTPC, just from the internal SSD instead and does not have these problems.

Which leaves me to speculate that this might(!) be some kind of USB problem: On the test system external USB keyboard and USB HDD are attached (as the test system runs from there), whereas on the production system only the external USB keyboard is attached (as it runs from the internal SSD). Upstream problem with x-server? But any thoughts and advice appreciated.
I have to say running the latest build from the 28th on my chromebox and it's running like a champ. No issues that I have seen so far.

***Clearly I should not have said that as in the movie just had a black screen dropout. Will see if I can duplicate.
Just tested #0429

Seems no more gpu crash on bsw

Edit : nevermind still gpu crash


http://sprunge.us/CiBa

http://sprunge.us/bPiO

And also

A
- Left key of remote act as right key

- using addon like audio profile switcher to change audio profile (tv to avr passthrough) corrupts video (choppy, slowly, corrupted)

Log : http://sprunge.us/bZVB
@Milhouse: Interesting. I'm not alone it seems...

See this thread...
He has a fully different issue. He is running Ubuntu ... and keyboard layout change is OS dependend. Kodi's setting (not the OE settings setting) has no influence there.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Asked on his thread: The symptoms are exactly the same. Are you referring to differences in the underlying structures between an LE build and the Ubuntu version, fritsch?
OK, @Milhouse, @fritsch, forget it: I configured the keyboard settings in the wrong place (in Kodi instead of LE). That was all. Everything works as it should...
(2016-04-29, 18:10)M4tt0 Wrote: @Milhouse: Gee, probably tested 10 different version until I arrived at the result.

The "wrong keyboard layout" problem for my external USB keyboard started with your OpenELEC (that is correct: OPEN) tesbuild 7.0 #1119. Debug log

All of your earlier OE builds in the "old" thread have another problem though. My USB keyboard does not work AT ALL. Debug log of latest version with this sympton here (OE 7.0 #1117).

This is contrasting my experience with my working production system which runs on the same HTPC, just from the internal SSD instead and does not have these problems.

Which leaves me to speculate that this might(!) be some kind of USB problem: On the test system external USB keyboard and USB HDD are attached (as the test system runs from there), whereas on the production system only the external USB keyboard is attached (as it runs from the internal SSD). Upstream problem with x-server? But any thoughts and advice appreciated.

Thanks for digging. In build #1119 there is an xorg server bump (deferred from the previous build due to issues - see #1117 for the commit). However since this issue dates back to these OpenELEC 7.0 builds, you should find you have this same problem in the latest OE 7.0 Beta 2 and LibreELEC 7.0 release builds - can you confirm?

Assuming this problem is present in these release builds, it should then be reported upstream.

Edit: OK just seen your last post. Good, good. Smile
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-04-29, 22:56)Roby77 Wrote: And also

A
- Left key of remote act as right key

Yes, it's PR9656. I've pulled the build, will upload #0429b shortly.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0429b: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc5 #1 SMP Fri Apr 29 23:27:52 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160429232628-#0429b-gac8e298 [Build #0429b]

Based on tip of LibreELEC.tv master (ac8e298b, changelog) and tip of XBMC master (b6ddce80, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. #0429b: Reverted Apple remote change - breaks MCE remotes
Build Details:
  1. LibreELEC.tv:
    • Linux update to 4.6 (PR:183, 11 commits, 45 files changed)
    • LibreELEC addon repository: change to xml.gz (PR:175, 1 commit, 1 file changed)
    • WeTek_Core/WeTek_Play: fix new cec driver patch (PR:230, 1 commit, 2 files changed)
    • system-tools: initial add-on (PR:232, 27 commits, 47 files changed)
    • network-tools: initial add-on (PR:233, 17 commits, 23 files changed)
    • dvb-tools: initial add-on (PR:234, 6 commits, 13 files changed)
    • multimedia-tools: initial add-on (PR:235, 8 commits, 15 files changed)
    • fixes and picks from seo (PR:247, 3 commits, 2 files changed)
    • projects/WeTek*: Fix build with Kodi 17 (PR:256, 2 commits, 4 files changed)
    • tvheadend xmltv fix (PR:255, 2 commits, 2 files changed)
    • rpi-tools: move depends to rpi-tools-depends (PR:236, 1 commit, 3 files changed)
    • Python: fix build by including $ROOT (PR:261, 1 commit, 1 file changed)
  2. XBMC:
    • [doxygen] add code guidelines (PR:9687, 1 commit, 6 files changed)
    • cmake: Handle ENABLE_VAAPI and ENABLE_VDPAU both being disabled correctly (PR:9693, 2 commits, 2 files changed)
    • [OSX] Fix non working apple remote / universal ir remote / harmony (PR:9656, 4 commits, 5 files changed)
    • [pvr] - make running instance aware of changed settings (PR:9707, 1 commit, 2 files changed)
    • [cmake] Cosmetics (PR:9711, 2 commits, 4 files changed)
    • [cmake][linux] Insert PulseAudio block into kodi-standalone (PR:9709, 1 commit, 1 file changed)
  3. pvr.argustv:
    • Dependencies are not needed from brew/apt-get (PR:55, 1 commit, 1 file changed)
  4. pvr.hdhomerun:
    • Dependencies are not needed from brew/apt-get (PR:24, 1 commit, 1 file changed)
  5. pvr.pctv:
    • Dependencies are not needed from brew/apt-get (PR:37, 1 commit, 1 file changed)
  6. pvr.stalker:
    • Dependencies are not needed from brew/apt-get (PR:59, 1 commit, 1 file changed)
  7. Additional commits/pull requests/changes not yet merged upstream:
    • Reverted: [pkg] PR:9656: [OSX] Fix non working apple remote / universal ir remote / harmony (Reason: breaks LEFT/RIGHT)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Anyone that reported problems adding shortcuts that were not being saved after a reboot, can you confirm if this problem is still present in build #0428 and later? Hopefully it's fixed now.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I'm having very little success

http://sprunge.us/NOiR

This lockup occurred while watching a Myth recording

I'm having lockups generally very often with the last few builds
  •   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111