•   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-05-28, 00:42)Milhouse Wrote: It was fixed 2 weeks ago but I thought I'd keep it to myself. j/k

I knew it! I just wanted you to admit it! Smile

(2016-05-28, 00:42)Milhouse Wrote: No, there's no news. That's why the last release continues to announce there is no DVD support.

It has been unsupported for a couple of months, but I wasn't able to find any further info (did I mention I'm a lurker?)
Not that I can do something about it, I was just curious...
I'm missing the save button under "libreelec/connection settings" when trying to change the IP. Is it just me or is it a general issue?
(2016-05-23, 13:58)Milhouse Wrote:
(2016-05-23, 10:26)aesthetiker Wrote: Since I upgraded from openelec to librelec.

This is absolutely of no help.

(2016-05-23, 10:26)aesthetiker Wrote: Tried to uninstall pvr.hts reconfigure etc no changes to this behavior.

The add-on is built-in, trying to uninstall it won't work.

If you want a fix you'll need to determine when the problem starts (ie. identify the first build with the problem).

Hi Milhouse,

I try to setup from scratch. As soon as i used profiles pvr.hts didn't start anymore. I need profiles for kids and master user. Is there any change in profiles ?
(2016-05-29, 10:57)mule1 Wrote: I'm missing the save button under "libreelec/connection settings" when trying to change the IP. Is it just me or is it a general issue?
Yes it's a bug.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-29, 11:44)aesthetiker Wrote: Hi Milhouse,

I try to setup from scratch. As soon as i used profiles pvr.hts didn't start anymore. I need profiles for kids and master user. Is there any change in profiles ?

Not that I'm aware of. Do you have this problem with LibreELEC 7.0.1 too (you'll need to install pvr.hts)? Maybe it's a pvr.hts problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0529: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0 #1 SMP Sun May 29 21:06:19 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160529210452-#0529-g270d9f1 [Build #0529]

Based on tip of LibreELEC.tv master (270d9f15, changelog) and tip of XBMC master (0ecc4b55, changelog) with the following modifications:
  • Includes FernetMenta "VideoPlayer" patches
  • Includes latest kodi-platform master (c8188d82, ahead +4)
  • Includes latest libcec master (6d68d212)
  • Includes latest libnfs master (00d9ba15, ahead +19)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: adsp.basic (2ae604e5, +8), adsp.biquad.filters (01236bbe, +7), adsp.freesurround (34f50406, +7), asplib (da66f517), inputstream.mpd (3ac19c39, +11), inputstream.smoothstream (32275717, +2), peripheral.joystick (83371862, +30), pvr.argustv (5f48dcec, +4), pvr.demo (0fa9e1d0, +4), pvr.dvblink (a92f1264, +5), pvr.dvbviewer (3d0bea9a, +4), pvr.filmon (8743511d, +4), pvr.hdhomerun (b5ce9309, +4), pvr.hts (acd1a6ac, +5), pvr.iptvsimple (7a5a43f8, +4), pvr.mediaportal.tvserver (172a273c, +4), pvr.mythtv (e2b60252, +8), pvr.nextpvr (150698b7, +4), pvr.njoy (b5d65655, +4), pvr.pctv (feed5990, +4), pvr.stalker (4244220f, +12), pvr.vbox (c6594819, +4), pvr.vdr.vnsi (5498a8c1, +7), pvr.vuplus (ea3b33f6, +4), pvr.wmc (77af8daf, +4)
  • Includes commits from xbmc/master, ahead +5 (FernetMenta)
  • Exclude [env] kodi-999.10-aarch64-support.patch: Merged upstream
  • Include [env] e7cbe9cb: xf86-video-intel: Explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] patch: xf86-video-intel: bump to 3fafabe
  • Include [env] patch: Fix SIGTERM patch after PR9748
  • Include [env] patch: Fix cmake after PR9750
  • Include [env] patch: Add extra headers needed by 3D BD MVC
  • Include [env] patch: Disable -werror as libnfs won't build 32-bit without it
  • Include [env] patch: Bump libbluray - include MVC support
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.*, os.* and peripheral.*
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] patch: Enable other binary addons
  • Include [env] PR:353: plymouth-lite: add bilinear interpolation patch
  • Include [env] PR:366: mysql: update to 5.7.12
  • Include [env] PR:382: systemd: update to 230
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] dd81c2f1: [librtmp] Update to 15-Dec-2015 from http://stream-recorder.com/forum/customi...16103.html (kodi)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Extend Fake HDMI live status to Valley View (linux)
  • Include [pkg] patch: drm/i915/psr: Try to program link training times correctly (HSW fix) (linux)
  • Include [pkg] patch: Revert "drm/i915: Exit cherryview_irq_handler() after one pass" (BSW fix) (linux)
  • Include [pkg] patch: CSC: Remove average logic when saving NV12 surface on IVB+ (VAAPI fix) (libva-intel-driver)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:9803: [PeripheralCecAdapter] fix playback stopping on screensaver deactivated
  • Include [pkg] PR:9847: [PVR] Feature: Make instant recording behavior configurable
Build Highlights:
  1. NOTE: DVD ISO playback remains temporarily disabled
  2. VideoPlayer fixes
Build Details:
  1. LibreELEC.tv:
    • xf86-video-nvidia: update to xf86-video-nvidia-361.42 (PR:388, 1 commit, 3 files changed)
    • splash: Select splash image based on native resolution (PR:381, 1 commit, 8 files changed)
    • fluxbox: add key binding alt + escape to close window (PR:385, 1 commit, 1 file changed)
    • Virtual bump for vbox guest additions and build fixes (PR:131, 1 commit, 6 files changed)
    • linux: add RTC_DRV_DS3232 to RPi/RPi2 (PR:397, 1 commit, 2 files changed)
    • virtual: use Generic addon repo (PR:401, 1 commit, 1 file changed)
    • oscam: update to 11233 (PR:399, 1 commit, 2 files changed)
  2. XBMC:
    • [DVDDemuxClient] fix not adapted log texts after C/P (PR:9883, 1 commit, 1 file changed)
    • VideoPlayer: fixes (PR:9881, 3 commits, 2 files changed)
    • [CodecIMX] correction after 449758b82b8ff92590c420f213c918b94495eb0f … (PR:9882, 1 commit, 1 file changed)
    • GUISliderControl & AudioDSP music OSD (PR:9869, 2 commits, 3 files changed)
    • [peripherals] Fix another deadlock (PR:9825, 3 commits, 2 files changed)
    • [lang][kodi.core] automatic syntax corrections for the en_GB language file (2b6cc184)
    • [lang] updated language files from Transifex (65ed41e4)
    • [lang][skin.estuary] updated language files from Transifex (90a5c86f)
    • [lang][skin.estouchy] updated language files from Transifex (11a63964)
  3. xbmc/master (FernetMenta):
    • Commits no longer in build:
      • VideoPlayer: fix CheckEnableClockSync (47230c83)
      • VideoPlayer: remove some useless code (3c554a61)
      • VideoPlayer: improve skipping frames (7712899e)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-29, 22:39)Milhouse Wrote: [*]Commits no longer in build:
  • VideoPlayer: fix CheckEnableClockSync (47230c83)
  • VideoPlayer: remove some useless code (3c554a61)
  • VideoPlayer: improve skipping frames (7712899e)

why?

And suspend is broken in latest builds as it seems.
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - Harmony Elite BT
Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT
all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
(2016-05-30, 01:20)john.cord Wrote: why?

The original commits have now been merged as PR9881.

(2016-05-30, 01:20)john.cord Wrote: And suspend is broken in latest builds as it seems.

Latest builds? When did it last work?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-30, 02:08)Milhouse Wrote: Latest builds? When did it last work?

I have to do further testing to nail the problem down. Maybe a problem with my HDMI Setup (TV --> HDMI Splitter --> AVR --> Kodi).
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - Harmony Elite BT
Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT
all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
If i configure Kodi to 1080/50p output resolution most of the times (90%) after kodi/libreelec has been started i get no audio and the log is beeing flooded with "failed to create audio renderer". Audio can be restored by changing the audio configuration (e.g. switch passthrough on/off).
A workaround in order to avoid the issue is to set the output resolution to 1080/60p. With 60Hz audio is allways working as it should.

I tried many different libreelec builds (oldest, latest etc.) on a NUC34010 and a beebox N3150 and on two different TVs with the same faulty behaviour. The curious thing is that it never happened with V17 builds from fritsch which i used before switiching to libreelec.

This issue has already been discussed about 2 years ago on the openelec forum (Link: http://openelec.tv/forum/68-audio/70881-...ctic-mc001) but it seems that it has never been solved.

Shall i post logs?
Try to force the EDID information as shown in the wiki and see if this works for you. The kernel folks are still working on proper i2c support for HDMI Audio, which is not yet existent on BSW.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@mule1 curious never ecounterd this problem with chromebox and same beebox
(2016-05-30, 14:49)fritsch Wrote: Try to force the EDID information as shown in the wiki and see if this works for you. The kernel folks are still working on proper i2c support for HDMI Audio, which is not yet existent on BSW.
Sorry forgot to mention that i already tried it with forced EDID.

You're talking about implemention for BSW, but the NUC34010 is based on Haswell. Are the kernel folks still working on Haswll too?
The issue seems not to be Intel only related because the guy who reported it 2 years ago on the openelec forum had an Artic MC001 which is using an AMD Mobility 5430 GPU.

What i don't get: Most times audio ist faulty, BUT sometimes it is not (without any change to the system). And why can a change within audio settings (e.g. disabling/enabling passthrough) reanimate audio? And why is audio allways working when the default refreshrate is set to 60Hz?
Changing device does a reenumeration. So if devices before and after are different, this has only one reason: while booting up EDID / Audio information was not yet available and no signal was emitted when that changed. I am running a HSW based setup myself with edid forced and xorg.conf I never had an issue in that combination. Provide Xorg.0.log dmesg | pastebinit and kodi.log with an unsuccesful boot _with_ edid forced.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Will post the dmesg output today in the evening.

But in theory a restart of Kodi only after openelec/libreelec has fully booted should solve an enumeration issue, or am I wrong? Therefore in the mentioned thread on the openelec forum someone suggested to restart kodi after a defined delay after the boot process has finished using the the autostart.sh of openelec/libreelec. I also tried this suggestion (even with a 30! second delay) but without success: Sometimes audio can be restored, sometimes not.
  •   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111