•   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-07-12, 04:04)artur9 Wrote: I have a movie that only plays the sound but no video. Black screen.

dmesg: http://sprunge.us/IQEX
kodi.log (movie play starts at 21:57:35 3247.654785) http://sprunge.us/HOBW

What am I doing wrong?

Anything?
(2016-07-14, 13:06)artur9 Wrote: I have a movie that only plays the sound but no video. Black screen.

Code:
21:57:39 3252.362549 T:139621392443136   ERROR: VAAPI::Decode - timed out waiting for output message - decoded: 0, proc: 4, has free surface: yes

It's a VAAPI hw decoder error. I know nothing about that, but disabling VAAPI in video acceleration settings is worth a try.
@Milhouse did you after update mesa recompile whole other grafic stuff ?

(my friend now instaled your latest build and i saw in dmesg this)
Quote:[drm:intel_pipe_update_end] *ERROR* Atomic update failure on pipe C (start=649865 end=649866) time 295 us, min 1073, max 1079, scanline start 1068, end 1088

This error i got when i only updated mesa to latest, i dont know which package is depended of that with mesa, anyway after make clean and recompiled whole LE error gone.

UPDATE:
on kernel 4.7 dvb driver from dvbsky crash Sad
http://pastebin.com/esMC8Cah

UPDATE2:

my friend with latest Intel Computerstick with m3 skylake - after upgrade to #712 stock on syslinux ... dialog and system no boot any more
and any other next version also, last working #711
(before he only used your this same build GENERIC)
(2016-07-14, 14:48)piotrasd Wrote: This error i got when i only updated mesa to latest, i dont know which package is depended of that with mesa, anyway after make clean and recompiled whole LE error gone.

No it wasn't a clean build after the last mesa bump. I'll build clean for this evening.

(2016-07-14, 14:48)piotrasd Wrote: UPDATE:
on kernel 4.7 dvb driver from dvbsky crash Sad
http://pastebin.com/esMC8Cah

Thanks, hopefully someone familiar with that code can suggest a fix.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I just noticed that beginning with build #0626 I can't play m2ts videos with truehd audiotracks on my Intel NUC34010 anymore if audio passthrough of dolby truehd is enabled. Even the samples from the kodi wiki are not playing anymore.
Kodi seems to play the files (time counter is running when pressing info button), but the screen is just black and audio is silent. Sometimes when stopping this kind of playback kodi crashes.
If I disable passthrough or disable the option that the receiver has the capability to decode dolby truehed tracks the videos play without any issue.

Shall i post logs?
@mule1 a debug log and also your crashlog would be useful.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-07-14, 18:38)Milhouse Wrote: @mule1 a debug log and also your crashlog would be useful.
What's better: Using latest build or #0626?
Latest please.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Here we go!

Kodi log: http://pastebin.com/q7ZufGSV
Crash log: http://pastebin.com/9sGh4JtX
New LibreELEC.tv Krypton build #0714: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc7 #1 SMP Thu Jul 14 21:57:22 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160714215524-#0714-gcd6bf14 [Build #0714]

Based on tip of LibreELEC.tv master (cd6bf143, changelog) and tip of XBMC master (aa0f7ea3, changelog) with the following modifications: Build Highlights:
  1. Allow lirc to process event codes >= 256
Build Details:
  1. LibreELEC.tv:
    • Update image script to expose build filename (PR:540, 1 commit, 1 file changed)
  2. XBMC:
    • Subtitles/SAMI: fix parsing of files with leading whitespace (PR:10100, 1 commit, 1 file changed)
    • Add ipv6 support to Event Server (PR:10104, 1 commit, 3 files changed)
    • VideoPlayer: fix seeking while paused (PR:10109, 2 commits, 2 files changed)
    • Various micro-optimizations in the URL code (PR:10070, 17 commits, 12 files changed)
    • FIX: [droid] high cpu with amc surface (PR:10111, 1 commit, 3 files changed)
    • fix typo after 093912e311525de7bf39f316b8cfa20e400febad (e84ba1f5)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] patch: Allow event codes >= 256 (lirc)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
With build #0714 are there any remaining remote-control (lirc) issues, such as incorrect/missing buttons?

Note that auto-repeat remains broken, and is a separate issue.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
With latest #714 I have bad audio when I start the video or if I skip fw/rev. The sound is like an old cassette tape under speed and than catches up . All this with audio passthrough disabled.
I think this stared few build a go but not sure which one.
log: http://sprunge.us/Kehd

With audio passthrough enabled I still have tons of dropped frames on 29.97 videos only.
log: http://sprunge.us/ZaZS

Thanks for all the hard work you guys do!
(2016-07-14, 14:37)popcornmix Wrote:
(2016-07-14, 13:06)artur9 Wrote: I have a movie that only plays the sound but no video. Black screen.

Code:
21:57:39 3252.362549 T:139621392443136   ERROR: VAAPI::Decode - timed out waiting for output message - decoded: 0, proc: 4, has free surface: yes

It's a VAAPI hw decoder error. I know nothing about that, but disabling VAAPI in video acceleration settings is worth a try.

Disabling VAAPI got the movie to play. Thanks!

BTW, not being to play this movie goes all the way back to the Milhouse OpenELEC builds.
(2016-07-14, 14:48)piotrasd Wrote: @Milhouse did you after update mesa recompile whole other grafic stuff ?

Any better with #0714 (which is a clean build)?

(2016-07-14, 14:48)piotrasd Wrote: UPDATE2:

my friend with latest Intel Computerstick with m3 skylake - after upgrade to #712 stock on syslinux ... dialog and system no boot any more
and any other next version also, last working #711
(before he only used your this same build GENERIC)

Is this the same friend with the mesa issue (in which case he probably can't test #0714...although worth a shot as it's a clean build).

I guess there's something in the latest 4.7-rc7 kernel that disagrees with Skylake, though what that might be I've no idea. The latest #0714 build is booting just fine on a NUC6I5SYH which is also Skylake (i5-6260U), so perhaps something specific to the Computestick?

If your friend with the Computestick copies the SYSTEM and KERNEL files from the #0711 tar to the boot partition, does the Computestick then boot normally again?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0715: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.0-rc7 #1 SMP Fri Jul 15 21:41:51 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160715213952-#0715-gde6f79d [Build #0715]

Based on tip of LibreELEC.tv master (de6f79d0, changelog) and tip of XBMC master (80095b65, changelog) with the following modifications: Build Highlights:
  1. Bump (non-legacy) nvidia driver to latest 367.35
  2. Updated database migration message to avoid crashing during Addons*.db migration
Build Details:
  1. LibreELEC.tv:
    • lirc: re-add patch to support additional keys (PR:542, 1 commit, 1 file changed)
  2. XBMC:
    • [fix][tests] Missed this one (PR:10113, 1 commit, 1 file changed)
    • [win32] Improve installer and add appxmanifest (PR:10110, 1 commit, 3 files changed)
    • [fix] revert commit c9884248b729709450087f05dd8449e794253a6 utils/Var… (PR:10116, 1 commit, 1 file changed)
    • [win32] update AppVeyor with ffmpeg 3.1.1 (fbae963d)
  3. inputstream.smoothstream:
    • disable stream after last segment (31e7afef)
  4. peripheral.joystick:
    • [cocoa] Fix compiler warning: missing override keyword (6090a90e)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:543: xf86-video-nvidia: update to 367.35
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111