•   
  • 1
  • 130
  • 131
  • 132(current)
  • 133
  • 134
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-09-13, 22:21)Milhouse Wrote:
(2016-09-13, 20:44)_Spook_ Wrote: @Milhouse When 4.8 is finished I would like a build to test on my NUC6i7KYK to see if that fixes that 8-bit patch thing we have been talking about here previosly.

@_Spook_ (and others):

Here is another kernel 4.8-rc6 build, #0913y: Generic.

This #0913y build is essentially the same as the (soon to be published) #0913 build, apart from being based on gcc6.2, and 4.8-rc6 kernel, and it includes the updated binary blobs I mentioned previously (amdgpu, i915, radeon). However the Chris Wilson 8bpc patch is now dropped from #0913y, and replaced with the following 4K patch:

https://patchwork.freedesktop.org/series/11252

This 4K patch only applies on top of 4.8-rcX so 4.7.3 based builds will continue to use the Chris Wilson 8bpc patch.

This is the last 4.8-rc6 build. I'll upload another 4.8-rc7 build next week once 4.8-rc7 is released.

Thanks,

Same kernel panic though as previous one.
bugs.freedesktop.org please. It needs attention.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
i unsquasfsed the SYSTEM file, but can't find anywhere the polaris* blobs ... am i doing something wrong ? (they are not in /etc/firmware/amdgpu , they should be right ?)
(2016-09-14, 06:19)fritsch Wrote: bugs.freedesktop.org please. It needs attention.

How can i get the logs when kernel panic on boot ?
Screenshot (Edit: With real camera), if nothing else helps.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2016-09-14, 12:25)fritsch Wrote: Screenshot (Edit: With real camera), if nothing else helps.

Well i don't even know what to report !

Besides, i've tested on another linux distro (elementary, with mesa 12.1, kernel 4.8 rc5...), the card is working. (but i've rebuilt the kernel myself, like here : https://linuxconfig.org/getting-the-rx-4...u-on-linux)

so i'm not even sure it's not libreelec related.
(2016-09-14, 07:23)alxtr1bal Wrote: i unsquasfsed the SYSTEM file, but can't find anywhere the polaris* blobs ... am i doing something wrong ? (they are not in /etc/firmware/amdgpu , they should be right ?)

The firmware isn't in SYSTEM, it's in the initrd of the kernel (KERNEL).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I'm getting the same kernel panic with AMD Radeon RX 460 GPU.
And here again the bugs.freedesktop.org link for you.

Either you donate a card to someone that wants to fix it or you get involved :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
New LibreELEC.tv Krypton build #0914: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.3 #1 SMP Wed Sep 14 21:05:14 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160914210358-#0914-gd875a87 [Build #0914]

Based on tip of LibreELEC.tv master (d875a87d, changelog) and tip of XBMC master (88367403, changelog) with the following modifications: Build Highlights:
  1. Skin migration and addon compatibility checking
Build Details:
  1. LibreELEC.tv:
    • Update Amlogic kernel 3.10 to 86c93aa (PR:731, 3 commits, 3 files changed)
    • projects/WeTek_Hub/patches/kodi: use poweroff instead of suspend (PR:732, 1 commit, 1 file changed)
    • projects/WeTek_Hub: Map Home button on IR remote to KEY_HOME (PR:734, 2 commits, 1 file changed)
  2. XBMC:
    • VideoPlayer: fix some remaining http header issues (PR:10458, 2 commits, 2 files changed)
    • [pvr] show notification if no pvr addon is enabled while entering a pvr window (PR:10461, 1 commit, 6 files changed)
    • skin migration and addon compatibility checking (PR:10335, 14 commits, 27 files changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: kodi: Fix addon wrapper after PR:10335
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-13, 22:25)_Spook_ Wrote: Cool. I will test it tomorrow on the other NUC. Is the LSPCON patch in there also?

How is #0913y (4.8-rc6 kernel with 4K patch, and without Chris Wilson 8bpc patch)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Sorry I have been away for the last couple of days, I will do all I can to help get the Radeon issue resolved.
here is my dmesg log for build 0914, same xorg error.
http://sprunge.us/QAeA
(2016-09-14, 23:49)madmarkym Wrote: Sorry I have been away for the last couple of days, I will do all I can to help get the Radeon issue resolved.
here is my dmesg log for build 0914, same xorg error.
http://sprunge.us/QAeA

Just an observation - it's after the memory initialization message that the 4.8-rc6 kernel panics (photo):
Code:
[    0.728565] [TTM] Memory type 2 has not been initialized
[    0.728775] amdgpu: probe of 0000:01:00.0 failed with error -22

At least the errors are consistent, it's just that the 4.8-rc6 kernel handles it all rather badly.

I'm really not sure how to solve this right now. We're using the latest amdgpu driver, latest firmware binaries, and latest (stable) kernel. In theory it should "just work"... Sad
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-14, 23:49)madmarkym Wrote: Sorry I have been away for the last couple of days, I will do all I can to help get the Radeon issue resolved.
here is my dmesg log for build 0914, same xorg error.
http://sprunge.us/QAeA

Can you try build #0914x: Generic

This is identical to build #0914 (ie. based on 4.7.3 kernel) but has CONFIG_DRM_AMD_POWERPLAY=y enabled in the kernel. Enabling this feature might avoid one of those initialisation errors the kernel is experiencing.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-15, 00:48)Milhouse Wrote:
(2016-09-14, 23:49)madmarkym Wrote: Sorry I have been away for the last couple of days, I will do all I can to help get the Radeon issue resolved.
here is my dmesg log for build 0914, same xorg error.
http://sprunge.us/QAeA

Can you try build #0914x: Generic

This is identical to build #0914 (ie. based on 4.7.3 kernel) but has CONFIG_DRM_AMD_POWERPLAY=y enabled in the kernel. Enabling this feature might avoid one of those initialisation errors the kernel is experiencing.

It certainly looks like we are getting a bit closer now. We are booting into a blacks screen with a mouse cursor, there were no on screen errors though.
Here are my logs including xorg this time, it looks like there were a few modules that failed to load
dmesg: http://sprunge.us/FjMe
xorg: http://pastebin.com/TQsvyXdf
  •   
  • 1
  • 130
  • 131
  • 132(current)
  • 133
  • 134
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111