•   
  • 1
  • 148
  • 149
  • 150(current)
  • 151
  • 152
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
I tried HDMI bitstream 5.1/7.1 and HDMI passthrough 7.1/5.1 to AVR. No sound. Same setup on #1003 4.7.6 is OK.

I also made sure that the output device was correct because that sometimes changes for some reason.
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
New LibreELEC.tv Krypton build #1004: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.7.6 #1 SMP Tue Oct 4 23:32:04 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161004233048-#1004-g438740d [Build #1004]

Based on tip of LibreELEC.tv master (438740d2, changelog) and tip of XBMC master (70417777, changelog) with the following modifications:
  • Includes latest kodi-platform master (c8188d82)
  • Includes latest libcec master (62b8520c, ahead +15)
  • Includes latest libnfs master (048e7737, ahead +59)
  • Includes latest p8-platform master (041a8c6c, ahead +1)
  • Includes latest addons: inputstream.mpd (9a14177d), inputstream.rtmp (70cb86f6), inputstream.smoothstream (081c6c43), peripheral.joystick (abff3165), pvr.argustv (87cb6780, +3), pvr.demo (01c68c88), pvr.dvblink (e842db92, +4), pvr.dvbviewer (f72c62ff), pvr.filmon (675c2b4e), pvr.hdhomerun (eef1bd15), pvr.hts (c091da30, +4), pvr.iptvsimple (a4c52558), pvr.mediaportal.tvserver (845479b6, +10), pvr.mythtv (b1b426f3), pvr.nextpvr (f99b17d3, +7), pvr.njoy (b5d65655), pvr.pctv (d6d969fe), pvr.stalker (168e35f7), pvr.vbox (c966c5fd, +8), pvr.vdr.vnsi (dd95edef, +2), pvr.vuplus (7ab30d34), pvr.wmc (d9eac84f)
  • Exclude [env] kodi-100.17-dbupgrade-dynamic-splash-message.patch: use upstream alternative
  • Exclude [env] kodi-999.99-PR10345.patch: closed upstream, no longer required
  • Exclude [env] kodi-999.99-PR10501.patch: merged upstream
  • Exclude [env] kodi-999.99-PR10502.patch: merged upstream
  • Exclude [env] libcec-PR208.patch: merged upstream (libcec)
  • Exclude [env] pvr.dvblink-0001-PR54.patch: merged upstream
  • Include [env] patch: Add kodi binary addons (pvr, adsp, other)
  • Include [env] patch: Don't build ADSP addons
  • Include [env] patch: RPi2: Enable CONFIG_KERNEL_MODE_NEON
  • Include [env] patch: ffmpeg: update to ffmpeg-3.1.4-Krypton-Beta3
  • Include [env] patch: libdrm: update to libdrm-2.4.71
  • Include [env] patch: Bump included addon versions to prevent online updates
  • Include [env] patch: Add experimental splash video for RPi
  • Include [env] patch: HACK: Disable multiple PVR addons during migration. Always enable inputstream.* and os.*
  • Include [env] PR:752: linux: extra options for Baytrail and 32-bit EFI
  • Include [env] PR:786: xf86-video-ati: add xorg-radeon.conf to enable dri3 and glamor
  • Include [env] PR:800: xf86-video-intel: enable dri3 and make it default
  • Revert [env] 46b9b7b3: rtmpdump (Reason: use newclock5 bump)
  • Include [pkg] 441217d8: logging: Add microsecond timer to log messages (kodi)
  • Include [pkg] patch: drm/i915: Fixes and diagnostics for Braswell (linux)
  • Include [pkg] patch: drm/i915: Fix backwards test in Chris Wilson patch (link) (linux)
  • Include [pkg] patch: [skin.estuary] Hide watched items on home (kodi-theme-Estuary)
  • Include [pkg] patch: drm/i915: Limit the depth of the display pipeline to the framebuffer (linux)
  • Include [pkg] PR:30: enable samba at wizard (LibreELEC-settings)
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:10370: Add settings to control notification rumble duration and strength
  • Include [pkg] PR:10543: [platform] - add unique hardware identifier as info label
  • Include [pkg] PR:10572: [CryptThreading] replace hardcoded value for CRYPTO_LOCK by macro
  • Include [pkg] PR:10594: [gui] smartplaylisteditor: convert spinners etc to regular buttons
  • Include [pkg] PR:10617: [eventlog] implement high resolution datetime sort method (CDateTime granularity of 1 sec is not sufficient).
  • Include [pkg] PR:10620: [jsonrpc] CAnnouncementManager: fix invalid type "movies" for video items without video info tag
  • Revert [pkg] d44e0212: Untested: android MediaDRM (reverted: breaks linux build) (inputstream.mpd)
  • Revert [pkg] 9a14177d: mediandk (reverted: breaks linux build) (inputstream.mpd)
Build Highlights:
  1. Update libdrm to 2.7.1 (link). RX460/470/480 users can you confirm if your custom xorg.conf is still required? I imagine it will be, just checking...
  2. Enable DRI3 for Intel as the default
Build Details:
  1. LibreELEC.tv:
    • linux: remove /dev/console patch from aarch64 (PR:799, 1 commit, 1 file changed)
  2. XBMC:
    • [cmake] Fix always outdated targets (PR:10614, 2 commits, 2 files changed)
    • VTB on OSX: fix flickering video caused by buffer overwrite (PR:10615, 2 commits, 8 files changed)
    • [doxygen] add support to show function with version change text (PR:10621, 1 commit, 3 files changed)
    • Create italian.xml (#10545) (dd13b734)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: libdrm: update to libdrm-2.4.71
    • Added: [env] PR:800: xf86-video-intel: enable dri3 and make it default
    • Added: [pkg] PR:10617: [eventlog] implement high resolution datetime sort method (CDateTime granularity of 1 sec is not sufficient).
    • Added: [pkg] PR:10620: [jsonrpc] CAnnouncementManager: fix invalid type "movies" for video items without video info tag
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Same here with 4.8 no audio on the asus chromebox. Nothing looked out of the ordinary - will have to dig in more later.
Correction to my earlier post, my NUC is a NUC6i5SYH not NUC6i5SYK.

@_Spook_ and @porkchop999: I've now hooked the NUC6i5SYH up to my Onkyo NR-828 amp (into 5.1 speakers) and I get no audio with any recent 4.8 build - not #1003x (4.8.0), #0926x (4.8-rc8) or #0919x (4.8-rc7). I've tested both with and without passthrough, same result - no sound.

Audio is working fine with the same setup and 4.7.6 (ie. #1004). Audio is also working fine with my Revo3700 (Atom)/ION2 and 4.8 (any version) into this amp. The amp doesn't support 4K, nor does my TV.

The only 4.8 builds that have working audio when the NUC is connected to the amp are #0917k and #0917m:
(2016-09-17, 07:16)Milhouse Wrote: @_Spook_: Here are your three 4.8-rc6 based builds.

#0917k: without the 4k patch; without the lspcon patch
#0917l: with the 4k patch; with the lspcon patch
#0917m: without the 4k patch; with the lspcon patch

#0917l also has no audio.

Oddly, all these builds have working audio when testing with my 1080p computer monitor over HDMI.

Obviously the 4K patch would appear to be the problem, but I've no idea why the same builds work with a cheap computer monitor but not with a more capable amp. And why this problem is only being reported now, when the older builds also had problems (or maybe it's only with specific hardware?)

Are you Intel users testing these 4.8 builds with 4K capable hardware (either amp, TV or both)?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Here's a new 4.8.0 build #1005x: Generic

It's the same as #1004 (in terms of Kodi etc., but built with gcc-6.2), but does NOT include the 4K patch like previous 4.8 builds. Can you test this and let me know if you now have working audio?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yes #1005x has audio
Great, I've now dropped the 4K patch so it won't appear in future 4.8 builds.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I still have it skipping a frame every 5 sec (only on 4.8 builds). But will do a bit more testing to make sure its not hyperion or something like that causing it.
Looks like modesetting driver was causing the skipped frames. No problem with the intel driver.
Don't forget to file bugs for all this upstream. Concerning the 4kpatch, also in the already open report.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
using #1004 works everything fine,

but i have some entries in my Logfile which I do not know myself what that can mean, and no idea how to resolve.

Hope someone of you can help me there, or confirm that the messages are harmless

- ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
- ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
@_Spook_ and @porkchop999 - can you confirm if #0926x (4.8-rc8) has working audio for you?

My NUC6i5SYH when connected to my amp has no audio going back as far as #0917l (which is based on 4.8-rc6). I'm sure we had positive reports with these builds, and I can only assume this and later builds with the 4K patch were all working for you both (but not the latest #1003x build based on 4.8.0 - I've no idea what changed here, if anything).

I'm just wondering if the 4K patch _ever_ worked... or maybe it only worked when connected to a 4K-capable output device (or something very basic)? For me, the 4K patch works only when connected to a simple computer monitor with the most basic audio capabilities, and doesn't appear to have ever produced working audio with my amp.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yes #0926x has audio
I have hdmi going straight to the TV (4ktv) and the audio going via DP to the receiver (my receiver messes up the color space)
I will check all this after work for my setup.
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
Millhouse - just as a reference my asus chromebox is hooked up to a Denon amp to a jvc proejctor (1080p) so nothing 4k related and I had no audio in the 1003x build.
  •   
  • 1
  • 148
  • 149
  • 150(current)
  • 151
  • 152
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111