•   
  • 1
  • 157
  • 158
  • 159(current)
  • 160
  • 161
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-10-16, 15:43)Superbert Wrote: Hi Millhouse,
i tested brave all of your new releases, no one fixed my DTS problem.
I read, the new kernel has a lot of audio patches on board. Maybe this will help....

The problem here is, that no one else has your DTS issue. So I am not sure what to do here.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2016-10-16, 15:43)Superbert Wrote: Hi Millhouse,
i tested brave all of your new releases, no one fixed my DTS problem.
I read, the new kernel has a lot of audio patches on board. Maybe this will help....

I'm really not sure, did you also test the OpenELEC builds?

You've said you have working DTS with ci321 with 7.0.2, which is based on the 4.4.x kernel and Kodi 16. All of the builds in this thread are based on Kodi 17, and only the earliest builds are based on 4.4.x. This might mean testing the older OpenELEC builds, as this includes my last Kodi 16 build based on Kodi 16 Beta 3: #1201. If that build has working DTS, then start working forwards through those OpenELEC builds until you no longer have working DTS.

If you've tested those OpenELEC builds already, and none of them are working, then I can't explain that.

I missed your post with screenshot settings - thanks for that. I assume you have "Player > Sync playback to display" disabled?

Assuming it's not a build related issue, maybe it's some sort of EDID issue...?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
For DTS - edid does not play a role. It's just 48 khz / 2 channel.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
It´s crazy in all other builds i have tested every situation.
Only in #1015 i left Player > Sync playback to display, enabled.

Now with diabled DTS works again.

Thank you very much for your patience.
:-( - just read the description of it, it will tell you, that it disabled PT.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2016-10-16, 17:50)fritsch Wrote: :-( - just read the description of it, it will tell you, that it disabled PT.

Entschuldige, dass ich nicht unfehlbar bin....
Sigh still Black screen after video stop

##############################################
# LibreELEC #
# http://libreelec.tv #
##############################################

LibreELEC (community) Version: devel-201610160239
17-#1015-ged2f577
LibreELEC git: ed2f5777aa656ef736fb870fa51a9058fa
83ba3a
LibreELEC:~ # cat /storage/.kodi/temp/kodi.log |
pastebinit
http://sprunge.us/JTgQ
LibreELEC:~ #
LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/gEjH
LibreELEC:~ #
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/jCjb
LibreELEC:~ #
LibreELEC:~ # cat /var/log/Xorg.0.log | pastebini
t
http://sprunge.us/CdaU


Was solved after several months with kernel 4.7, now problem reappear

Am i the only One with this problem ?
(2016-10-16, 18:04)Superbert Wrote:
(2016-10-16, 17:50)fritsch Wrote: :-( - just read the description of it, it will tell you, that it disabled PT.

Entschuldige, dass ich nicht unfehlbar bin....

Passt schon.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2016-10-16, 18:04)Roby77 Wrote: Sigh still Black screen after video stop

##############################################
# LibreELEC #
# http://libreelec.tv #
##############################################

LibreELEC (community) Version: devel-201610160239
17-#1015-ged2f577
LibreELEC git: ed2f5777aa656ef736fb870fa51a9058fa
83ba3a
LibreELEC:~ # cat /storage/.kodi/temp/kodi.log |
pastebinit
http://sprunge.us/JTgQ
LibreELEC:~ #
LibreELEC:~ # dmesg | pastebinit
http://sprunge.us/gEjH
LibreELEC:~ #
LibreELEC:~ # journalctl -a | pastebinit
http://sprunge.us/jCjb
LibreELEC:~ #
LibreELEC:~ # cat /var/log/Xorg.0.log | pastebini
t
http://sprunge.us/CdaU


Was solved after several months with kernel 4.7, now problem reappear

Am i the only One with this problem ?


mmh maybe this time is not a kernel fault ?

Code:
17:58:09 10671.144531 T:140524019353664  NOTICE: Display resolution ADJUST : HDMI1: 1920x1080 @ 23.98Hz (24) (weight: 0.000)
17:58:09 10671.257812 T:140521811592960  NOTICE: CDVDVideoCodecFFmpeg::CDropControl: calculated diff time: 41727
17:58:58 10719.843750 T:140521811592960 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
17:58:58 10719.910156 T:140521302714112  NOTICE: COutput::OnStartup: Output Thread created
17:58:58 10719.958008 T:140521811592960 WARNING: CVideoSurfaces::ClearReference - surface invalid
17:58:58 10719.980469 T:140524019353664  NOTICE: VAAPI::Close
17:58:58 10719.982422 T:140523064518400  NOTICE: COutput::OnExit: Output Thread terminated
17:59:00 10722.587891 T:140523064518400  NOTICE: COutput::OnStartup: Output Thread created
17:59:00 10722.616211 T:140521811592960 WARNING: CVideoSurfaces::ClearReference - surface invalid
17:59:00 10722.641602 T:140524019353664  NOTICE: VAAPI::Close
17:59:00 10722.642578 T:140521302714112  NOTICE: COutput::OnExit: Output Thread terminated
17:59:43 10765.389648 T:140521811592960 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
17:59:43 10765.447266 T:140521302714112  NOTICE: COutput::OnStartup: Output Thread created
17:59:43 10765.495117 T:140521811592960 WARNING: CVideoSurfaces::ClearReference - surface invalid
17:59:43 10765.520508 T:140524019353664  NOTICE: VAAPI::Close
17:59:43 10765.522461 T:140523064518400  NOTICE: COutput::OnExit: Output Thread terminated
18:01:06 10847.891602 T:140524019353664  NOTICE: CVideoPlayer::CloseFile()
18:01:06 10847.892578 T:140524019353664  NOTICE: VideoPlayer: waiting for threads to exit
18:01:06 10847.900391 T:140521532028672  NOTICE: CVideoPlayer::OnExit()
18:01:06 10847.900391 T:140521532028672  NOTICE: Closing stream player 1
18:01:06 10847.900391 T:140521532028672  NOTICE: Waiting for audio thread to exit
18:01:06 10847.941406 T:140523028088576  NOTICE: thread end: CVideoPlayerAudio::OnExit()
18:01:06 10847.941406 T:140521532028672  NOTICE: Closing audio device
18:01:06 10847.995117 T:140521532028672  NOTICE: Deleting audio codec
18:01:06 10847.995117 T:140521532028672  NOTICE: Closing stream player 2
18:01:06 10847.995117 T:140521532028672  NOTICE: waiting for video thread to exit
18:01:06 10848.041992 T:140521811592960  NOTICE: thread end: video_thread
18:01:06 10848.043945 T:140521532028672  NOTICE: deleting video codec
18:01:06 10848.051758 T:140524019353664  NOTICE: VideoPlayer: finished waiting
18:01:06 10848.051758 T:140524019353664  NOTICE: VAAPI::Close
18:01:06 10848.053711 T:140521302714112  NOTICE: COutput::OnExit: Output Thread terminated
18:01:06 10848.065430 T:140524019353664  NOTICE: VAAPI::Close - closing decoder context
18:01:06 10848.090820 T:140524019353664  NOTICE: CWinSystemX11::SetFullScreen - calling xrandr
18:01:06 10848.227539 T:140524019353664  NOTICE: VideoPlayer: OnLostDisplay received
18:01:06 10848.227539 T:140524019353664 WARNING: CDVDMessageQueue(audio)::Put MSGQ_NOT_INITIALIZED
18:01:06 10848.227539 T:140524019353664 WARNING: CDVDMessageQueue(video)::Put MSGQ_NOT_INITIALIZED
18:01:07 10849.002930 T:140524019353664  NOTICE: CVideoPlayer::CloseFile()
18:01:07 10849.002930 T:140524019353664  NOTICE: VideoPlayer: waiting for threads to exit
18:01:07 10849.002930 T:140524019353664  NOTICE: VideoPlayer: finished waiting
18:01:07 10849.002930 T:140524019353664  NOTICE: CVideoPlayer::CloseFile()
18:01:07 10849.003906 T:140524019353664  NOTICE: VideoPlayer: waiting for threads to exit
18:01:07 10849.003906 T:140524019353664  NOTICE: VideoPlayer: finished waiting
New LibreELEC.tv Krypton build #1016: Generic
(Supercedes previous build)

Code:
# uname -a
Linux NUC 4.8.1 #1 SMP Sun Oct 16 22:58:18 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161016225659-#1016-g15c3a1c [Build #1016]

# Kodi version
23:05:35   5.705308 T:140152034297920  NOTICE: Starting Kodi (17.0-BETA4 Git:e1d0050). Platform: Linux x86 64-bit

Based on tip of LibreELEC.tv master (15c3a1cb, changelog) and tip of XBMC master (e1d00503, changelog) with the following modifications: Build Highlights:
  1. openssh: UsePrivilegeSeparation/StrictModes not needed
  2. Fix cross-linked updates
Build Details:
  1. LibreELEC.tv:
    • llvm: build llvm-tblgen for host and use it for target (PR:838, 1 commit, 1 file changed)
    • emby: update to 3.0.8100 (PR:835, 2 commits, 3 files changed)
    • scripts/create_addon: add changelog to new "news" item (PR:836, 1 commit, 5 files changed)
    • openssh: UsePrivilegeSeparation/StrictModes not needed (PR:844, 1 commit, 4 files changed)
    • sqlite: update to sqlite-autoconf-3150000 (PR:843, 1 commit, 1 file changed)
  2. XBMC:
    • VideoPlayer: ffmpeg - use codec aspect ratio for stereo modes (PR:10708, 1 commit, 1 file changed)
    • remove last references to confluence (PR:10712, 2 commits, 15 files changed)
    • DVDDemuxFFmpeg: Read RIFF tags in order to detect language (PR:10687, 1 commit, 1 file changed)
    • [win32] extend UWP with capabilities and file associations (PR:10710, 1 commit, 1 file changed)
    • [doxygen] Add revision when API was changed or expanded (PR:10715, 1 commit, 7 files changed)
    • [gui] pictures: only show "info" context menu button when item isPict… (PR:10702, 1 commit, 1 file changed)
    • configure: fix aarch64 builds (PR:10713, 1 commit, 1 file changed)
    • [Texture][FIX] Prevent an access violation in CFFmpegImage:Big GrinecodeFra… (PR:10704, 1 commit, 2 files changed)
    • [python] - allow detailedmode for xbmcgui.Dialog().select() / multiselect() (PR:10586, 1 commit, 2 files changed)
  3. peripheral.joystick:
    • Fix return type in AnomalousTrigger.h (25c12ee7)
  4. pvr.nextpvr:
    • Fixed recording/timers refresh issue (PR:52, 1 commit, 4 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [pkg] PR:34: system update - fix cross-device linking (service.libreelec.settings)
    • Added: [pkg] PR:10714: AESinkAUDIOTrack: Don't false alarm with m_offset
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-16, 15:02)Milhouse Wrote: @artur9 the cross-device update issue will be fixed in tonight's build, but you'll still need to perform a manual update to get on to #1016. Once you are on #1016 you should be able to update normally using the LibreELEC Settings add-on.

Thanks so much. I didn't expect such a quick turnaround as it was a bit of a self-inflicted problem. Thanks again!
BTW, I noticed after I did the last update (20161016023917) that all my hardware acceleration settings had been turned off. Was that intentional at some point?

In any case, I turned them all back on and even a problematic video I had previously now works well. Great job!
Please use the build codes when discussing releases - 20161016023917 is #1015 (and doesn't include the fix for cross-linked updates).

I wouldn't have expected your acceleration settings to be reset when upgrading from #0925, are you sure they were the only settings to be reset? If guisettings.xml ever becomes corrupted then it will be recreated with default settings.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Update from #1015 to #1016 sets all skin settings to standard, the guisetting remains untouched.
(2016-10-17, 08:29)pacoma2610 Wrote: Update from #1015 to #1016 sets all skin settings to standard

My settings level is set to Expert.

I've just booted into #1014, changed a setting and ensured it was saved (ie. guisettings.xml updated).
I then booted into #1015, settings level is still Expert.
Finally booted into #1016, and the settings level remains Expert, so I'm not able to reproduce here.

(2016-10-17, 08:29)pacoma2610 Wrote: the guisetting remains untouched.

The settings level is stored in guisettings.xml (general > /settinglevel) so if you see the level as Standard in the GUI but your guisettings.xml has a value of 0 (Basic), 2 (Advanced) or 3 (Expert) then there's a problem with the skin, or something is really screwed up.

Are you testing with stock Estuary? If not, then it might be a skin issue (contact your skin maintainer).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 157
  • 158
  • 159(current)
  • 160
  • 161
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111