•   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 74
  •   
  Thread Closed
[REQUEST] BBC iPlayer (Video) Plugin or Script?
marlboroman1 Wrote:maybe Its me but I couldn't find a download from your linkHuh

Whoops, fixed it Smile

marlboroman1 Wrote:sorry I didn't notice it was a svn pull down Blush

I'm just off the ball a bit at the moment. Here's the zip:
http://xbmc-iplayer.googlecode.com/svn/t...plugin.zip
@johnsto

the end of my log looks like this:
Code:
11:20:04 M: 40849408   ERROR: DNS lookup for EXPERIEN-CCAB05 failed: 11001
11:20:09 M: 24305664  NOTICE: Display resolution AUTO : PAL 16:9 (7)
11:41:06 M: 39559168  NOTICE: DVDPlayer: Opening: rtmp://84.53.134.86:1935/ondemand?_fcs_vhost=cp41752.edgefcs.net&auth=daEdPaPaYd7bzd1bma6bObHcxb_bCb0ajda-bi1Is6-cCp-CnmDAqFoKEqFpwK&aifp=v001&slist=secure/b000dn7jj-streaming91745686
11:41:06 M: 39559168 WARNING: CDVDMessageQueue::Put MSGQ_NOT_INITIALIZED
11:41:06 M: 39034880  NOTICE: Creating InputStream
11:41:06 M: 38506496  NOTICE: Creating Demuxer

The Stream seems to start and I can see loads of HDD & Lan activity on the Xbox Mod but nothing happens.

Would you need the detailed log being turned on as Box is non responsive after above.
johnsto Wrote:Ok, just managed to commit a fix, please try the latest SVN plugin release:
http://xbmc-iplayer.googlecode.com/svn/t...plugin.zip

That was fast, thank you. I now get the lists of channels and programmes - though as you say 0x16 errors when I try to watch anything.
@johnsto

same here now with detailed Log on:

http://www.pt-1.net/xbox/xbmc_12_10_21_09_2008.log

Code:
12:04:48 M: 32915456   DEBUG: CDVDDemuxFFmpeg::Open - av_find_stream_info starting
12:04:48 M: 32407552   ERROR: ffmpeg: [flv] Bad picture start code
12:04:48 M: 32407552   ERROR: ffmpeg: [flv] header damaged
12:04:48 M: 32407552   ERROR: ffmpeg: [flv] Bad picture start code
12:04:48 M: 32407552   ERROR: ffmpeg: [flv] header damaged
12:04:49 M: 32370688   ERROR: ffmpeg: [flv] Bad picture start code
12:04:49 M: 32276480   ERROR: ffmpeg: [flv] header damaged
12:04:49 M: 32264192   DEBUG: unknown packet type received: 0x16
12:04:50 M: 32194560   DEBUG: .\Platinum\Source\Core\PltCtrlPoint.cpp(909): [platinum.core.ctrlpoint] 1221995090:221 [PLT_CtrlPoint::ProcessGetSCPDResponse] SEVERE: Bad SCPD response
12:04:50 M: 32260096   DEBUG: unknown packet type received: 0x16

and ongoing
has any one been able to apply this patch

http://trac.xbmc.org/ticket/4905

if it works it could all come together Big Grin
In an earlier post I was asking about the 'high quality' streams offered by the real iPlayer. beebhack suggests it's a higher-res H264 stream still delivered over RTMP (rather than the vp6 or spark encodings). I'd love to see this working on XBMC as they have a noticibly better picture quality compared to the rtmp/vp6 streams. However, I haven't managed to connect successfully to play one of these streams - does anyone know more about how these work?

The rtmp/h264 streams come from Level3 instead of Akamai servers. Packet-sniffing iPlayer connecting to a high-quality stream shows a few differences:
  • The Akamai server IP is fetched from http://[server]/fcs/ident (returning XML). The Level3 server IP is instead fetched from http://[server]/fcs/ident2 (returning plain text).
  • The Akamai servers accept a connection to 'app'='ondemand'. The Level3 servers return 'unknown application' for 'ondemand'. iPlayer is using 'app'='bbciplayertok'. This means the URL for a stream should be something like rtmp://[server]:1935/bbciplayertok/...
  • Akamai servers appear to read the auth value from the 'tcUrl' parameter in the RTMP connect packet. This is working as we send the complete URL we're playing as the value of 'tcUrl'
    For Level3 servers the real iPlayer doesn't send any URL parameters in the 'tcUrl' param of the RTMP connect packet. There does seem to be a couple of extra (unnamed) parameters at the end of the connect packet however, which look like (bool)<true> and (string)<the-auth-value>. I've tried hacking these in to the connect packet sent by XBMC, but got no joy - the server sends an error reply and closes the connection.

Edit 2009-03-19 :
This no longer seems to be true. In mediaselecter output such as http://www.bbc.co.uk/mediaselector/4/mti...m/b00ftfmb there are H264 796kbit streams available from Level3 servers, but these now have a long authString such as:
authString="token=c3RhcnRfdGltZT0yMDA5MDMxODExMjIyNCZlbmRfdGltZT0yMDA5MDMxOTExMjIyNCZkaWdlc3Q9MTFmMmY4NWUyMDQ4MTZkYjJlZjY0NDhiMWFlNDlkYWU="
and this does not need to be added to the connect packet to allow playback.
Excellent work Frosty, rtmp is now here for xbmc for xbox.
with the patch applied I get this log on Windows XP SP2 32bit it freezes and stops responding

http://pastebin.com/m10a4767f

haven't been able to get the patch applied to the trunk to test on xbox
marlboroman1 Wrote:with the patch applied I get this log on Windows XP SP2 32bit it freezes and stops responding

http://pastebin.com/m10a4767f

haven't been able to get the patch applied to the trunk to test on xbox

Looks like you're running an old version. Try this one:
http://xbmc-iplayer.googlecode.com/svn/t...plugin.zip
i think I was using the latest but i downloaded the one you linked to to make sure and its exhibiting the same behaver at least visually

http://pastebin.com/m103d642e
marlboroman1 Wrote:i think I was using the latest but i downloaded the one you linked to to make sure and its exhibiting the same behaver at least visually

Err, are you sure you downloaded and installed it correctly? The error is the same (can't find BeautifulSoup.py); the library you're missing would be there if you extracted the plugin to the right location.
johnsto Wrote:Err, are you sure you downloaded and installed it correctly? The error is the same (can't find BeautifulSoup.py); the library you're missing would be there if you extracted the plugin to the right location.

I deleted the old plugin and extracted the new one to the same location I checked the install directory for BeautifulSoup.py and BeautifulSoup.pyo are both present
@C:\Program Files\XBMC\plugins\video\xbmc-iplayer-plugin

I wonder why they are not being used
marlboroman1 Wrote:I deleted the old plugin and extracted the new one to the same location I checked the install directory for BeautifulSoup.py and BeautifulSoup.pyo are both present
@C:\Program Files\XBMC\plugins\video\xbmc-iplayer-plugin

I wonder why they are not being used

The log says you're still using this one:

C:\Program Files\XBMC\plugins\video\xbmc-iplayer-plugin-200809102132\default.py

You may need to delete the existing source (it's using the script in 'xbmc-iplayer-plugin-200809102132') and then add it again (using the script in 'xbmc-iplayer-plugin')
Thumbs Up 
johnsto Wrote:The log says you're still using this one:

C:\Program Files\XBMC\plugins\video\xbmc-iplayer-plugin-200809102132\default.py

You may need to delete the existing source (it's using the script in 'xbmc-iplayer-plugin-200809102132') and then add it again (using the script in 'xbmc-iplayer-plugin')

That is really strange as that revision had been deleted some time ago as had the source. is anything from the script stored in XBMC application data folderHuh

After some unrelated problems with building XBMC with patch included. I did a full fresh install of XBMC and The iplayer plugin work great now on windows. I really hope the patch is added to the xbox svn soon. In the mean time if any one knows how to port it over please share

thanks for all the effort your putting in to make this workSmile
Ok, Tried the current SVN on the current T3CH release 'T3CH XBMC 2008-09-19 SVN rev15640-BETA1'.
The script gets to the point of trying to play the file through DVDplayer, then freezes up as it creates the demuxer.

08:22:57 M: 56426496 NOTICE: -----------------------------------------------------------------------
08:22:57 M: 56406016 NOTICE: Starting XBMC, Platform: Xbox. Built on Sep 20 2008
08:22:57 M: 56406016 NOTICE: Q is mapped to: F:\Apps\XBMC
08:22:57 M: 56406016 NOTICE: The executable running is: F:\Apps\XBMC\default.xbe
08:22:57 M: 56406016 NOTICE: Log File is located: Q:\xbmc.log
08:22:57 M: 56406016 NOTICE: -----------------------------------------------------------------------
08:22:57 M: 56406016 NOTICE: Unmapped drive T
08:22:57 M: 56406016 NOTICE: Mapping drive T to Harddisk0\Partition6\Apps\XBMC\UserData
08:22:57 M: 56406016 NOTICE: Setup DirectX
08:22:58 M: 56381440 NOTICE: Mapping drive C to Harddisk0\Partition2
08:22:58 M: 56381440 NOTICE: Mapping drive E to Harddisk0\Partition1
08:22:58 M: 56381440 NOTICE: Unmapped drive D
08:22:58 M: 56381440 NOTICE: Mapping drive D to Cdrom0
08:22:58 M: 56381440 NOTICE: Mapping drive F to Harddisk0\Partition6
08:22:58 M: 56381440 NOTICE: Mapping drive X to Harddisk0\Partition3
08:22:58 M: 56381440 NOTICE: Mapping drive Y to Harddisk0\Partition4
08:22:58 M: 56381440 NOTICE: Unmapped drive Z
08:22:58 M: 56381440 NOTICE: Mapping drive Z to Harddisk0\Partition5
08:22:58 M: 56381440 NOTICE: load settings...
08:22:58 M: 56381440 NOTICE: Mapping drive P to Harddisk0\Partition6\Apps\XBMC\UserData
08:22:58 M: 56381440 NOTICE: loading T:\guisettings.xml
08:22:58 M: 56184832 NOTICE: Getting hardware information now...
08:22:58 M: 56184832 NOTICE: Checking resolution 10
08:22:58 M: 56184832 NOTICE: Setting autoresolution mode 7
08:22:58 M: 56184832 NOTICE: Per AV pack settings are off
08:22:58 M: 56328192 NOTICE: q:\UserData\sources.xml
08:22:59 M: 50016256 NOTICE: Checking the Date!
08:22:59 M: 50016256 NOTICE: start dvd mediatype detection
08:22:59 M: 49950720 NOTICE: initializing playlistplayer
08:22:59 M: 49950720 NOTICE: DONE initializing playlistplayer
08:22:59 M: 49942528 NOTICE: load default skin:[MediaStream]
08:23:00 M: 47173632 NOTICE: Unmapped drive D
08:23:00 M: 47030272 NOTICE: Mapping drive D to Cdrom0
08:23:00 M: 45109248 ERROR: Window Translator: Can't find window settingscategory
08:23:00 M: 45088768 ERROR: Error evaluating boolean expression !Window.Previous(0) + !Window.Previous(SettingsCategory) + !Window.Previous(1001) + !Window.Previous(130) + !Window.Previous(34)
08:23:01 M: 43782144 WARNING: use dashboard
08:23:01 M: 43462656 NOTICE: initialize done
08:23:01 M: 43462656 NOTICE: Running the application...
08:23:01 M: 36691968 NOTICE: XBFileZilla: Starting...
08:23:01 M: 36626432 NOTICE: ES: Starting event server
08:23:01 M: 35565568 NOTICE: ES: Starting UDP Event server on 0.0.0.0:9777
08:23:01 M: 35565568 NOTICE: UDP: Listening on port 9777
08:23:01 M: 34852864 NOTICE: XBFileZilla: Started
08:23:21 M: 28147712 ERROR: Error Getting Directory (\)
08:25:38 M: 32514048 NOTICE: DVDPlayer: Opening: rtmp://213.123.84.228:1935/ondemand?_fcs_vhost=cp41752.edgefcs.net&auth=daEbYaHc9bkdla4cza6bzcKdhcjcHb5dVcG-bi2ER5-cCp-BnoFBowqGBtGswK&aifp=v001&slist=secure/b000dq8mr-streaming92354603
08:25:38 M: 32514048 WARNING: CDVDMessageQueue:Tongueut MSGQ_NOT_INITIALIZED
08:25:38 M: 31989760 NOTICE: Creating InputStream
08:25:38 M: 31457280 NOTICE: Creating Demuxer
  •   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 74
  •   
  Thread Closed
 
Thread Rating:
  • 7 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[REQUEST] BBC iPlayer (Video) Plugin or Script?57
This forum uses Lukasz Tkacz MyBB addons.