Alpha [BUG] German Keyboard Layout QWERTZ is not applied
#1
Bug 
Kodi 17.0 Alpha[master branch] German QWERTZ layout is not applied

Hi, i just finished building Kodi 17.0 Alpha on my banana pro [LeMaker.org] using master branch from GIT.
Build succeeded, launching succeeded. Configuration succeeded, except for the Keyboard Layout: Changing it to German QWERTZ does not work. Typing Y on the keyboard prints Z and vice versa. So the keyboard layout is not changed at all and remains English QWERTY. I also tried to dpkg-reconfigure keyboard-configuration setting up German layout and keys but it did not solve the problem. Maybe something is wrong with locale settings in Kodi?

How can I solve this? Is there any log message which might be helpful I can post here Huh

I must say the new UI is a bit uglier then the 16.1-Jarvis standard one. And I still can not configure wifi even enabled on OS level. The UI response time is worse then 16.1-Jarvis one. I don't like that Add-Ons must be installed from one place and not from Video, Music etc. sections directly using [Get more...] button anymore.
I would change back to 16.1-Jarvis but this means another 3 Hours of rebuild time Confused Sleepy
I maybe setup a cross-compile enviornment on my laptop which has an i5 CPU. This would decrease the build time but I am afraid to break my current laptop OS installing wrong compilers in the wrong place Rolleyes
Reply
#2
Keyboard / Wifi are all OS settings. Kodi only influences the onscreen keyboard. Kodi is not the OS, but an application.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
I see. I tried 16.1-Jarvis with same settings and it worked well with German QWERTZ. Switching to 17.0 Alpha breaks it. Sad
Reply
#4
Sorry, to make sure. Do you have that problem when entering text in some Kodi window (e.g. Search Window) or on your Ubuntu system?
Reply
#5
I have bananian(distro for banana pro). Typing in text into tty works with QWERTZ. Launching Kodi in standalone mode with X11 support and then typing into e.g. the search field of the YouTube Add-On(even QWERTZ is active layout) the Y key is printed as Z and vice versa. So its only an X11/Kodi-App problem. Not on the OS level. I had such problem using lightdm, a workaround was to use "setxkbmap de" as start script and then it worked in lightdm using QWERTZ.
Reply
#6
OK, no, cannot help you then. I have had a problem with similar symptoms on Milhouse's LE builds, but fritsch thinks it is of different nature, and he is usually right... ;-)
Reply
#7
Ok. I also have the Kore App on my Smartphone installed. With that app its also possible to control kodi and QWERTZ is working on my smartphone so this is my workaround. Big Grin
Reply
#8
Fritsch WAS right! I have just been stupid, for you there is still hope. That's a good thing... ;-)
Reply
#9
Ok, so tell me more. Smile How can I fix it? Is it source code change related or XML configuration related? I just looked on changes on github but I can't figure out which source code file is responsible for keymaps... :~|
Reply
#10
Change /etc/default/keyboard

and configure it accordingly.

could look like:
Code:
# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS=""

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz
BACKSPACE="guess"

To emphasize on this: kodi has nothing to do with your issue but your not properly configured system.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#11
My /etc/default/keyboard:
Code:
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="logicd"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS="lv3:ralt_switch,compose:lwin"

BACKSPACE="guess"

But this configuration file was unchanged since 16.1-Jarvis. And it worked with 16.1-Jarvis.
Reply
#12
I think it is X server related. See this thread https://bbs.archlinux.org/viewtopic.php?id=100794. I try to fix it using ~/.xinitrc script setting the keyboard map explicit to German.
Reply
#13
I fixed it. I start up my box with no changes to configs of X11 etc. Running the command setxkbmap de -display :0 where kodi runs on display 0 and it works. How can I run this command at boot time AFTER kodi has started?
Reply
#14
Found this one. Maybe solved now also on boot time -> 148508 (thread)
Reply
#15
Solved added autoexec.py to ~/.kodi/userdata/ directory. Make it executable using chmod +x added the following code:
Code:
import os
os.system("setxkbmap de -display :0")
Works like a charm. Smile
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[BUG] German Keyboard Layout QWERTZ is not applied00