Upgrade to Python 2.7.11
#1
Hi,

I just downloaded the latest release of Kodi (16.1 Jarvis at the time of writing), it comes with Python 2.7.8.
This version of Python doesn't support SNI for HTTPS requests which means that many sites cannot be accessed (for reference, see http://urllib3.readthedocs.io/en/latest/...ingwarning ).
Is it in the plans to upgrade the embedded Python soon? Otherwise, would you consider it?
This is a minor version change so it should be a drop-in replacement. In fact I just dropped in 2.7.11 in my local instance and it all seems to work fine, haven't found any issues so far.

Thanks
Reply
#2
It's done for v17
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#3
Brilliant, thanks!
Reply
#4
(2016-05-02, 12:31)Martijn Wrote: It's done for v17
its not option for million devices that still use android 4.4
Reply
#5
(2017-04-24, 00:21)ewwink Wrote:
(2016-05-02, 12:31)Martijn Wrote: It's done for v17
its not option for million devices that still use android 4.4
Not our problem
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#6
So someone is making tons of money from selling boxes
Each time a new version of Kodi is launched thousands of boxes get outdated
Reply
#7
(2017-05-17, 22:08)africanbrit Wrote: So someone is making tons of money from selling boxes
Each time a new version of Kodi is launched thousands of boxes get outdated

don't buy crap boxes that never update their firmware
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Upgrade to Python 2.7.1100