Thread Rating:
  • 0 Vote(s) - 0 Average
Cannot install kodi ubuntu 16 amd64
#1
Hi All,

I cannot install kodi on ubuntu 14, 15 or 16, I have tried all and come up with the same problem. At present I am very fustrated having spent 2 days on this and multiple installs.

I am using vanilla installs of ubuntu 14, 15, 16 amd64 installed to USB using mulipule methods of the usb install. Once installed I do the following from a lot of research:

sudo apt-get update
sudo apt-get upgrade
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi

At which point it always errors with dependancy issues. I will post the dependancy issues on my next try.

Could someone provide me with the proven steps to install kodi on linux.

As a last comment, this should not be this hard and in now days times of fast and automated systems - I cannot explain how bad wasting this time is for software and linux adoption.
Reply
#2
I forgot to mention, I also tried kodibuntu, however it booted once - then when I exited came up with errors. I rebooted and it would never boot up again. So I gave up on that idea. Also in the procedure I posted above, I have tried the command "sudo apt-get install software-properties-common" but this is always up to date.
Reply
#3
Below is the output of the dependency problems, note this is on a standard laptop (with intel processor and was running windows 8 beforehand):

[email protected]:~$ sudo add-apt-repository ppa:team-xbmc/ppa

More info: https://launchpad.net/~team-xbmc/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpr9yvtveo/secring.gpg' created
gpg: keyring `/tmp/tmpr9yvtveo/pubring.gpg' created
gpg: requesting key 91E7EE5E from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpr9yvtveo/trustdb.gpg: trustdb created
gpg: key 91E7EE5E: public key "Launchpad PPA for XBMC for Linux" imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
[email protected]:~$ sudo apt-get update
Ign:1 cdrom://Ubuntu 16.04 LTS _Xenial Xerus_ - Release i386 (20160420.1) xenial InRelease
Hit:2 cdrom://Ubuntu 16.04 LTS _Xenial Xerus_ - Release i386 (20160420.1) xenial Release
Get:4 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease [17.5 kB]
Hit:5 http://archive.ubuntu.com/ubuntu xenial InRelease
Hit:6 http://security.ubuntu.com/ubuntu xenial-security InRelease
Get:7 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [94.5 kB]
Get:8 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial/main i386 Packages [14.2 kB]
Get:9 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial/main Translation-en [4,308 B]
Fetched 131 kB in 1s (66.7 kB/s)
Reading package lists... Done
[email protected]:~$ sudo apt-get install kodi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi : Depends: kodi-bin (>= 2:16.1~git20160425.1001-final-0xenial) but it is not going to be installed
Depends: kodi-bin (< 2:16.1~git20160425.1001-final-0xenial.1~) but it is not going to be installed
Depends: mesa-utils but it is not installable
Depends: python-bluez but it is not installable or
python-lightblue but it is not installable
Depends: python-imaging but it is not installable
Depends: libmad0 but it is not installable
Depends: libass5 but it is not installable or
libass4 but it is not installable
Depends: libnfs8 but it is not installable or
libnfs4 but it is not installable or
libnfs1 but it is not installable
Depends: libbluray1 but it is not installable
Depends: libaacs0 but it is not installable
Recommends: libvdpau1 but it is not going to be installed
Recommends: libva-intel-vaapi-driver but it is not installable or
i965-va-driver but it is not installable
Recommends: libva1 but it is not installable
E: Unable to correct problems, you have held broken packages.
[email protected]:~$ sudo apt-get install kodi-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-bin : Depends: libmicrohttpd10 (>= 0.9.20) but it is not installable
Depends: libsdl2-2.0-0 (>= 2.0.4) but it is not installable
Depends: libva-x11-1 (>= 1.0.3) but it is not installable
Depends: libva1 (>= 1.2.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
[email protected]:~$
Reply
#4
Read the first post in this thread http://forum.kodi.tv/showthread.php?tid=231955

It gives you the packages you need to install. but you can skip the nightly and fernetmenta. that is only if you want to start dabble in v17 alpha's of Kodi.
If my post helped you then there is a nice "Thank user" button on the bottom of the post.
Reply
#5
Hi Laric,

Thankyou for the help on getting kodi working. The post worked and that is great. Thanks to the kodi developers who made the post (even though it is for v17 which is why I would have never tried it).

Is it possible to have the website HOW-TO:Install_Kodi_for_Linux (wiki) updated?

As expressed above, one of my main reasons staying off linux systems is the difficulty for getting applications working compared to windows. Yet in my job I am quite able and willing to work with linux and console technologies were a vendor has a refined process. E.g Cisco/hp switches, vmware just to name a few. I believe this is where the linux community needs to improve.
Reply
#6
TL,DR: I'm trying (unsuccesfully) to install Kodi 16.1 on a new Ubuntu 16.04 LTS installation (running on an Intel NUC).



I have run these commands:

sudo apt install ppa-purge
sudo ppa-purge ppa:team-xbmc/ppa
sudo apt-add-repository ppa:team-xbmc/kodi-old
sudo apt update
sudo apt-get install kodi=2:16.1~git20160425.1001-final-0xenial kodi-bin=2:16.1~git20160425.1001-final-0xenial


When I run the last command (sudo apt-get install....), I get this output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kodi-bin : Depends: libcrossguid1 but it is not installable
E: Unable to correct problems, you have held broken packages.


When I run this command:

sudo apt-cache policy | grep team-xbmc

I get this output:

500 http://ppa.launchpad.net/team-xbmc/kodi-old/ubuntu xenial/main i386 Packages
release v=16.04,o=LP-PPA-team-xbmc-kodi-old,a=xenial,n=xenial,l=kodi-old-stable,c=main,b=i386
500 http://ppa.launchpad.net/team-xbmc/kodi-old/ubuntu xenial/main amd64 Packages
release v=16.04,o=LP-PPA-team-xbmc-kodi-old,a=xenial,n=xenial,l=kodi-old-stable,c=main,b=amd64



Running this command:

apt-cache showpkg kodi

Produces this output:

Package: kodi
Versions:
2:16.1~git20160425.1001-final-0xenial (/var/lib/apt/lists/ppa.launchpad.net_team-xbmc_kodi-old_ubuntu_dists_xenial_main_binary-amd64_Packages) (/var/lib/apt/lists/ppa.launchpad.net_team-xbmc_kodi-old_ubuntu_dists_xenial_main_binary-i386_Packages)
Description Language:
File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_kodi-old_ubuntu_dists_xenial_main_binary-amd64_Packages
MD5: 0e7e4c0691603796de3f6b71e9bd4d9d
Description Language: en
File: /var/lib/apt/lists/ppa.launchpad.net_team-xbmc_kodi-old_ubuntu_dists_xenial_main_i18n_Translation-en
MD5: 0e7e4c0691603796de3f6b71e9bd4d9d

15.2+dfsg1-3ubuntu1.1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-amd64_Packages) (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_xenial-security_universe_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_binary-amd64_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_binary-i386_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language: en
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_i18n_Translation-en
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-amd64_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-i386_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a

15.2+dfsg1-3ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_binary-amd64_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_binary-i386_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language: en
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial_universe_i18n_Translation-en
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-amd64_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a
Description Language:
File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_xenial-updates_universe_binary-i386_Packages
MD5: 8cbb7a58aa8f70442021b6474bb4487a


Reverse Depends:
kodi-pvr-hts,kodi 15.1+dfsg1-4
xbmc,kodi
kodi:i386,kodi
kodi-data,kodi 15.2~rc1+dfsg1-2~
kodi-data,kodi 15.2~rc1+dfsg1-2~
kodi:i386,kodi
multimedia-video,kodi
multimedia-players,kodi
multimedia-photography,kodi
multimedia-broadcasting,kodi
kodi-pvr-vdr-vnsi,kodi
kodi-pvr-vdr-vnsi,kodi 15.1+dfsg1-4
kodi-pvr-hts,kodi
kodi-data,kodi 15.2~rc1+dfsg1-2~
kodi-data,kodi 15.2~rc1+dfsg1-2~
Dependencies:
2:16.1~git20160425.1001-final-0xenial - kodi-bin (2 2:16.1~git20160425.1001-final-0xenial) kodi-bin (3 2:16.1~git20160425.1001-final-0xenial.1~) curl (0 (null))libcurl3 (0 (null)) mesa-utils (0 (null)) x11-utils (0 (null)) fonts-liberation(16 (null)) ttf-liberation (0 (null)) fonts-dejavu-core (16 (null)) ttf-dejavu-core (0 (null)) python-bluez (16 (null)) python-lightblue (0 (null)) python-imaging (0 (null)) python-simplejson (0 (null)) libmad0 (0 (null)) libass5 (16 (null)) libass4 (0 (null)) libgif7 (16 (null)) libgif5 (0 (null)) libssh-4 (16 (null)) libssh2-1 (0 (null)) libnfs8 (16 (null)) libnfs4 (16 (null)) libnfs1 (0 (null)) libbluray1 (0 (null)) libshairplay0 (0 (null)) libvorbisfile3 (0 (null)) libaacs0 (0 (null)) libcec3 (0 (null)) librtmp1 (16 (null)) librtmp0 (0 (null)) libgnutls30 (16 (null)) libgnutls-deb0-28 (16 (null)) libgnutls28 (16 (null)) libgnutls26 (0 (null)) libxslt1.1 (0 (null)) libyajl2 (0 (null)) xbmc (3 2:14.0~git20141019) xbmc:i386 (3 2:14.0~git20141019) xbmc-data (0 (null)) xbmc-skin-confluence (0 (null)) xbmc-standalone (0 (null)) libvdpau1 (0 (null)) libva-intel-vaapi-driver (16 (null)) i965-va-driver (0 (null)) libva1 (0 (null)) kodi-pvr-mythtv (0(null)) kodi-pvr-vuplus (0 (null)) kodi-pvr-vdr-vnsi (0 (null)) kodi-pvr-njoy (0(null)) kodi-pvr-nextpvr (0 (null)) kodi-pvr-mediaportal-tvserver (0 (null)) kodi-pvr-tvheadend-hts (0 (null)) kodi-pvr-dvbviewer (0 (null)) kodi-pvr-argustv (0(null)) kodi-pvr-iptvsimple (0 (null)) kodi-audioencoder-vorbis (0 (null)) kodi-audioencoder-flac (0 (null)) kodi-audioencoder-lame (0 (null)) xbmc (3 2:14.0~git20141019) xbmc:i386 (3 2:14.0~git20141019) xbmc-data (0 (null)) xbmc-skin-confluence (0 (null)) xbmc-standalone (0 (null)) kodi:i386 (32 (null))
15.2+dfsg1-3ubuntu1.1 - kodi-bin (2 15.2+dfsg1-3ubuntu1.1) kodi-bin (3 15.2+dfsg1-3ubuntu1.1.1~) kodi-data (0 (null)) xbmc (3 2:13.2+dfsg1-5~) xbmc:i386 (3 2:13.2+dfsg1-5~) xbmc (3 2:13.2+dfsg1-5~) xbmc:i386 (3 2:13.2+dfsg1-5~) kodi:i386 (32 (null))
15.2+dfsg1-3ubuntu1 - kodi-bin (2 15.2+dfsg1-3ubuntu1) kodi-bin (3 15.2+dfsg1-3ubuntu1.1~) kodi-data (0 (null)) xbmc (3 2:13.2+dfsg1-5~) xbmc (3 2:13.2+dfsg1-5~) kodi:i386 (32 (null)) xbmc:i386 (3 2:13.2+dfsg1-5~) xbmc:i386 (3 2:13.2+dfsg1-5~)
Provides:
2:16.1~git20160425.1001-final-0xenial - xbmc-standalone (= ) xbmc-skin-confluence (= ) xbmc-data (= ) xbmc (= ) kodi-standalone (= ) kodi-skin-confluence (= ) kodi-data (= )
15.2+dfsg1-3ubuntu1.1 -
15.2+dfsg1-3ubuntu1 -
Reverse Provides:



What am I doing wrong? My goal is to run Kodi 16.1 (and prevent any automatic updates that would update my Kodi to 17.x, 18.x, etc....
Reply
#7
Use the https://launchpad.net/~team-xbmc/+archiv...u/kodi-old ppa, please
"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
Reply
#8
(2017-06-18, 22:04)fritsch Wrote: Use the https://launchpad.net/~team-xbmc/+archiv...u/kodi-old ppa, please

I must be incredibly dense, because when I click on that link (https://launchpad.net/~team-xbmc/+archiv...u/kodi-old ppa) I see a a page that tells me to use:

sudo add-apt-repository ppa:team-xbmc/kodi-old
Image


However, that is the command that I'm already using. I must be missing something.
Reply
#9
please install pastebinit on your system in case it´s not done already:

Code:
sudo apt-get install pastebinit

After that please get us the URL you will get from that command:

Code:
ls -al /etc/apt/sources.list.d/ | pastebinit

Get us the following as well:

Code:
apt-cache policy kodi | pastebinit
and
Code:
apt-cache policy kodi-bin | pastebinit
and
Code:
apt-cache policy libcrossguid* | pastebinit
Reply
#10
Mmh :-) Imisread the original post.

sudo apt-get install kodi kodi-bin should work fine then, without a version if ppa has built everything correctly.
"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
Reply
#11
https://launchpad.net/~team-xbmc/+archiv...hive-extra was missing, fixed now
Reply



Cannot install kodi ubuntu 16 amd6400