Help: Cannot view recording in progress
#1
Hi

Since moving to MediaPortal as my PVR backend I have the following problem. Help appreciated.

If I set a show to record, then attempt to access/view the recording while it's in progress, it will not play.

No error message is shown, Kodi simply does not open the file.

I can tune to the live stream and watch that. Once the recoding is completed, it will play back OK.

It's just that while a show is recording, the recording will not play. We like to record shows and jump into them after 20 mins to allow us ff ads. This issues prevents that.

Any ideas?
Reply
#2
No idea. It works fine for me. You need to post logs, as we don't know what version of Kodi you are using, what version of the plugin, etc.
Reply
#3
I've exactly the same problem as ptrmee.
I set a timer in the epg guide and if i select that show it directly starts with the live stream.

After the record is done I can watch the file over the recordings.

Kodi 16.1 / Windows 7 / Titan Skin
external MP TV Server 1.15
last MP PVR Plugin
Reply
#4
Same problem here. I've also created an issue on github for this.
Reply
#5
(2016-05-13, 23:35)mcelliott Wrote: No idea. It works fine for me. You need to post logs, as we don't know what version of Kodi you are using, what version of the plugin, etc.
What versions of TVServer, plugin, addon and Kodi (Windows or Linux based) do you use? Singleseat or Multiseat? TSReader or ffmpeg in addon settings? Network path or local path in recording settings of TVServer?
Reply
#6
Without detailed information, I cannot debug this issue. It is supposed to work and it works fine here, so there must be particular details that I'm missing.

What I need:
1) a Kodi debug log (a full log, not a snippet)
2) Your TVServer version & TVServerKodi plugin version
3) Single seat or multi seat setup?
4) Is your ongoing recording part of a series timer or a single recording?

I can't promise that I can fix this soon, since I'm unable to build Kodi at the moment due to the recent switch to cmake for building Kodi. The Kodi wiki is not yet up-to-date with build instruction.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
#7
Give me a half hour...
Reply
#8
(2016-08-22, 21:55)margro Wrote: Without detailed information, I cannot debug this issue. It is supposed to work and it works fine here, so there must be particular details that I'm missing.

What I need:
1) a Kodi debug log (a full log, not a snippet)
2) Your TVServer version & TVServerKodi plugin version
3) Single seat or multi seat setup?
4) Is your ongoing recording part of a series timer or a single recording?

I can't promise that I can fix this soon, since I'm unable to build Kodi at the moment due to the recent switch to cmake for building Kodi. The Kodi wiki is not yet up-to-date with build instruction.

Okay here's a first debug log: http://pastebin.com/download/sjcs26ty
This is a single seat setup with Kodi 16.1, TVServer 1.12.0 and TVServerKodi plugin 1.10.0.128
In the logs you'll find two ongoing recordings i've tried. "Castle" as a one time schedule and "Gotham" as part of a series timer. Both were not playable.

The same happens for me with TVServer 1.15.0 and TVServerKodi plugin 1.15.0.134.
It also makes no difference here, if Kodi is on the TVServer machine or another pc.
If you also need logs of this, just say a word.

Side note: If i change the streaming method of the pvr addon to ffmpeg, it is working as expected.
Reply
#9
(2016-08-22, 23:31)pünktchen Wrote: Side note: If i change the streaming method of the pvr addon to ffmpeg, it is working as expected.

Even that does not work for me.
Reply
#10
(2016-08-22, 23:31)pünktchen Wrote:
(2016-08-22, 21:55)margro Wrote: Without detailed information, I cannot debug this issue. It is supposed to work and it works fine here, so there must be particular details that I'm missing.

What I need:
1) a Kodi debug log (a full log, not a snippet)
2) Your TVServer version & TVServerKodi plugin version
3) Single seat or multi seat setup?
4) Is your ongoing recording part of a series timer or a single recording?

I can't promise that I can fix this soon, since I'm unable to build Kodi at the moment due to the recent switch to cmake for building Kodi. The Kodi wiki is not yet up-to-date with build instruction.

Okay here's a first debug log: http://pastebin.com/download/sjcs26ty
This is a single seat setup with Kodi 16.1, TVServer 1.12.0 and TVServerKodi plugin 1.10.0.128
In the logs you'll find two ongoing recordings i've tried. "Castle" as a one time schedule and "Gotham" as part of a series timer. Both were not playable.

The same happens for me with TVServer 1.15.0 and TVServerKodi plugin 1.15.0.134.
It also makes no difference here, if Kodi is on the TVServer machine or another pc.
If you also need logs of this, just say a word.

Side note: If i change the streaming method of the pvr addon to ffmpeg, it is working as expected.
Switching in Kodi 17 b5 to ffmpeg with MP2 backend works fine for me. Thanks
Anyidea when this will be fixed for tsreader?
Reply
#11
Are there any news?

For me it does not work the way it works for Mediaportal (frontend) or TVH + Kodi.
I am planning a switch from a Windows- to a Linuxserer just to eliminate this annoying issue.

I've tested a lot.
Sundry versions of Kodi, the newest PVR-Plugin on server and client, all kinds of settings, ...   without success.
If anybody can show me a functional solution I kindly ask for the settings in detail.

Actually I want to avoid the switch from Windows to Linux. Never touch a running system (except above mentioned point).
Reply
#12
Are you using ffmpeg or rtsp streaming in the plugin?

If I use ffmpeg, it doesn't work. If I use rtsp, it does.
Reply
#13
I normally use TSReader.
If RTSP Stream is activated Kodi crashes every time when a channel will be selected.

Kodi PVR-addon settings:

Connection:
Mediaportal Hostname=<IP address of server>
Mediaportal Kodi plugin port=9596
Connect Timeout(s)=10
Windows user account (SMB)=User
Windows password (SMB)=<PW>

Playback:
Streaming Method=TSReader
Use RTSP streaming=Yes
Fast channel switching=No
Wait time after tuning a channel (ms)=0


MP TV-server seetings:
 - Plugins / TVServer Kodi
     - TCP Port 9596
     - Shares are green for recordings and timeshift (for each tuner)
       \\Server\MP TV-Aufnahmen
       \\Server\MP Timeshift

Log till crash / loading circle:
08:44:57.419 T:7624  NOTICE: VideoPlayer: Opening: pvr://channels/tv/Alle Kanäle/pvr.mediaportal.tvserver_1566.pvr
08:44:57.419 T:7624 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
08:44:57.421 T:7816  NOTICE: Creating InputStream
08:44:57.421 T:7816  NOTICE: AddOnLog: MediaPortal PVR Client: Open Live stream for channel uid=1566
08:44:58.065 T:7816  NOTICE: AddOnLog: MediaPortal PVR Client: Channel timeshift buffer: \\SERVER\MP Timeshift\live5-0.ts.tsbuffer
08:44:58.065 T:7816  NOTICE: AddOnLog: MediaPortal PVR Client: Creating a new TsReader...
08:44:58.065 T:7816  NOTICE: AddOnLog: MediaPortal PVR Client: TsReader open 'rtsp://192.168.0.100/stream5.0'
08:45:11.250 T:7624  NOTICE: VideoPlayer: waiting for threads to exit

Do I have to do any other settings on the server?

​​​​​​​Further I can see under "Manual Control" that the channel will be tuned.
Reply
#14
The default is NOT to use rtsp streaming.

Which version of Kodi are you now using?

Also, your log seems to be for tuning live TV, not for playing back a recording in progress.
Reply



Logout Mark Read Team Forum Stats Members Help
Help: Cannot view recording in progress0
This forum uses Lukasz Tkacz MyBB addons.