WMA Pro Audio Codec (Microsoft WMVHD/WVC1 Sound)?
#1
Question 
Hey there. I am trying to play a WMV 720p reencoded to an Xvid. Usually for my HD vids I play them in DVDPlayer since it seems to drop the least amount of frames. When I try and play any of those Iguana WMV releases on usenet on DVDPlayer I get no audio. There is audio on MPlayer but the frameskip is unwatchable. When I check the info at the top on MPlayer, it says Windows Media Audio 9 and I can hear it (choppy but still there). When I check the info on DVDPlayer, it switched between MP3, MP1 and various bitrates but no sound comes out. Is this a restriction on DVDPlayer or... Any help would be greatly appreciated.

*Will provide logs and/or more info if needed
Reply
#2
yes, dvdplayer have no support for binary codecs and hence your proprietary file wont play. use (somewhat more) free alternatives instead and you'll be fine.

and logs NEVER hurt.
Reply
#3
I think the original files were designed for use on the 360. The sound works in WMP but not even VLC. Well thank you Spiff, I guess I'll take a crash course in audio reencoding as there are a ton of these files that I would love to watch on the box. Thanks again!
Reply
#4
Question 
Hi!

I have a Mac Mini 2.0 connected via S/PDIF to my reciever. Everything works exeptionally good in xbmc, i can view everything at 1080p (matroska, quicktime) except i don't get any sound when viewing Windows Media 1080p's.

Any solution? Sound works in Quicktime with Flip4Mac, VLC etc.


Any response appretiated.
Reply
#5
WMA Pro isn't supported, and some other versions of WMA isn't either.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Reply
#6
FYI; XBMC for Linux, XBMC for Mac, and XBMC for Windows, do not use MPlayer, instead they uses Team-XBMC's own in-house developed video-player (DVDPlayer) which is based on FFmpeg, ...so if and when FFmpeg supports WMV Pro, then XBMC for Linux/Mac/Windows will (soon) support WMV Pro as well. Please read this article for more information:
http://wiki.xbmc.org/?title=Codec_and_Format_requests

Rolleyes
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#7
Hello thanks for your hard work - I noticed in the 0.4.5 release it mention fixing a crash when reading WMA files, I haven’t tried any WMA audio files but i do have some video files conveterd for my 360, It will play these files fine video only, but I do not have an audio, These videos are WMV vid format with WMA 10 Pro audio.

What am i missing a codec etc for my hackintosh or?

Thanks
AJ
Laugh
Reply
#8
don't use crappy proprietary formats
Reply
#9
spiff Wrote:don't use crappy proprietary formats

HAHAHA - Good One - Seriously Spiff just trying to use a file/movie that is compatible with my 360, Geezz it's not like I am using a Real Player fileRolleyes
Reply
#10
WMV is just about as bad as Real Video, proprietary shit is proprietary. ffmpeg would need support for it but it can't get it without some reverse engineering and I think most of the devs dont think it's worth of it.
Reply
#11
_tv_ Wrote:WMV is just about as bad as Real Video, proprietary shit is proprietary. ffmpeg would need support for it but it can't get it without some reverse engineering and I think most of the devs dont think it's worth of it.

WMV-HD Files are not crap - infact they look as good as MKV files - We all know it's dependt on the source! So I just asked a simple question. I guess i should of been more specific.

Thanks for Caring criticism Laugh

AJ
Reply
#12
well, the issue is that nobody has reversed engineered the audio codec used in those files - most likely due to the ability to load the binary in apps like mplayer.

mkv files doesnt look one way or another, that is they look like a lot of 1's and 0's. mkv is a container.
Reply
#13
Hello,

I've some WMVHD movies with WMA Pro 9 audio which, video playback works fine on XBMC Linux but the audio won't playback.

I found WMA Pro is not (yet?) supported, so i was wondering is there a possibility it is gonna be implemented or is it just not opensource so it can't be played on ubuntu.

Razor
HTPC + Mediaserver
E8400 - ABIT I-N73HD - 2GB DDR2 - 3.5TB - Geforce G210 - ANTEC FUSION V2 - Ubuntu 10.04 - XBMC-PVR

TV-Server
Ubuntu 10.04 - Tvheadend - Smargo Reader - Oscam Card Server - 2x PCI DVB-C
Reply
#14
Razor_109 Wrote:is it just not open source
That is exacly the case, please read this (from the XBMC FAQ):
http://wiki.xbmc.org/?title=What_is_XBMC...to_XBMC.3F
http://wiki.xbmc.org/?title=What_is_XBMC...by_XBMC.3F
http://wiki.xbmc.org/?title=Codec_and_Format_requests
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#15
Exclamation 
Hi,

I am using XBMC for windows rev14125 i currently have windows XP PRO with SP3 and an Soundblaster Audigy with the SBAX_PCDRV_LB_2_18_0001 driver.

When i try to play an .divx movie everything works just fine, video and audio playback are great. When i, however, try to play an HD .wmv file it plays the video steam just fine, but the audio stream isn't played.

http://pastebin.com/m39e06e4c (This is where you can see the log file of xbmc.)

#
15:05:07 T:3944 M: 92295168 DEBUG: CDVDPlayer:Tonguerocess - starting demuxer from: 71.973333
#
15:05:07 T:3944 M: 92295168 NOTICE: Opening video stream: 1 source: 256
#
15:05:07 T:3944 M: 92295168 NOTICE: Creating video codec with codec id: 73
#
15:05:07 T:3944 M: 92295168 DEBUG: FactoryCodec - Video: FFmpeg - Opening
#
15:05:07 T:3944 M: 91586560 DEBUG: FactoryCodec - Video: FFmpeg - Opened
#
15:05:07 T:3944 M: 91586560 NOTICE: Creating video thread
#
15:05:07 T:3944 M: 91582464 NOTICE: Opening audio stream: 0 source: 256
#
15:05:07 T:3944 M: 91582464 NOTICE: Finding audio codec for: 86057
#
15:05:07 T:3944 M: 91582464 DEBUG: FactoryCodec - Audio: passthrough - Opening
#
15:05:07 T:3944 M: 91582464 DEBUG: FactoryCodec - Audio: passthrough - Failed
#
15:05:07 T:3944 M: 91582464 DEBUG: FactoryCodec - Audio: FFmpeg - Opening
#
15:05:07 T:3944 M: 91582464 DEBUG: CDVDAudioCodecFFmpeg::Open() Unable to find codec
#
15:05:07 T:3944 M: 91578368 DEBUG: FactoryCodec - Audio: FFmpeg - Failed
#
15:05:07 T:3944 M: 91578368 ERROR: Unsupported audio codec
#
15:05:07 T:3944 M: 91578368 WARNING: CDVDPlayer::OpenAudioStream - Unsupported stream 0. Stream disabled.
#
15:05:07 T:3944 M: 91578368 DEBUG: Playback has started
#
15:05:08 T:3808 M: 83632128 ERROR: CDVDVideoCodecFFmpeg:Big Grinecode - avcodec_decode_video returned failure
#
15:05:08 T:3808 M: 83808256 ERROR: CDVDVideoCodecFFmpeg:Big Grinecode - avcodec_decode_video returned failure

To highlight the errors.

I can play the HD .wmv files perfectly with windows movie player and i understand that it has it's pro's to have xbmc not depend on installed codecs in windows.

However, how do i install the codec wich i already have into XBMC? It's on my computer somewhere so it shouldn't be impossible.

Or maybe better yet. Would it be possible to just let the windows movie player play the files since that's already installed and working?

Any idea's would be greatly appreciated!
Martijn.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
WMA Pro Audio Codec (Microsoft WMVHD/WVC1 Sound)?00
This forum uses Lukasz Tkacz MyBB addons.