Thumbnails

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
margro Offline
Posting Freak
Posts: 810
Joined: Oct 2009
Reputation: 28
Location: The Netherlands
Post: #16
A bit more information about the recording thumbnails. Kodi already supported them before the TV Server could generate them.
When the addon is configured in TSReader mode (default), Kodi gets the finished recordings just as (network) file paths. Kodi itself generates in that case the thumbnails.
This does not work when using the addon in ffmpeg (rtsp streaming) mode.

In case the TVServer generates the thumbnail, it must be next to the recording with the same file name except for the extension.
I'm taking the recording file name and replaceing the .ts file extension by .jpg.
If the PVR addon can find and access a file named "myrecordingname.jpg" next to the "myrecordingname.ts" file, it will set the strThumbnailPath to point to this thumbnail.

Unfortunately, the current addon does not write any (debug) log for the thumbnails, so even with a Kodi log file, I'm unable to 'see' why it does not work. I need to add debug logging to the addon first.

Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
archie456 Offline
Fan
Posts: 345
Joined: Jun 2012
Reputation: 0
Post: #17
I've got 'Streaming Method' in the Playback settings of the PVR plugin set to ffmpeg - I set the plugin to this as ages ago as I seem to remember that it was better at playing back than TSReader, but that was when I had a Raspberry Pi 1, I now use Rpi3s.

I might try TSReader to see if that makes any difference? (Not too sure what the difference is though).


Looking at the recorded folder, I can see three files for each recording, one with the TS extension, one JPG file and one XML file.
find quote
hackthis02 Offline
Junior Member
Posts: 19
Joined: Jun 2015
Reputation: 1
Location: Chicago, IL
Post: #18
Are you still having your issue?
I'm not sure why but when I first had this issue I setup everything the way you did.

Set TSReader on Kodi
Set MediaPortal TV Server -> Recording -> Folders tab to UNC.
Set thumbnails to Auto Create and Leave images in recovering folder.

Oddly none of that fixed it. It wasn't until new recordings were made that the thumbnails started to appear.
find quote
archie456 Offline
Fan
Posts: 345
Joined: Jun 2012
Reputation: 0
Post: #19
Unfortunately, I've never been able to fix this issue... I'd appreciate any advise.
find quote
UsefulG Offline
Donor
Posts: 353
Joined: Jun 2015
Reputation: 7
Post: #20
Without being the +1 guy but +1 I'm having the same issue with almost the exact same kit (Rpi clients with MP TV Server on a PC) and I've totally rebuilt one Pi to see if it was skin.helper.service PVR artwork conflicting but still no joy.
find quote
margro Offline
Posting Freak
Posts: 810
Joined: Oct 2009
Reputation: 28
Location: The Netherlands
Post: #21
Check post #16.
Thumbnails will not work if you are using RTSP streams.

Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
UsefulG Offline
Donor
Posts: 353
Joined: Jun 2015
Reputation: 7
Post: #22
@margro The clients use the default TSReader with RTSP Streaming Off.

I can see the Thumbnails being created in the \\Server\Recording folder next to the .ts files and I can play the files correctly so I guess the SMB account details and shared folder structure is ok but for whatever reason the thumbs are not showing.

I am using the latest TVServerKodi plugin 1.15.134 on the server and the latest 999.2.6.4 addon on the clients.
(This post was last modified: 2016-10-24 10:29 by UsefulG.)
find quote
hackthis02 Offline
Junior Member
Posts: 19
Joined: Jun 2015
Reputation: 1
Location: Chicago, IL
Post: #23
This might be a long shot. But if you SSH in and open "$HOME/.kodi/temp/kodi.log" then search for .jpg. You should see the location it tried to get the image.

It should look like this.
20:07:04 46863.937500 T:1580016544 NOTICE: LoadJpeg: unable to load smb://{username}:{password}@{server}"/Recorded TV/Arrow_CW HD_2016-10-19_7_00 PM.jpg"

Confirm it's at least looking for the correct location.

If that looks correct. Check the sharing settings on your recording folder. It's might be a security issues but I set everyone to Read/Write.

@margro correct me if I'm wrong but pvr.mediaportal.tvserver doesn't log if it can't find the thumbnail.
find quote
UsefulG Offline
Donor
Posts: 353
Joined: Jun 2015
Reputation: 7
Post: #24
@hackthis02 I turned on debug logging and restarted kodi browsed my recordings and didn't get any errors like the one above. However I did notice that despite my changing the recording folder to \\server\recordings in the TVServerKodi plugin it was giving a local drive as the location i.e D:\PVR\Recordings\ so I changed the Recordings folder in Mediaportal TV Server and restarted the service. Now when I record I can see the generated thumb for new recordings, thanks for pointing me in the right direction.
find quote
margro Offline
Posting Freak
Posts: 810
Joined: Oct 2009
Reputation: 28
Location: The Netherlands
Post: #25
@UsefulG: Could you explain in detail which setting did not work and which setting does work for you? Hopefully I can reproduce the issue and fix it.

Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
find quote
hackthis02 Offline
Junior Member
Posts: 19
Joined: Jun 2015
Reputation: 1
Location: Chicago, IL
Post: #26
@Margro I believe his issue was in the TVServerKodi plugin he had set the pathto UNC but in MediaPortal TV Server -> Recording -> Folders they were still set to a local path.
Setting them both to the UNC path fixed the issue.

The only remaining issue, one which I have seen before as well, is if the paths aren't set correctly when recording the show, the thumbnails will never display. Even after you set all the paths correctly, only NEW recordings will display.

My guess is MP write the thumbnails path when recording and doesn't update it when/if you change the recording path.
find quote
archie456 Offline
Fan
Posts: 345
Joined: Jun 2012
Reputation: 0
Post: #27
@hackthis02 - that suggestion didn't work for me.

In the TVServerKodi Shares tab I have all the UNC recording paths set to a UNC path (\\TVSERVER\Recorded TV) - note my PC which has media portal on it is called TVSERVER...

I then have in Recording in the TV Server Configuation 'Autocreate thumbs ticked'.

When I look in the \\TVSERVER\Recorded TV i can see a JPG for the thumbnail, a TS for the recording and an XML file.

All seems in order, just no thumbs are displayed in Kodi on the Raspberry PI install and also on my PC install.

I tried looking in the log file for the JPG filename of a recording as suggested in your post 23 but couldn't find any reference to any JPGs for the recorded files (I used the PC version of Kodi).
(This post was last modified: 2016-11-03 22:52 by archie456.)
find quote
hackthis02 Offline
Junior Member
Posts: 19
Joined: Jun 2015
Reputation: 1
Location: Chicago, IL
Post: #28
I believe you missed one step

You have TVServerKodi set correctly
[Image: FgKaKr9.png]

But do you have MediaPortal TV Server -> Recording -> Folders set correctly?
[Image: fd0pVo5.png]

Also even after these are set. You won't see thumbnails till after a new recording has finished.

If someone's post helps you out, click the thank user button.
find quote
UsefulG Offline
Donor
Posts: 353
Joined: Jun 2015
Reputation: 7
Post: #29
Apologies I work away so can't always answer questions quickly.

@hackthis02 in post 28 has pretty much described my problem I had the share path in the Plugin page but the Mediaportal->Recording->Folder was set to local path. When I changed that to the share path the next recording had a thumbnail as required.

The strange this is I'm sure this worked before I upgraded to Windows 10 on the tv server but I've been playing with so many different bits and my aforementioned absences make my recollection hazy.

Thanks for investigating though everyone and hackthis02 for pointing the right way.
find quote
archie456 Offline
Fan
Posts: 345
Joined: Jun 2012
Reputation: 0
Post: #30
@hackthis02 - Yes I have the Folders tab also set to \\TVSERVER\Recorded TV

Also, in the thumbs tab Autocreate thumbs is ticked along with Leave a thumb in recording folder.

I'd post a screen shot if I could work out how...
find quote