Physical keyboard unresponsive after upgrade
#1
I just upgraded from 13 to 14, and I have the strangest problem. I have a physical USB keyboard plugged in and kodi is not accepting input. This has happened on two machines now. Mouse works.

I've tried:

1. Making sure the keyboard layout is set. It is.
2. Making sure the mouse and peripheral input is allowed. It is.
3. I've tried setting the focus for the kodi window by clicking on it. Doesn't do anything.

I can exit (or kill) kodi, and then the keyboard will work in other places (like the terminal or myth frontend.) When I start kodi, the keyboard dies (I can use ctrl+alt+f1 to drop to terminal) but any other input like using the arrows to navigate doesn't work.

This is irritating, v13 didn't do this. Anyone have any clue?

Edit: Both kodi log and Xorg.0.log show nothing related to the keyboard.
Reply
#2
Hey! It's often the little things that should work that are the worst.
13 to 14? We're almost on 17.

Do you have a gamepad plugged in? Unplug, reboot, add keyboard.

Also, Settings -> System -> Input devices -> uncheck enable joysticks

Try and report back.
Reply
#3
ALSO, the Keyboard was updated for Helix (14). You will need a compatible skin. Just because it worked in 13, doesn't mean it will now.
Did you try it on Confluence? When all else fails, go back to default and poke around.
Reply
#4
He is talkin about the physical keyboard.

Post the non relevant full Debug Log, please
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
(2016-05-30, 08:30)McButton Wrote: Hey! It's often the little things that should work that are the worst.
13 to 14? We're almost on 17.

Do you have a gamepad plugged in? Unplug, reboot, add keyboard.

Also, Settings -> System -> Input devices -> uncheck enable joysticks

Try and report back.

I don't have gamepad support built in.

(2016-05-30, 08:33)McButton Wrote: ALSO, the Keyboard was updated for Helix (14). You will need a compatible skin. Just because it worked in 13, doesn't mean it will now.
Did you try it on Confluence? When all else fails, go back to default and poke around.

I'm using Confluence, and the on screen keyboard works fine - it's the physical keyboard that doesn't work.

(2016-05-30, 09:10)fritsch Wrote: He is talkin about the physical keyboard.

Post the non relevant full Debug Log, please

OK, I've sent it to http://pastebin.com/AtKtJSkE

The xbmc paste site has a problem of some sort.

I've updated four machines now and they all do this, it must be a setting somewhere or maybe something is missing. Or maybe the distro (gentoo) changed something in the package I'm not aware of?

USB support is built, as the mouse and the IR work.
Reply
#6
Ouh now I see - kodi 14. Mind testing a recent version?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
I will try, but anything newer is marked unstable.
Reply
#8
OK, I managed to get kodi 16 installed, still have the same problem. I've put the log on pastebin.

http://pastebin.com/UUDTW0mp

Mouse, remote, and onscreen keyboard work fine. Physical USB keyboard does not (can use ctrl+alt+fn to drop to terminal.) Other apps on the same system use the keyboard just fine.
Reply
#9
Hmm...
"I" didn't notice anything.
I was thinking something was wrong with your install package, but you've had 2 versions now.
We'll hold out for someone more savvy than myself to check the log.
Reply
#10
I figured it out - sdl was dropped and so X wasn't giving focus to the kodi window. Clicking the mouse on the window wasn't giving it focus either.

I boot into mythfrontend and have an entry to start kodi as needed, I probably should have included that information, but I didn't think it was relevant. Whoops!

I modified my kodi startup entry in mythfrontend to look like this:

Code:
#!/bin/bash
/usr/bin/kodi &
sleep 3
DISPLAY=:0 xdotool windowfocus `xwininfo -display :0 -name "Kodi" | grep "Window id:" | cut -d\  -f4`

It starts kodi, detaches, waits a second for it to start up, then queries X for kodi's window ID and finally forces focus to it.

Problem solved!
Reply
#11
Awesome! Well done, dude. I assumed someone somewhere had the issue. Glad you got it. I hate when things just don't work 100%.

That should help someone in the future, I'm sure.
Reply



Logout Mark Read Team Forum Stats Members Help
Physical keyboard unresponsive after upgrade0
This forum uses Lukasz Tkacz MyBB addons.