v16 Streaming of HEVC DVB-T2 channels is not working
#16
Hi

true, but in my case not 4K just FullHD

br
Reply
#17
Hi All,

sorry, that i haven't posted for a while. I have checked my channel settings, and both not working channels have a service id and a service name. Still they are not working with Kodis HTSP plugin. Meanwhile I managed to view one of the non-working channels via my Laptop on Linux Mint with the integrated Video player. I had the hevc codecs for gstreamer installed.
It was still not perfect, the picture was pretty slow but it was running. This was on my TVHeadend 4.0.8 setup on jessie. I still believe this is not an issue of TVHeaedend nor one of Kodi - I can playback recorded shows (HEVC in Full HD) via Kodi (16.1). It must be a bug of the HTSP-Plugin.

@ralatick can you provide us the link to the bug report?

thanks
Reply
#18
(2016-06-19, 21:04)mdawid Wrote: Hi All,

sorry, that i haven't posted for a while. I have checked my channel settings, and both not working channels have a service id and a service name. Still they are not working with Kodis HTSP plugin. Meanwhile I managed to view one of the non-working channels via my Laptop on Linux Mint with the integrated Video player. I had the hevc codecs for gstreamer installed.
It was still not perfect, the picture was pretty slow but it was running. This was on my TVHeadend 4.0.8 setup on jessie. I still believe this is not an issue of TVHeaedend nor one of Kodi - I can playback recorded shows (HEVC in Full HD) via Kodi (16.1). It must be a bug of the HTSP-Plugin.

@ralatick can you provide us the link to the bug report?

thanks

Hi, Yes 90/100 is a bug of htsp protocolSmile but no one knows if it's in the kodi 's plugin or in tvheadend: because in the plugin 's log you can see the error message "get failed to get stream" but in the other side if you start a debug logging you can see that tvheadend is not "sending the first frame" check out the debug log of my bug report (be aware the description of this bug is wrong in some part because I've really tried everything to check if my theory was true but at the end I've not found a solution) this is the bug report: if all you guys will write something maybe someone will "see us" and respond. https://tvheadend.org/issues/3853

I'm using the last git version and this bug is still present: only one hevc channel (and as you can read this is the only thing that we have in common) is not working for me, the other 2 channels that I've are working good.

Edit: does the description of that bug correspond to you? ignore of course the part were I 've written "UPDATE 1,2,3..."
Reply
#19
Hi

sorry for the delay


yes u are right HVEC encoded material but in my case just FullHD and just live view / TV is affected, watching recordings is fine for me

br

Ralatick
Reply
#20
Have both of you at least one channel working (of course among hevc channels) ? Smile Because I've 3 channels and only one of them isn't working. If not you should try to update to git the git version Smile (if you are in the stable branch)
Reply
#21
I will try when i setup the new mediaserver in the next days
Reply
#22
(2016-06-15, 09:39)mdawid Wrote:
(2016-06-10, 13:17)membrane Wrote: I have a LibreELEC installation here and it is working fine with the new DVB-T2 signal. No special setting needed, everything worked out of the box (local and remote playback).

I set up a raspberry 3 with LibreELEC and was able to install TVHeadend 4.2 plugin. Configuration of TVHeadend was fine (via web). I was also able to view a stream via Laptop (Linux Mint stanard video player, not VLC). But i was not able to connect via Kodi and HTSP plugin to the tvheadend instance on the raspberry. Neither locally from LibreELEC nor from my Laptop (both running Kodi 16.1 Jarvis) .....

SRY for offtopic but which DVB-T Stick do u using? Would buy one with HEVC support for german DVB-T2.
This is my first post and cant send a PM!

EDIT: Ok, found the August T210 in your "How to" posting"! Smile
RPi3 | RPi4 | LibreElec Kodi
Reply
#23
So, has someone found a workaround or something to make it work? Nobody has responded to the bug report yet, it's a pity because i think tvheadend is maybe the best software for television on pc.
Reply
#24
Hi Nojoe

jep August T210 but it has no HVEC support, HVEC decoding is done by your PC


btw. is there any other way to get TVH 4.2 don´t wan´t to install Libre Elec, checked TVH GIT but no source for 4.2
tried 4.0.9 and 4.1 today and for both the same problem ...
Reply
#25
(2016-06-28, 21:58)ralatick Wrote: Hi Nojoe

jep August T210 but it has no HVEC support, HVEC decoding is done by your PC


btw. is there any other way to get TVH 4.2 don´t wan´t to install Libre Elec, checked TVH GIT but no source for 4.2
tried 4.0.9 and 4.1 today and for both the same problem ...
I think that tvheadend 4.2 will be the stable release of the current developer version of 4.1: there are no branches or tags about 4.2 in github Smile Libreelec's devs have only rename 4.1 to what il will be final 4.2 (you can see on tvheadend's site the roadmap that points out that 4.2 is almost near the end of developing)
Reply
#26
I don't think that there is a bug in the PVR add-on. I can view DVB-T2/Hevc it via Libreelec 7.0.1/Kodi 16.1 on x64, ARM (Odroid C2) and Kodi 16.1/17 on Windows. My backend is the stock Tvheadend 4.1.1945 of Libreelec 7.0.1 on my Intel Atom "server". 4.0.* might be too old for that.

I have a RTL2832 tuner and it works flawlessly. It is the cheapest one from ebay (~16€) - normally noname, sometimes under the name "Astrometa".
Reply
#27
Sorry double post
Reply
#28
(2016-06-29, 12:35)membrane Wrote: I don't think that there is a bug in the PVR add-on. I can view DVB-T2/Hevc it via Libreelec 7.0.1/Kodi 16.1 on x64, ARM (Odroid C2) and Kodi 16.1/17 on Windows. My backend is the stock Tvheadend 4.1.1945 of Libreelec 7.0.1 on my Intel Atom "server". 4.0.* might be too old for that.

I have a RTL2832 tuner and it works flawlessly. It is the cheapest one from ebay (~16€) - normally noname, sometimes under the name "Astrometa".
There is surely something that doesn't work or in the add-on itself or in tvheadend: you can watch logs where there is no "subscription start" in tvheadend and "get fail to get stream (or something like that I don't remember)" in kodi add-on. I have only one of hevc channels that is not working and only with htsp. It works with HTTP and direct mux streaming. Smile
Reply
#29
Hi all, the issue has been fixed in tvheadend today Wink You need the last revision from git master Wink Thanks to Jaroslav Kysela again for investigating and fixing it.
Reply



Logout Mark Read Team Forum Stats Members Help
Streaming of HEVC DVB-T2 channels is not working0
This forum uses Lukasz Tkacz MyBB addons.