Win -  DXVA2 and Hevc
#1
Hi Guys!

I am really desperate and need your help. I have searched this forum and also others but without success.
My problem: While DXVA2 activated and a HEVC video is playing the video is smooth and CPU is at 10 - 30% (Pentium G4400 Skylake/HD510)
but it has a kind of "stairs" oder blocks in the picture. I have screenshots linked:
Screenshot 1 - Screenshot 2

I 've discovered that this apparently is a Problem with the native DXVA2 setting. In MPC, I had the same effect. But there I can change (in the LAV settings) to DXVA2 (copy-back) and the problem is solved. Unfortunately, there seems to be no way to adjust this option when Kodi. Is there any possibility to set the Kodi to (copy-back) or even Intel Quicksync ?

PS: sorry for my bad english and I am grateful for any hint
Reply
#2
Try:

Code:
<advancedsettings>
  <video>
    <forcedxvarenderer>false</forcedxvarenderer>
  </video>
</advancedsettings>

Not sure if that works anymore, it's not documented in the wiki. Also for hevc 10 bit support Krypton nightly is needed.

Will ping our windows dev to see if that will work.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2016-06-07, 09:52)fritsch Wrote: Try:

Code:
<advancedsettings>
  <video>
    <forcedxvarenderer>false</forcedxvarenderer>
  </video>
</advancedsettings>

Not sure if that works anymore, it's not documented in the wiki. Also for hevc 10 bit support Krypton nightly is needed.

Will ping our windows dev to see if that will work.

Hello fritsch,

that does the trick! Everything looks perfekt now.
No "blocks" anymore and the CPU usage is still low in all videos from 1080p up to 4K.
Thank you SO much!
Reply
#4
For instructions how to enter Advanced Settings - http://kodi.wiki/view/Advancedsettings.xml
Reply
#5
(2016-06-07, 17:58)michael2063 Wrote:
(2016-06-07, 09:52)fritsch Wrote: Try:

Code:
<advancedsettings>
  <video>
    <forcedxvarenderer>false</forcedxvarenderer>
  </video>
</advancedsettings>

Not sure if that works anymore, it's not documented in the wiki. Also for hevc 10 bit support Krypton nightly is needed.

Will ping our windows dev to see if that will work.

Hello fritsch,

that does the trick! Everything looks perfekt now.
No "blocks" anymore and the CPU usage is still low in all videos from 1080p up to 4K.
Thank you SO much!

Still - that's no proper solution. IIRC there was an intel driver setting that caused this issue, but cannot remember anymore.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
@fritsch - Yes there were a few threads regarding the Stairway effect. This is what I was advising windows users to do. I'll have to make a note of your fix as well.

The stairway artefact is an issue that affects some Intel HD Graphics chipsets

To remove this artefact...

1. Close Kodi
2. Open the Intel HD Graphics Control Panel
3. Navigate to Video Settings
4. Disable Contrast Enhancement.
5. Save and Close
6. Start Kodi

(Your control panel may be slightly different to the above procedure)
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#7
(2016-06-07, 09:52)fritsch Wrote: Try:

Code:
<advancedsettings>
  <video>
    <forcedxvarenderer>false</forcedxvarenderer>
  </video>
</advancedsettings>

Not sure if that works anymore, it's not documented in the wiki. Also for hevc 10 bit support Krypton nightly is needed.

Will ping our windows dev to see if that will work.

Fritsch's code worked for me.

I have a Microsoft Surface Pro 4, and of course, Microsoft do not offer access to settings in the Intel HD driver. (Grrr.)
Reply
#8
(2017-05-21, 11:35)Karellen Wrote: @fritsch - Yes there were a few threads regarding the Stairway effect. This is what I was advising windows users to do. I'll have to make a note of your fix as well.

The stairway artefact is an issue that affects some Intel HD Graphics chipsets

To remove this artefact...

1. Close Kodi
2. Open the Intel HD Graphics Control Panel
3. Navigate to Video Settings
4. Disable Contrast Enhancement.
5. Save and Close
6. Start Kodi

(Your control panel may be slightly different to the above procedure)
Big Thanks for that tip...the 'stairway to heaven' has gone in Kodi 17.x on Wndows 10 Intel NUC6I5SYH that uses Intel Grfx...lots of things to rewatch lol
Reply
#9
Happy that it helped Smile
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic_controls (wiki) | Import-export_library (wiki) | Movie_sets (wiki) | NFO_files (wiki) | Quick start guide (wiki)
Reply
#10
This worked. Thanks alot. this has been driving me insane for a year!!!!
Reply
#11
Changing the settings like Karellen said worked on my NUC 7i3BNH.

I wasn't having the stairway effect but something more like the top 15% distorted with flipped colors. Strange thing though, I wasn't getting it on all my x265 encodes. All the 4:3 material seems unaffected with some 16:9 and 21:9 being affected. Everything was encoded with Handbreak using the same settings.
Reply
 
Thread Rating:
  • 1 Vote(s) - 3 Average



Logout Mark Read Team Forum Stats Members Help
DXVA2 and Hevc31