Linux pvr stalker
#1
hello

I am running Kodi 16.1 and Stalker PVR on Xubuntu Linux (ubuntu + xfce)

when I enable live tv in settings>tv my kodi crashes and closes immediately... this does not happen in windows or android

I have tried a fresh install of kodi with the pvr client not configured and it still crashes as soon as I start it.... any suggestions?
Reply
#2
Yes of course I have a suggestion. debug log (wiki)
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
If you can provide what nickr suggested that would be helpful. I'll also check and see if the same happens to me.
Reply
#4
*Link Removed
Reply
#5
I'm not sure what the problem could be. The build from the kodi-pvr-stalker package force closes Kodi immediately, but when I compiled the same version from the git repo (static build) it works fine. There's no crash log or core dump from Kodi either.
Reply
#6
Looking into this more I found the source of the problem.

Looking at the build log for the kodi-pvr-stalker package. There's a build setting (USE_LTO) that's ultimately causing undefined symbols. Thus crashes Kodi when the add-on is loaded.

It's too bad this wasn't caught early enough for Jarvis. I should of been checking the builds in the Ubuntu ppa.
Reply
#7
interesting, sorry for taking so long to get back to you

is there anything I can do to patch this issue or do I just need to wait for it to be fixed? or can it be fixed? is it something I am doing?
Reply
#8
The only immediate solution is to build the add-on yourself. You can try the following commands in terminal. This worked for me on Ubuntu. Afterwards just run Kodi, as it should be installed.

Code:
sudo apt-get purge kodi-pvr-stalker
sudo apt-get install git cmake

git clone -b Jarvis --depth 1 https://github.com/xbmc/xbmc.git

git clone -b Jarvis https://github.com/kodi-pvr/pvr.stalker.git
cd pvr.stalker/
mkdir build && cd build/
cmake \
  -DADDONS_TO_BUILD=pvr.stalker \
  -DADDON_SRC_PREFIX=`pwd`/../../ \
  -DCMAKE_BUILD_TYPE=Release \
  -DCMAKE_INSTALL_PREFIX=~/.kodi/addons/ \
  -DPACKAGE_ZIP=1 ../../xbmc/project/cmake/addons/
make


Also, I think I'm gonna ask the ppa maintainer if it's possible to get the add-on rebuilt and updated in the repo.
Reply
#9
thank you so much I got it working!!!!!!

really appreciate all the help thanks again
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
pvr stalker51