Opensubtitles fail to download
Suddenly I can't download in Kodi on my Blaze TV box, but I don't have a problem with to download them on my other box which Matricom G Box . Both are set up the same way...just difference is that Blaze box run Android 4.4 and Matricom G box Android 5.1
Getting message : Error Check the log for more information ( honestly don't know how ) and later change to Failed to download subtitles .
Any idea what could change ? I tried to uninstall and install them again, but no luck......
I am having the same issue, anyone that can help? Also A lot of Spanish subtitles are not loading at all. Tried and Podnapsi. Still a lot of failed loads.
What is a interesting, till I was not registered with opensubtitles they was working perfect almost 2 months, after I get registered 2 days later I can't use them anymore.......
had the same, solution reboot all modem/router. and trun vpn off see what happens
Tomtomclub thanks! Will try it
I think the problem is that OpenSubtitles is using captcha to stop bots and other systems (maybe like Kodi too) from downloading the subtitles off of their websites. I absolutely hate captchas. You need to pass it even if you sign in. They have one where you have to match the pictures to the three categories and no matter what I do I cannot get past that stupid captcha screen and I know the pictures are in the right categories! Their tech support will not budge and it appears that they do not care the inconvenience they are causing people.
On my side I understood the problem. Maybe this can help you.

I've just had the very same problem a few minutes ago when I decided to stop trying and to download the subtitle myself from the browser. When I tried I got the error message that I've being downloading too many subtitles from the same IP and the Firewall was blocking me. Using a proxy allowed me to download that single subtitle.
So, it's a matter of don't trying too much. The trick to restart the modem/router works if you get a dynamic IP from your ISP.

Enjoy Smile
searching on their website is also broken, I guess this is the reason:

11-9-2016: 22:24 CEST

Error 503 Backend fetch failed

Backend fetch failed
Guru Meditation:

XID: 760683303
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Opensubtitles fail to download00
This forum uses Lukasz Tkacz MyBB addons.