How to "read" SRT files in Kodi?
#1
Hi there, this might be un ultra stupid question, but I cannot get Kodi to read the SRT files. Streaming (ie through the add-ons everything works great). I however have a number of MKV files where I have the subtitles for locally. They are in the same folder and have the exact same name, so:
\FOLDER\01.Moviename - film.mkv
\FOLDER\01.Moviename - film-srt

In the system settings section of Kodi I have the location of subtitles marked as "same as movie".

If I play the MKV file I still only get the subtitles embedded in the MKV file. I cannot find out how to access the srt file corresponding to the movie.

Can anybody point me to the solution?

Thanks in advance!

Arnoud (NL)



PS, forgot to add: when I test the movie on my computer with VLC the subtitles automatically are found and displayed!
Reply
#2
During playback press ok, go to the audio icon, press ok, there are options to choose subtitle file.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#3
(2016-06-18, 22:43)Arnoud Wrote: \FOLDER\01.Moviename - film.mkv
\FOLDER\01.Moviename - film-srt

Check your settings page, then videos, then subtitles (ondertiteling) and check each setting. Also, you have a dash where a dot should be in your filename. It isn't a .srt file at the moments, its a "Moviename -film-srt" file Wink

(NL)
Controleer even je Settings->Videos->Ondertiteling en loop even alle instellingen na. Daarnaast staat je bestandsnaam fout, je hebt een streepje staan ipv een punt. Maar dat zal wel een tikfout zijn van je forum post gok ik Wink
Reply
#4
Following solution works flawlessly for me:

In settings set preferred subtitle lang.
Add subtitles with exactly same name but add '.en' (for english or '.sv' for Swedish, or whatever Your lang code is) just before '.srt' in filename.

See example below:
/moviefolder/Moviename (year).mpg
/moviefolder/Moviename (year).en.srt

I have approx 1200 moves and few hundred has external subs named as above and all works without any hassle at all.
Reply
#5
(2016-09-14, 14:46)JockeSve Wrote: Following solution works flawlessly for me:

In settings set preferred subtitle lang.
Add subtitles with exactly same name but add '.en' (for english or '.sv' for Swedish, or whatever Your lang code is) just before '.srt' in filename.

See example below:
/moviefolder/Moviename (year).mpg
/moviefolder/Moviename (year).en.srt

I have approx 1200 moves and few hundred has external subs named as above and all works without any hassle at all.
Reply
#6
(2021-04-27, 17:45)astral69 Wrote:
(2016-09-14, 14:46)JockeSve Wrote: Following solution works flawlessly for me:

In settings set preferred subtitle lang.
Add subtitles with exactly same name but add '.en' (for english or '.sv' for Swedish, or whatever Your lang code is) just before '.srt' in filename.

See example below:
/moviefolder/Moviename (year).mpg
/moviefolder/Moviename (year).en.srt

I have approx 1200 moves and few hundred has external subs named as above and all works without any hassle at all.
Some time on from the original messages but still not resolved

Kodi V 19.0 Matrix running on Minix Neo U9-H

.srt files are not available if there are embedded subtitles
I can browse and see them
They are listed on the Subtitle screen
but the cursor skips over
Reply
#7
@astral69 Please do not edit/add your reply inside the quoted post. It makes things very confusing for other people.

Also, quoting your own post is a bit weird.
Got a Kodi problem? Provide us with a full Debug log (wiki) || Usefull pages: First time user (wiki) || Troubleshooting (wiki) || Free content (wiki) || Forum rules (wiki) || VPN policy (wiki)
Reply



Logout Mark Read Team Forum Stats Members Help
How to "read" SRT files in Kodi?0
This forum uses Lukasz Tkacz MyBB addons.