Thread Rating:
  • 0 Vote(s) - 0 Average
Is box inability to write backup to external usb Kodi or mfr issue?
#1
Sorry if I should not have posted this in this particular forum.

I have been asking on Android forums if problem I am experiencing is due to Kodi or to Android 5.1.1 or to the manufacturer's implementation

Here are the details in brief:

i) SoC - Amlogic S-905 SoC 64 bit
ii) Android OS :- 5.1.1
API Level 22, Kernel : Linux 3.14.29
iii) KODI App version:- 16.1


Reproducible Steps:-
1) Started the Android TV Box
2) Opened installed KODI
2) Installed KODI Backup 1.0.6 Program app by Author
robweber
3) Opened the Backup Program settings and browsed to set
backup location on external udisk0 from settings menu
4) Set the location and entered OK
5) Ran Backup addon and selected Backup
6) Popup menu reads "Write Error Detected" "The destination may not be writeable. Would you like to continue?"
7) Continuation writes nothing

Issue:- Backup to external storage device does not work.
I've asked on Android forums if this is particular to the Android 5.1.1 OS. They say it is not; that if the box does not allow writing it is due to manufacturer not implementing it or to the program I'm using.

Note: I'm trying to determine if this is unique to the box I have purchased.

KODI Log File Detail:-

13:48:42 T:18446744072293681552 ERROR: Static bool XFILE:Big Grinirectory::Create(const CURL&) - ERROR creating /storage/udisk0/MXQ-Pro_BU/201606291348/

Could someone please give me an idea of where the problem originates or direct me to where I should post this question?
Reply
#2
Hi

Did you ever get to the bottom of this. I set up a new Android 5.1 tv box yesterday. Seem to have this problem with Kodi not being able to write to external storage. So backup fails, and I keep my thumbnails on an external SD so they cannot be updated either.

I've tried a fresh install of Kodi 16.1 and still have the same error.
Reply
#3
Many S905 units have a known issue when it comes to writing large files to external devices. Try writing any large file to your stick, using the device, to see if you get the same issue. If so, your device is the problem and you will need firmware to fix it. If it writes fine, then device is likely not the issue. Make sure the file is larger than 10 Meg to test.
Reply
#4
After much de-installing, re-installing and general messing around I seem to have worked around it. I installed Kingroot and rooted the box and Kodi can write to the external usb drive and SD card. I'm not an android expert so didn't really get far when trying to figure out what was the cause. I did notice that when I tried to write files to SD with a file manager that when I hit the copy button another window opened, and I have no idea what app this is, which asked me to confirm the copy. Once I hit the appropriate button the copy happened.

I guess that from within Kodi this window never became visible and so I couldn't allow the write to happen.

Rooting seems to have sorted it out, although there was a lot more playing around than just rooting the box.So I guess it's possible something else I did fixed it.

There's a bunch of messages in Kodi log mentioning 'can't find windows filestacking dialog' which I spent time investigating but in the end I think is a red herring.

BTW the box is an MXQ, android 5.1.1
Reply
#5
I'm pretty sure it wasn't the root because I have root. Too bad you didn't take careful steps to isolate exactly what you did that worked.

I've been told that some TV boxes DO let Kodi write to external storage, but I haven't seen it.

Some tell me it is an operating system problem, that the Android API can be used to properly configure the needed permissions.

Then I hear that Kodi has not implemented the needed Android API configuration permissions.

On my box even ES File Explorer (and with root access, and using ES Root Browser to re-set mount permissions), writing to external storage fails.

Some tell me you need a firmware upgrade for the box. I'm not sure what is in a firmware upgrade, but I read people saying you need that to be able to upgrade Kodi (which I have found to be total nonsense). My box came with an older version of Kodi "pre-installed," and I'm sure, pre-configured. It isn't actually installed, but like a lot of the bloatware they include, the apk has been downloaded and is ready for you to install it. The first thing I do is uninstall all that space consuming garbage, including the old Kodi, and do a clean Kodi install of latest version (Jarvis). It works perfectly.

So, I still don't know what the fix is for this. With Kitkat, I saw that someone had fixed that with an app available from Google Play, but that does not work with 5.1. I had read that 5.1 was supposed to fix that permission blocking crap, but it didn't.

I don't know exactly what fixes this.
Reply
#6
Documenting what I did would have been good. But it descended into one of those frenzied try anything sessions. It came with pre-installed Kodi which I ultimately removed and replaced with a fresh copy downloaded from kodi website.

Whatever it was that fixed it is still holding up and Kodi is writing thumbnails and backups to the external storage.

Still waiting to hear back from the manufacturer as to what app or firmware may be causing the problem. I strongly suspect that the window that opened to grant permission after I tried to write a file to external storage with a standard file manager is the cause. But sadly I have no idea how to figure out what the app is and how to disable it properly or configure around it and allow Kodi permission to write.
Reply
#7
Here is what I found as the solution. After the backup app is installed, Insert your USB drive or SD Card with the box off, (box off is how I did mine). Once I power back on box it automatically created a Android folder. If you browse the path to that folder. Android/data/org.xbmc.kodi/files and select ok. Then the devices saves the files to this location with a date and allows you to restore at another time.
Reply



Is box inability to write backup to external usb Kodi or mfr issue?00