Playing in-built subtitles
#1
How can I get Kodi to play the subtitles which are embedded in the video file itself ? There are many movies where the subtitles are present in the video but Kodi doesn't seem to pick it up. Kodi is able to pick up the subtitles if they are present in the same folder though. Any workaround for this ?
HP Pavilion G6 Series | Samsung 40H5100
Reply
#2
Kodi does this by default. Every video file I have with embedded subs plays the embedded subs.
Reply
#3
Have you tried to manually select the embedded sub titles, rather then expecting Kodi to auto play them? For instance, not all embedded subtitles are set to auto play.
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
#4
well, the subtitles are not playing whenever they are embedded in the video file. Kodi is not detecting them entirely, so there is no question of manually selecting the subtitles. Any other way to select these ?
HP Pavilion G6 Series | Samsung 40H5100
Reply
#5
Debug log (wiki) and mediainfo for the same file you play during the log.
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
#6
Kodi plays only one subtitle track at a time, as far as I know.
Reply
#7
Did you create these files yourself?

Kodi auto plays subtitles in files IF they are muxed together correctly.
For instance, in a container file such as an MKV, you can choose how subtitles are impacted upon play {Kodi or otherwise}.
If the tracks are IN the file but not SET to auto play, they simply exist and await a user driven response.

Using MKVToolNix as an example program....
Lets say you have your sub track listed as
{Track 1 - English / Default track Flag [Default] / Forced track Flag [NO]}, the Forced track will need to be set to [YES].
This will enable this item to always play and force you to turn it off (unless you already instructed Kodi to turn it off the first time, then it won't play again unless you turn it back on).

If the above is the case, you will either have to find subs to put into the folders, turn the subs on individually once per file, or remux your videos with the correct settings.

I hope that helped.
Reply
#8
(2016-07-17, 00:51)Ned Scott Wrote: Kodi plays only one subtitle track at a time, as far as I know.

If that was a riddle to find your pot of gold...

I vote you can hard encode a sub track to a video, then either attach a default sub track to the video or add a standalone version to the video folder.

That'll do 2 at once if you like wasting your time.

If you want to get really Inception with it, you could always use a camera to record the above happening, then add the same subtitle track to that file as well. Subtitles within subtitles...within subtitles.
Reply
#9
(2016-07-10, 04:56)CaptainKen Wrote: Have you tried to manually select the embedded sub titles, rather then expecting Kodi to auto play them? For instance, not all embedded subtitles are set to auto play.

(2016-07-19, 09:44)McButton Wrote: Did you create these files yourself?

Kodi auto plays subtitles in files IF they are muxed together correctly.
For instance, in a container file such as an MKV, you can choose how subtitles are impacted upon play {Kodi or otherwise}.
If the tracks are IN the file but not SET to auto play, they simply exist and await a user driven response.

Using MKVToolNix as an example program....
Lets say you have your sub track listed as
{Track 1 - English / Default track Flag [Default] / Forced track Flag [NO]}, the Forced track will need to be set to [YES].
This will enable this item to always play and force you to turn it off (unless you already instructed Kodi to turn it off the first time, then it won't play again unless you turn it back on).

If the above is the case, you will either have to find subs to put into the folders, turn the subs on individually once per file, or remux your videos with the correct settings.

I hope that helped.

No, I did not create the file myself. It is a downloaded video file (by Grym) .

I do not have the subtitle file seperately. When I play this file in vlc, I have to manually select the subtitle track from vlc options. I don't mind doing that.. Problem is, Kodi doesn't even give me the option to select from. I don't care about auto play as long as the option is present, I am fine selecting it manually.

How do I turn the subtitles ON ?
HP Pavilion G6 Series | Samsung 40H5100
Reply
#10
While playing press "OK"

Navigate to the "Audio" button, Press "OK"

In there you will find the subtitle on/off switch.

EDIT: if that doesn't work go back to post 5 and follow my instructions.

Note: Gosh look what I found on the wiki, just by putting "subtitles" into the search. Amazing huh?

Subtitles (wiki)
If I have helped you or increased your knowledge, click the 'thumbs up' button to give thanks :) (People with less than 20 posts won't see the "thumbs up" button.)
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Playing in-built subtitles51