•   
  • 1
  • 18
  • 19
  • 20
  • 21
  • 22(current)
Release -  CleanSubs - (Clean subtitles from the ads and other rubbish)
HeresJohnny is right - I encounter a lot of subtitles (at least Serbian ones) that are in bad format - they are marked as UTF8 but are in fact CP1250. And it is no trivial task (if possible at all) to detect CP.
Kodi addons: Lanik repo
Reply
Hi @DaLanik 
I've just downloaded and opened the sub that was showing me artifacts and the sub that worked just fine.
First I checked the sub that worked and much to my surprise, I found out that it was in ISO-8859-1...
Then I checked the one that shows artifacts and found out that it's also in ISO-8859-1.
But then, also much to my surprise, I noticed that the artifacts can already be seen in the text editor...
as entranhas de um irmão dele
voltou em segurança.
- Concentre-se na sua recuperação.

These should all look like this:
as entranhas de um irmão dele
voltou em segurança.
- Concentre-se na sua recuperação.

So, in this case, it seems that there was some kind of conversion that didn't go according to what was planned and some characters were replaced by the artifacts, namely:
'ã' was replaced by 'ã'
'ç' was replaced by 'ç'
'ç' and 'ã' were both replaced by 'çã'

This is the first time that I bump into such a problem. When I first reported artifacts in cleansubs some months ago I was managing the subs on my PC with file editors and command line utils which means that by that time there seemed to be some sort of issue with cleansubs.
Right now, everything appears to be working fine and the problem is upstream in the sub provider. I will take this issue to them.
Thanks for all your support @DaLanik .
Cheers
Raspberry Pi 3B
PINN SDCard
LibreELEC 9.0
Kodi 18
Reply
v6.3
- Small bug fixes
Kodi addons: Lanik repo
Reply
v6.4
- Language file format related changes
Kodi addons: Lanik repo
Reply
Hi DaLanik,

does this addon still work under Kodi 18 Leia? There is no animation anymore, when i'm downloading the subs. And the rubbish with websites, etc is still showing at the beginning from movies and episodes.

Thank you for your answer
cgi2011
Reply
I'll check again, but it worked for me with animation and everything...
Kodi addons: Lanik repo
Reply
Yers, definitely working. I am using Leia v18.0 on windows (32 bit version)
Kodi addons: Lanik repo
Reply
I'm on Leia too with a RPi3.
In my case I can see the animation but apparently cleansubs doesn't do anything else apart from the animation.
Later today I'll try to grab some logs and upload them.
Cheers
Raspberry Pi 3B
PINN SDCard
LibreELEC 9.0
Kodi 18
Reply
  •   
  • 1
  • 18
  • 19
  • 20
  • 21
  • 22(current)
 
Thread Rating:
  • 2 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
CleanSubs - (Clean subtitles from the ads and other rubbish)3.52