MediaInfo from XML
#16
Thanks for the feedback, here is one of the xml files http://pastebin.com/X772kEBj

They are generated by mediainfo without me editing anything so one would expect them to be pick up fine. No rush in answering, I will wait patiently for any reply since in the end it would be amazing to finally have all infos for my 3D discs in my TMM.
#17
Dunno how you created the XML,
but MediaInfo parsed the playlist file (at least, it wrote this into xml)
Code:
<Complete_name>/media/mnt7/MOUNTED/BDMV/PLAYLIST/00100.mpls</Complete_name>
(I expected the Bluray root folder, or a video file)

This brakes our parsing a bit, so i ignored the mpls in this case.
It's already available in latest nightly, so you might want to try Smile
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
#18
A lot of Blurays nowadays use obfuscated playlist and broken standards as a means of protection. It seems best to provide the right playlist and only parse it so the result will have information that is actually correct Smile

Thanks for fixing it, I checked the nightly and it seems to work now for the subtitles and audio files.

The only thing that is still strange is the fact that it only knows the movie is 3D due to the naming of the file. It seems not to pick up 3D from the xml since then EDIT MOVIE -> MEDIA FILES has all information but the 3D selection is not filled in. Shouldn't TMM pick it up from the xml too?
#19
It should.
MediaInfo writes MultiView_Count=2, if 3D is detected.
Should be correctly filled in Movie Edit, when one video file is 3d...
(Havve to check for Bluray/Disc files...)
tinyMediaManager - THE media manager of your choice :)
Wanna help translate TMM ?
Image
#20
Interestingly enough this multiview tag is not in the xml output from mediainfo. Verified with other tools like Makemkv the disc is 3D MVC and mediainfo only shows that it is a regular bluray with one video track. I am using MediaInfoLib - v0.7.91 and tried CLI and GUI, noth come up with the same wrong result.

Looks like I have to file a bug with mediainfo Sad



Logout Mark Read Team Forum Stats Members Help
MediaInfo from XML0
This forum uses Lukasz Tkacz MyBB addons.