Bug krypton - deinterlacing isnt working correctly
#1
EDIT: old debug-log expired. post #7 (edit 2: +post #8) gives a summary with problem, more things i found out and a new debug log with activated video component logging.


OLD Post:

hi,
i use win 8.1 x64 and i have amd a6 richland apu. below you will find a debug log.

with kodi 17 there is clearly a deinterlacing-bug, at least with amd/windows. i test this with german interlaced n24 channel (you can easy see if deinterlacing is working based on "moving letters" or "ticker board" or "laufschrift") let me explain:

i turn on channel n24 and every time, exactly after 5/6 seconds deinterlacing turns off and remains off. if i switch to another interlaced channel deinterlacing remains off. if i switch back to n24 deinterlacing remains off. if i swich to a progressiv channel and after that back to n24 deinterlacing is working for 5/6 seconds. if i stop pvr and start again deinterlacing is also working for 5/6 seconds.

here you will find a debug log with behaviour describet (kodi 17): http://pastebin.com/u8GWPqiy
Reply
#2
i have found the problem:
if i activate the option "adjust display refresh rate", every time deinterlacing stops working after 5 or 6 seconds. if i turn of that option deinterlacing is working fine. i did not have that behaviour with kodi 16 or older.

it would be nice if a developer can look into this. thanks in advance!
Reply
#3
Can you test to see if this happens with the earlier Alpha 2? development builds (wiki).
Reply
#4
just tested with a older krypton nightly (25.04.2016) i found on my hdd. exactly the same problem. if i enable "adjust display refresh rate" deinterlacing turns of after 5 or 6 seconds (same behaviour as describet in more detail in first post).
maybe it has to do with videoplayer rework. also (iirc) there were some deinterlacing related pr for kodi v17.
can anyone confirm / not confirm this issue?
is there anything else i can do to help fixing this bug?
Reply
#5
i found out a little more (latest nightly):

if deinterlacing turns off after 5 or 6 seconds i open the video settings. there i change deinterlacing mode from "auto" to "off". after changing that option there is no difference in video quality (because deinterlacing was allready off). after that i change deinterlacing back to "auto" and now deinterlacing starts to work again. but now deinterlacing works "forever", means deinterlacing does not turn off automatically after 5 or 6 seconds.

in debug log you will see that i start interlaced channel n24 at 12:05:49. then there are no entrys between 12:05:51 and 12:05:55. one of the entrys between 12:05:55 and 12:05:57 must help to find the issue. and the issue must have something to do with automatic refresh rate change (see post #2)
Reply
#6
found out more:
if i record a video from interlaced channel n24 (because i wanted to provide a test video here) and i watch this video later with kodi v17, i dont have any problems with deinterlacing. deinterlacing only automatically turns off after some seconds while watching live tv (mpeg2/sd).
Reply
#7
found out more, below you will find a summary with problem, things i found out and a new debug log with activated video component logging.

problem:
if i activate the option "adjust display refresh rate" deinterlacing turns off after some seconds (5-7) while watching live tv (interlaced mpeg2). (note: i dont know if deinterlacing is really "off" (from a technical point of view), but at least it looks like that to me from what i can see on the display). debug log: http://pastebin.com/HTUaaxPn



things i found out that could help to find the problem:
no deinterlacing problem if i turn off "adjust display refresh rate".

no problems with kodi 16 or older (edit: wrong, see post #8) or other software like mediaportal/dvbviewer.

other drivers dont help to solve the problem.

no deinterlacing problems if i deactivate dxva2.

no problems with deinterlacing if i play a record of that live-tv-content (thats why it makes no sense to provide a test-sample).

while live tv is running and deinterlacing has "turned off" i switch "deinterlace video": "automatic --- off --- automatic" and after that deinterlacing works perfectly fine without any problems as long as i watch that tv-channel.

while live tv is running and deinterlacing has "turned off" i switch "stereoscopic 3d-mode": "automatic --- .... ----automatic". while doing that a change in referesh rate takes place (50hz --- 23.976hz ----50hz ??) and after that deinterlacing starts to work again perfectly fine. note: i dont have that change in refresh rate while doing the same with kodi 16.

why deinterlacing works for a recorded file but not with "real live tv"? i have noticed one difference in behaviour: if i play a record and immediately turn on playerdebug action directly after start playing the recorded file the different video informations appear in the upper left of the screen and stay there until i close playerdebug manually. if i do the same with "real live tv" playerdebug action closes automaticaly after 5-7 seconds and exactly thats the point where deinterlacing "turns off".
Reply
#8
getting closer:

tested more and i think i know whats going on. but now i really need help of developer:

i was wrong with thinking this problem is kodi 17 only. i have the same problem with kodi 16, but with kodi 16 there is a setting that "masked" the problem or is working as a kind of "workaround". i mean the "fallback refreshrate" setting within tv-section. in kodi 16 i have set this to 50 hz and deinterlacing is working fine, if i disable this setting i have the same deinterlacing problems as with kodi 17.

in kodi 17 it seems the setting "fallback refreshrate" is broken with latest nightly. if i use kodi 17 from april and i set fallback refreshrate to 50hz deinterlacing is working fine. the relevant entry in debug log should be this:

21:00:01 T:3484 DEBUG: CRenderManager::Configure - change configuration. 720x576. display: 720x405. framerate: 50.00. format: DXVA

if i use latest nightlies and set fallbackrefreshrate 50hz i get this:

21:05:30 T:2316 DEBUG: CRenderManager::Configure - change configuration. 720x576. display: 720x405. framerate: 25.00. format: DXVA


i would say thats the problem!? refreshrate should be 50 but is 25 with latest nightlies. i think there are 2 problems:

1) "fallback refreshrate" seems to be broken sometime between april and september

2) why i need a "fallback refreshrate" to get 50hz? it seems kodi or driver are not able to detect and set the correct refreshrate.
Reply
#9
Please open a trac ticket with all relevant logfiles. It's hard to track bugs in the forum.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#10
@fritsch
Here you go http://trac.kodi.tv/ticket/16899
Reply
#11
found the culprint: its "KodiSetup-20160506-d035bb9-leanback3.exe"

from this version on i have problem with deinterlacing/refreshrate.

in other words it means "KodiSetup-20160505-902fd8e-master.exe" was the last working version (concerning refresh rate fallback in livetv section).

thanks @developers for your help.
Reply
#12
(2016-09-15, 18:52)Ed76 Wrote: found the culprint: its "KodiSetup-20160506-d035bb9-leanback3.exe"

from this version on i have problem with deinterlacing/refreshrate.

in other words it means "KodiSetup-20160505-902fd8e-master.exe" was the last working version (concerning refresh rate fallback in livetv section).

thanks @developers for your help.
Maybe that's the responsible commit: https://github.com/xbmc/xbmc/pull/9747/files
Reply
#13
found out more:

note: i only tested this with kodi 16.1 and "fallback refreshrate" = off, so as i describet, with that setting i get the same deinterlacing- problem as with actual v17 nightly.

if deinterlacing "turns off" after some seconds and i press a key on my remote that is mapped to command "one step back", the home-screen (gui) is showing up or the pvr-channel-list-gui window is showing up. in this moment deinterlacing begins to work again.

you all know confluence skin. i press the back-button on my remote and the video goes into this 2/3 screen (channel list view). exactly after pressing this remote button deinterlacing starts to work. if i only press "ok" button that shows up the video player navigation-osd deinterlacing remains off.

Note: to get that behaviour i describet i have to change one setting: i think its called the "zoom-factor" (in german: vergrösserung). by default this setting is 1. to get that strange behaviour i describet the zoomfactor must be bigger 1.0 (i have 1.03 for all my videos). if zoomfactor is 1.0 or smaller deinterlacing remains off after 6-7 seconds although i press the "one step back"-key.

will test this tomorrow with latest nightly
Reply
#14
AAARGHH!!!!

i "fixed" the problem.
after thinking about the really strange bahaviour described in last post #13 i tested kodi 15.2 because of dx9. no deinterlacing problems (also no need of that refreshrate fallback workaround). it was not 100% true when i wrote "other drivers dont help to solve the problem." because i only tested different versions of the "new" driver generation "crimson". after installing the old catalyst driver from july last year (15.7.1) deinterlacing works perfectly fine with latest kodi v17 nightly (without the need of fallback refreshrat workaround).

i think my next gpu will be a intel.

thanks for you help @fritsch, afedchin, fernetmenta and pünktchen!

btw: why says "player process info" "deinterlacing method" "unknown"? is this normal?
Reply

Logout Mark Read Team Forum Stats Members Help
krypton - deinterlacing isnt working correctly3
This forum uses Lukasz Tkacz MyBB addons.