•   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 22
  •   
Release Viaplay add-on thread
#16
(2016-09-22, 19:34)unZane Wrote: Do you have any plans to make something similar to C More? Wink That would make my kodi-box complete.
Thanx btw for making this awsome addon

I've thought about it, but I'm currently only subscribed to Handbollsligan on C More. I'd need to borrow someone's account that has full access to see if this would be possible to do. It depends on how they've encrypted their streams and whether their API is a total mess or not. I'd also need it to be unified across all Nordic countries to avoid having to write different code for each country. If you have a Swedish account with full access and would like to see if this is possible, then feel free to drop me a PM. Wink

(2016-09-22, 23:01)-Dis Wrote: I have problem with this addon. Every episode and movie stops playing exactly 37:00 minutes.

Part of log when episode stops playing.
Code:
23:56:12 T:140277985568512   DEBUG: [vialib]: URL: https://content.viaplay.fi/pc-fi/sarjat/x-files-the?seasonNumber=6&partial=1&block=2
23:56:12 T:140277985568512   ERROR: /var/lib/vdr/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:791: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.org/en/latest/security.html
                                              InsecureRequestWarning)

Edit. also found this when I tried continue watching from 36:59 minutes.
Code:
00:16:19 T:139883616802560   ERROR: /var/lib/vdr/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:791: InsecureRequestWarning: Unverified HTTPS request is being made. Ad$
                                              InsecureRequestWarning)
00:16:19 T:139884095129664  NOTICE: VideoPlayer: Opening: http://scandi-secure-vod.hls.adaptive.level3.net/Viaplay_Prod_-_Scandi/71/412/20273646_Layer5_x58008050d46b4716aecebcef947e8bb7.m3u8|Cookie=None
00:16:19 T:139884095129664 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
00:16:19 T:139883616802560  NOTICE: Creating InputStream
00:16:19 T:139883616802560  NOTICE: Creating Demuxer
00:16:20 T:139883616802560  NOTICE: Opening stream: 0 source: 256
00:16:20 T:139883616802560  NOTICE: Creating video codec with codec id: 28
00:16:20 T:139883616802560  NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
00:16:20 T:139883616802560  NOTICE: Creating video thread
00:16:20 T:139883616802560  NOTICE: Opening stream: 1 source: 256
00:16:20 T:139883616802560  NOTICE: Finding audio codec for: 86018
00:16:20 T:139882471069440  NOTICE: running thread: video_thread
00:16:20 T:139883616802560  NOTICE: Creating audio thread
00:16:20 T:139883616802560  NOTICE: Opening stream: 0 source: 1025
00:16:20 T:139882479462144  NOTICE: running thread: CVideoPlayerAudio::Process()
00:16:21 T:139883616802560  NOTICE: CVideoPlayer::OnExit()
00:16:21 T:139883616802560  NOTICE: VideoPlayer: eof, waiting for queues to empty
00:16:21 T:139883616802560  NOTICE: Closing stream player 1
00:16:21 T:139883616802560  NOTICE: Waiting for audio thread to exit
00:16:21 T:139882479462144  NOTICE: thread end: CVideoPlayerAudio::OnExit()
00:16:21 T:139883616802560  NOTICE: Closing audio device
00:16:21 T:139883616802560  NOTICE: Deleting audio codec
00:16:21 T:139883616802560  NOTICE: Closing stream player 2
00:16:21 T:139883616802560  NOTICE: waiting for video thread to exit
00:16:21 T:139882471069440   ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
00:16:21 T:139882471069440  NOTICE: thread end: video_thread
00:16:21 T:139883616802560  NOTICE: deleting video codec
00:16:21 T:139883616802560  NOTICE: Closing stream player 3
00:16:21 T:139884095129664  NOTICE: CVideoPlayer::CloseFile()
00:16:21 T:139884095129664  NOTICE: VideoPlayer: waiting for threads to exit
00:16:21 T:139884095129664  NOTICE: VideoPlayer: finished waiting

Edit2. Got it working. I need to limit bitrate to 720p from addon settings if setting is automatic then video stops playing at 37:00.

I'm guessing this is hardware/platform related because I haven't noticed this issue. It would be nice if you could post a full debug log with component specific logging for ffmpeg enabled. The log you posted cut out the relevant parts. :/
Reply
#17
(2016-09-23, 16:07)emilsvennesson Wrote: I'm guessing this is hardware/platform related because I haven't noticed this issue. It would be nice if you could post a full debug log with component specific logging for ffmpeg enabled. The log you posted cut out the relevant parts. :/

Here is full log with addon and ffmpeg debugging enabled: http://pastebin.ubuntu.com/xxxxxxxxxx

I don't think this is OS related because I tried this also with my mac and that also stops playing at 37:00 minutes.
With both systems I use latest krypton nightly builds.
Reply
#18
(2016-09-23, 17:40)-Dis Wrote:
(2016-09-23, 16:07)emilsvennesson Wrote: I'm guessing this is hardware/platform related because I haven't noticed this issue. It would be nice if you could post a full debug log with component specific logging for ffmpeg enabled. The log you posted cut out the relevant parts. :/

Here is full log with addon and ffmpeg debugging enabled: http://pastebin.ubuntu.com/xxxxxxxxx

I don't think this is OS related because I tried this also with my mac and that also stops playing at 37:00 minutes.
With both systems I use latest krypton nightly builds.
I just tried the latest Empire episode and I'm experiencing the same thing. There's definitely something in the 1080p streams from Viaplay that ffmpeg/Kodi doesn't like. I tried the same URL using VLC and that worked just fine. Seeing as this is a ffmpeg/Kodi issue, this issue is out of my control I'm afraid. :/

Would you like to submit this bug to the Kodi bug tracker (http://trac.kodi.tv)?

Edit: Never mind, I'm submitting the issue myself. :-)
Reply
#19
(2016-09-23, 18:15)emilsvennesson Wrote: I just tried the latest Empire episode and I'm experiencing the same thing. There's definitely something in the 1080p streams from Viaplay that ffmpeg/Kodi doesn't like. I tried the same URL using VLC and that worked just fine. Seeing as this is a ffmpeg/Kodi issue, this issue is out of my control I'm afraid. :/

Would you like to submit this bug to the Kodi bug tracker (http://trac.kodi.tv)?

Edit: Never mind, I'm submitting the issue myself. :-)

Thanks for submitting this issue to kodi bug tracker. Luckily addon works fine when bitrate is 720p, so this isn't huge issue for me.
Can you edit that pastebin address away from quote? I just noticed that it contains my personal information :/
Reply
#20
Edited the paste link
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
#21
(2016-09-23, 19:52)-Dis Wrote:
(2016-09-23, 18:15)emilsvennesson Wrote: I just tried the latest Empire episode and I'm experiencing the same thing. There's definitely something in the 1080p streams from Viaplay that ffmpeg/Kodi doesn't like. I tried the same URL using VLC and that worked just fine. Seeing as this is a ffmpeg/Kodi issue, this issue is out of my control I'm afraid. :/

Would you like to submit this bug to the Kodi bug tracker (http://trac.kodi.tv)?

Edit: Never mind, I'm submitting the issue myself. :-)

Thanks for submitting this issue to kodi bug tracker. Luckily addon works fine when bitrate is 720p, so this isn't huge issue for me.
Can you edit that pastebin address away from quote? I just noticed that it contains my personal information :/

Yeah, luckily it only seems to be affecting the 1080p streams. Here's the link to the submitted ticket: http://trac.kodi.tv/ticket/16926.

By the way, I'm definitely adding that the log may contain sensible information to the README. Sorry about that.
Reply
#22
Good news about the 37 minute-bug. :-) Turns out it was a ffmpeg bug that affected all segmented streams over 2 GB.

It's been resolved now and the fix will be included in future Krypton nightlies. Big thanks to the Kodi devs (especially Anssi) for resolving this so quickly.
Reply
#23
Hi,

Wonder full add-on, although Krypton did not show so stable yet.

One thing that would be an awesome feature (that might already be possible i may have missed something), is the ability to choose the next stream automatically.

Is this functionality available ?

//
Frisk
Reply
#24
Hi!

Nope, this is not (yet) supported. I would recommend you to open an issue on GitHub as it's easier to keep track on feature requests there.
Reply
#25
hey !! got this working by updating to kodi 17 Smile your putting out some amazing addons.
Reply
#26
Hi any update on the audio issue for live sports?
Reply
#27
(2016-10-17, 14:04)sasagr Wrote: Hi any update on the audio issue for live sports?

No, unfortunately not. Nothing has changed and it's getting unlikely that a fix for the issue (http://trac.kodi.tv/ticket/16670) will make it into Krypton stable. Sad
Reply
#28
Hi

Thank you for this amazing add-on Smile

Im having trouble with the default subtitle language.
I have chosen Denmark in country under the settings - but when I open movies or series it often starts up with a different subtitle language.

Is it possible to set/lock the default subtitle language or am I missing something?
Reply
#29
(2016-10-19, 16:24)sammeren Wrote: Hi

Thank you for this amazing add-on Smile

Im having trouble with the default subtitle language.
I have chosen Denmark in country under the settings - but when I open movies or series it often starts up with a different subtitle language.

Is it possible to set/lock the default subtitle language or am I missing something?

Hi! Selecting Danish in System -> Video -> Subtitles -> Preferred subtitle language should take care of this.
Reply
#30
hls4 is fixed now

edit: forgot to say thanks to emil for this wonderful plugin, c more would be great too Smile
Reply
  •   
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 22
  •   



Logout Mark Read Team Forum Stats Members Help
Viaplay add-on thread6
This forum uses Lukasz Tkacz MyBB addons.