•   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 154
  •   
Beta Advanced Emulator Launcher - Multi-emulator frontend for Kodi
Hi.  I am unable to get AEL to scan for Mega Drive ROMs under LibreELEC 8.2.5 for RPI3.  Scan for ROMs get me an error

Here's the log in Ubuntu Pastebin

https://paste.ubuntu.com/p/K9YKkTsxNv/

I have no problem with SNES, playstation, PC Engine, etc

Thanks
Reply
(2018-08-24, 23:21)stray_tachyon Wrote: Hi.  I am unable to get AEL to scan for Mega Drive ROMs under LibreELEC 8.2.5 for RPI3.  Scan for ROMs get me an error

Here's the log in Ubuntu Pastebin

https://paste.ubuntu.com/p/K9YKkTsxNv/

I have no problem with SNES, playstation, PC Engine, etc

Thanks
I'm with my phone, so short response. Remove the '/' character from the launcher name. In any case it's a bug, AEL should have done it for you when creating the report filename.
Reply
Im trying to make it work advanced  mame launcher git but doesnt work. It show error when buiild all db.

11:16:09.871 T:4304  NOTICE: AML INFO : mame_load_GameInit_DAT() Rows in data_dic 780
11:16:09.871 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Parsing "D:\MAME\dats\command.dat"
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Version "0.188"
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Rows in idx_list 146
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Rows in data_dic 146
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Entries in proper_idx_list 638
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Entries in proper_data_dic 638
11:16:10.153 T:4304  NOTICE: AML INFO : mame_build_MAME_main_database() Loading "C:\Users\xxxxx\AppData\Roaming\Kodi\userdata\addon_data\plugin.program.AML\MAME.xml"
11:16:11.093 T:4304   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'xml.etree.ElementTree.ParseError'>
                                            Error Contents: syntax error: line 1, column 0
                                            Traceback (most recent call last):
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\addon.py", line 37, in <module>
                                                resources.main.run_plugin(sys.argv)
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\main.py", line 393, in run_plugin
                                                _command_context_setup_plugin()
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\main.py", line 4714, in _command_context_setup_plugin
                                                DB = mame_build_MAME_main_database(PATHS, g_settings, control_dic, __addon_version__)
                                              File "C:\Users\xxxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\mame.py", line 3395, in mame_build_MAME_main_database
                                                event, root = context.next()
                                              File "C:\Program Files\Kodi\system\python\Lib\xml\etree\ElementTree.py", line 1271, in next
                                                raise e
                                            ParseError: syntax error: line 1, column 0
                                            -->End of Python script error report<--
11:16:15.379 T:3328  NOTICE: stop player
11:16:15.379 T:3328  NOTICE: Storing total System Uptime
11:16:15.379 T:3328  NOTICE: Saving settings
11:16:15.387 T:3328  NOTICE: Saving skin settings
11:16:15.391 T:3328  NOTICE: stop all

I tried with just history.dat, then tried to add many more dats, still same error. Couldnt find all the dats or inis the plugin ask for. Not sure if all are required.
Reply
(2018-08-24, 11:02)warrick Wrote: Hello,

I managed to install version .98 but.... I cannot create a Launcher for any of my emulators.
Is it possible to create a new launcher to launch retroarch with the proper INTENT for Android?. 

Thanks,
Warrick.
Check https://github.com/Wintermute0110/AEL-asset-library for good examples. What kind of android/system are you using?
If you are brave enough and a little patience then I might have a (very alpha) version where I am testing out a dedicated Retroarch launcher so you don't have to setup the intents yourself on Android. Fixing and testing some last parts so that it is ready to be merged.
Reply
(2018-08-25, 16:18)trihy Wrote: Im trying to make it work advanced  mame launcher git but doesnt work. It show error when buiild all db.

11:16:09.871 T:4304  NOTICE: AML INFO : mame_load_GameInit_DAT() Rows in data_dic 780
11:16:09.871 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Parsing "D:\MAME\dats\command.dat"
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Version "0.188"
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Rows in idx_list 146
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Rows in data_dic 146
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Entries in proper_idx_list 638
11:16:10.114 T:4304  NOTICE: AML INFO : mame_load_Command_DAT() Entries in proper_data_dic 638
11:16:10.153 T:4304  NOTICE: AML INFO : mame_build_MAME_main_database() Loading "C:\Users\xxxxx\AppData\Roaming\Kodi\userdata\addon_data\plugin.program.AML\MAME.xml"
11:16:11.093 T:4304   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'xml.etree.ElementTree.ParseError'>
                                            Error Contents: syntax error: line 1, column 0
                                            Traceback (most recent call last):
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\addon.py", line 37, in <module>
                                                resources.main.run_plugin(sys.argv)
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\main.py", line 393, in run_plugin
                                                _command_context_setup_plugin()
                                              File "C:\Users\xxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\main.py", line 4714, in _command_context_setup_plugin
                                                DB = mame_build_MAME_main_database(PATHS, g_settings, control_dic, __addon_version__)
                                              File "C:\Users\xxxxxx\AppData\Roaming\Kodi\addons\plugin.program.AML\resources\mame.py", line 3395, in mame_build_MAME_main_database
                                                event, root = context.next()
                                              File "C:\Program Files\Kodi\system\python\Lib\xml\etree\ElementTree.py", line 1271, in next
                                                raise e
                                            ParseError: syntax error: line 1, column 0
                                            -->End of Python script error report<--
11:16:15.379 T:3328  NOTICE: stop player
11:16:15.379 T:3328  NOTICE: Storing total System Uptime
11:16:15.379 T:3328  NOTICE: Saving settings
11:16:15.387 T:3328  NOTICE: Saving skin settings
11:16:15.391 T:3328  NOTICE: stop all

I tried with just history.dat, then tried to add many more dats, still same error. Couldnt find all the dats or inis the plugin ask for. Not sure if all are required.
If you are not using a recent version of MAME please upgrade to 0.196 at least (0.200 better). If you are already using a recent version, please post the full debug log. I need to see all the AML operations when building the DBs to determine what's going on, not just the crash point.
Reply
Hi. Im using mame 0.200.


All dats and inis are required? I have no idea where to find some of them.

I just pointed mame emulator path, rom path, history dat path, did the steps,extracting xml went good and bulding databases ends with error.

If should work with only history.dat, i will make a full log with only that dat.
Reply
(2018-08-25, 17:18)trihy Wrote: Hi. Im using mame 0.200.


All dats and inis are required? I have no idea where to find some of them.

I just pointed mame emulator path, rom path, history dat path, did the steps,extracting xml went good and bulding databases ends with error.

If should work with only history.dat, i will make a full log with only that dat.
I always use all DATs and INIs when developing. However, AML should work with any combination you like and even bare. Please post a full debug log. I will see your config and all the steps that lead to the crash. Also, last mame I tried myself was 0.199. if the devs introduced some change in the 0.200 XML that could be the cause of the crash.

You have links to the sites you can find the DATs and INIs in AML thread.
Reply
Hi, didnt knew about advance mame thread.

Sent you a pm.

Thanks
Reply
is there any way to view categorys eg beatem ups  driving,shooter ect, on the platforms ive set up
Reply
(2018-08-26, 03:05)kpop Wrote: is there any way to view categorys eg beatem ups  driving,shooter ect, on the platforms ive set up
I don't understand what you mean. Can you please elaborate?
Reply
(2018-08-25, 09:06)Wintermute0110 Wrote:
(2018-08-24, 23:21)stray_tachyon Wrote: Hi.  I am unable to get AEL to scan for Mega Drive ROMs under LibreELEC 8.2.5 for RPI3.  Scan for ROMs get me an error

Here's the log in Ubuntu Pastebin

https://paste.ubuntu.com/p/K9YKkTsxNv/

I have no problem with SNES, playstation, PC Engine, etc

Thanks
I'm with my phone, so short response. Remove the '/' character from the launcher name. In any case it's a bug, AEL should have done it for you when creating the report filename. 
 Thanks a lot bud.  I updated the launcher's title and the scan works now.  I installed the Advanced Emulator Launcher through Gamestarter repository.  I would like to update the launcher title in GitHub.  Do you know which GitHub repository I should update?

Thanks
Reply
(2018-08-31, 05:06)stray_tachyon Wrote:
(2018-08-25, 09:06)Wintermute0110 Wrote:
(2018-08-24, 23:21)stray_tachyon Wrote: Hi.  I am unable to get AEL to scan for Mega Drive ROMs under LibreELEC 8.2.5 for RPI3.  Scan for ROMs get me an error

Here's the log in Ubuntu Pastebin

https://paste.ubuntu.com/p/K9YKkTsxNv/

I have no problem with SNES, playstation, PC Engine, etc

Thanks
I'm with my phone, so short response. Remove the '/' character from the launcher name. In any case it's a bug, AEL should have done it for you when creating the report filename.  
 Thanks a lot bud.  I updated the launcher's title and the scan works now.  I installed the Advanced Emulator Launcher through Gamestarter repository.  I would like to update the launcher title in GitHub.  Do you know which GitHub repository I should update?

Thanks 
Please report the issue in the GameStarter addon thread so @bite_your_idols can patch the addon.
Reply
Would you mind giving your installation guide another shot?  I followed it, and while it's running I'm just getting errors trying to do anything like add a launcher.  There must be more to the setup, dependencies or something.
Reply
(2018-09-03, 01:42)dib_ Wrote: Would you mind giving your installation guide another shot?  I followed it, and while it's running I'm just getting errors trying to do anything like add a launcher.  There must be more to the setup, dependencies or something.
I know the documentation is not the strongest point of the Advanced Launchers at the moment. As soon as I can I will improve it.

AEL/AML are totally independent plugins. You don't need to install any other Kodi addon nor third party addon. With the exception of MAME in the case of AML and the emulators/apps you want to launch in AEL, of course. Note that these are external programs unrelated to Kodi.

Can you please describe your setup and the errors you get better? Can you also provide a debug log as described in the first post of the thread?
Reply
Documentation is hard and I doubt you're getting paid for it.  I just wanted to be sure I'm not overlooking something because I tried setting this up on both a PC install of Kodi and my Nvidia Shield, and both are getting the same generic errors trying to add a launcher.

It looks to me like it can't resolve paths

08:11:21.577 T:137970226256 ERROR: GetDirectory - Error getting
08:11:21.832 T:138054976592 ERROR: Previous line repeats 2 times.
08:11:21.832 T:138054976592 ERROR: AEL VERB : fs_load_catfile() Loading special://profile/addon_data/plugin.program.advanced.emulator.launcher/categories.xml
08:11:27.389 T:138054976592 ERROR: Previous line repeats 1 times.
08:11:27.389 T:138054976592 ERROR: AEL INFO : Category ID not found. Creating laucher in addon root.
08:11:30.304 T:138054976592 ERROR: AEL INFO : launcherfactory.create() New launcher (launcher_type = NVIDIASTREAM)
08:11:30.305 T:138054976592 ERROR: AEL ERROR: SingleInstance::__exit__() Unhandled excepcion in protected code
08:11:30.322 T:138054976592 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.TypeError'>
Error Contents: _load() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/addon.py", line 39, in <module>
main.Main().run_plugin()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 305, in run_plugin
self.run_protected(command, args)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 391, in run_protected
self._command_add_new_launcher(VCATEGORY_ADDONROOT_ID)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 1006, in _command_add_new_launcher
launcher = self.launcherFactory.create(None)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/launchers.py", line 87, in create
return self._load(launcher_type, {}, None)
TypeError: _load() takes exactly 5 arguments (4 given)
-->End of Python script error report<--
08:11:34.879 T:138054976592 ERROR: AEL VERB : fs_load_catfile() Loading special://profile/addon_data/plugin.program.advanced.emulator.launcher/categories.xml
08:11:34.884 T:138054976592 ERROR: AEL INFO : Category ID not found. Creating laucher in addon root.
08:11:38.730 T:138054976592 ERROR: AEL INFO : launcherfactory.create() New launcher (launcher_type = ROM)
08:11:38.730 T:138054976592 ERROR: AEL ERROR: SingleInstance::__exit__() Unhandled excepcion in protected code
08:11:38.746 T:138054976592 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.TypeError'>
Error Contents: _load() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/addon.py", line 39, in <module>
main.Main().run_plugin()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 305, in run_plugin
self.run_protected(command, args)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 391, in run_protected
self._command_add_new_launcher(VCATEGORY_ADDONROOT_ID)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 1006, in _command_add_new_launcher
launcher = self.launcherFactory.create(None)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/launchers.py", line 87, in create
return self._load(launcher_type, {}, None)
TypeError: _load() takes exactly 5 arguments (4 given)
-->End of Python script error report<--
08:11:44.016 T:138054976592 ERROR: AEL VERB : fs_load_catfile() Loading special://profile/addon_data/plugin.program.advanced.emulator.launcher/categories.xml
08:11:44.021 T:138054976592 ERROR: AEL INFO : Category ID not found. Creating laucher in addon root.
08:11:46.440 T:138054976592 ERROR: AEL INFO : launcherfactory.create() New launcher (launcher_type = NVIDIASTREAM)
08:11:46.440 T:138054976592 ERROR: AEL ERROR: SingleInstance::__exit__() Unhandled excepcion in protected code
08:11:46.455 T:138054976592 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.TypeError'>
Error Contents: _load() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/addon.py", line 39, in <module>
main.Main().run_plugin()
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 305, in run_plugin
self.run_protected(command, args)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 391, in run_protected
self._command_add_new_launcher(VCATEGORY_ADDONROOT_ID)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/main.py", line 1006, in _command_add_new_launcher
launcher = self.launcherFactory.create(None)
File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.program.advanced.emulator.launcher/resources/launchers.py", line 87, in create
return self._load(launcher_type, {}, None)
TypeError: _load() takes exactly 5 arguments (4 given)
-->End of Python script error report<--
Reply
  •   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 154
  •   



Logout Mark Read Team Forum Stats Members Help
Advanced Emulator Launcher - Multi-emulator frontend for Kodi12
This forum uses Lukasz Tkacz MyBB addons.