•   
  • 1
  • 130
  • 131
  • 132
  • 133
  • 134(current)
Beta Advanced Emulator Launcher - Multi-emulator frontend for Kodi
(2020-05-11, 13:44)Wintermute0110 Wrote:
(2020-05-07, 11:58)GuiZ Wrote:
(2020-05-06, 09:27)Wintermute0110 Wrote: Please enable DEBUG in AEL settings BUT not in Kodi settings. If you enable debug in Kodi settings the log has so much information is very difficult to read. 
Hi,
Thx for your help,

Here's my log
yibipejuhe.kodi (paste) 

I do not see anything unusual in the log, the process /system/bin/am launches and returns with no error. However, execution last for a few dozen ms, which suggest that there is some kind of error with the /system/bin/am parameters. Also, you are using the --user 0 arguments, is your device rooted? That could be the cause.

I have a hunch. Can you change
Code:
org.dolphinemu.dolphin-emu/org.dolphinemu.dolphin-emu.ui.main.MainActivity

with
Code:
org.dolphinemu.dolphinemu/org.dolphinemu.dolphinemu.ui.main.MainActivity

in you launcher arguments and try? 
Hi,

I tried it but still no results. I had already tried this arguments and give a try with dolphin-emu (among other tests)
My device isn't rooted. To be honnest, i don't want to root it but it's a problem cause, I can't browse all files of the root directories with app like Solid explorer. I only can browse first level of the directory and i can't acess the subfolders. However, the androidmanifest.xml that i found on Dolphin Git clearly indicates org.dolphinemu.dolphinemu for package name and org.dolphinemu.dolphinemu.ui.main.MainActivity for the activity.
Maybe something to change on this side: -a android.intent.category.LAUNCHER /b /e "%rom%" ?
For user, I think it's Ok cause I use start --user 0 -n for Muppen64 and it works.
Reply
Just a heads up, I added another trailer view for Advanced Emulator Launcher in Arctic Zephyr 2. The new view is based on `Info Wall`.  Here is a view of it in action ~50s in after cycling through all the views

The pull request is here. Feel free to let me know what you think
https://github.com/jurialmunkey/skin.arc...2/pull/222

Reply
(2020-05-19, 16:09)mechevarria Wrote: Just a heads up, I added another trailer view for Advanced Emulator Launcher in Arctic Zephyr 2. The new view is based on `Info Wall`.  Here is a view of it in action ~50s in after cycling through all the views

The pull request is here. Feel free to let me know what you think
https://github.com/jurialmunkey/skin.arc...2/pull/222


Wonderful news @mechevarria , that's one of my favorite views in Arctic Zephyr 2. Will try asap.
Reply
@mechevarria Just tried the new view, very promising. Smile
There's still the weird hiccup transition before video snap starts (like in the other view) but that's probably a Kodi limitation

Is there a way to have the video snap instant stopping if we press back button? Else the video continues to play in the background in the main menu, for example.
Reply
(2020-05-21, 19:35)Zastava Wrote: @mechevarria Just tried the new view, very promising. Smile
There's still the weird hiccup transition before video snap starts (like in the other view) but that's probably a Kodi limitation

Is there a way to have the video snap instant stopping if we press back button? Else the video continues to play in the background in the main menu, for example.

I noticed that as well. I need to look into a way to prevent that from happening. Its a bit annoying to have to press the 'stop' button on my remote every once in a while
Reply
@Zastava , the code just got merged into main git repo. @drinfernoo do you when the add-on repo is going to pick up the new version?
Reply
(2020-05-24, 05:22)mechevarria Wrote: @Zastava , the code just got merged into main git repo. @drinfernoo do you when the add-on repo is going to pick up the new version?

I'll probably get time to update it tomorrow afternoon Smile
Reply
(2020-05-24, 05:22)mechevarria Wrote: @Zastava , the code just got merged into main git repo. @drinfernoo do you when the add-on repo is going to pick up the new version?

@mechevarria Sounds good and many thanks again for your work!

@Wintermute0110 I'm having an issue when re scanning roms in a launcher to add new games to it. Basically all the previous added games get duplicated in the process so I need to delete all of those after. Maybe I'm doing something wrong when adding the new games?
Reply
(2020-05-25, 14:17)Zastava Wrote: @Wintermute0110 I'm having an issue when re scanning roms in a launcher to add new games to it. Basically all the previous added games get duplicated in the process so I need to delete all of those after. Maybe I'm doing something wrong when adding the new games?

The scanner must work in a bullet-proof way. I need a debug log as instructed in the first post to track the problem.
Reply
(2020-05-25, 14:21)Wintermute0110 Wrote:
(2020-05-25, 14:17)Zastava Wrote: @Wintermute0110 I'm having an issue when re scanning roms in a launcher to add new games to it. Basically all the previous added games get duplicated in the process so I need to delete all of those after. Maybe I'm doing something wrong when adding the new games?

The scanner must work in a bullet-proof way. I need a debug log as instructed in the first post to track the problem. 

@Wintermute0110 here: uyolidijaw.kodi (paste)

And thank you so much again in advance.

For this test just scanned again the Commodore Amiga launcher and it just duplicated the same games/roms already there. Maybe it's related to using a portable version of Kodi, assets included per your instructions before.
Reply
(2020-05-25, 20:38)Zastava Wrote:
(2020-05-25, 14:21)Wintermute0110 Wrote:
(2020-05-25, 14:17)Zastava Wrote: @Wintermute0110 I'm having an issue when re scanning roms in a launcher to add new games to it. Basically all the previous added games get duplicated in the process so I need to delete all of those after. Maybe I'm doing something wrong when adding the new games?

The scanner must work in a bullet-proof way. I need a debug log as instructed in the first post to track the problem. 

@Wintermute0110 here: uyolidijaw.kodi (paste)

And thank you so much again in advance.

For this test just scanned again the Commodore Amiga launcher and it just duplicated the same games/roms already there. Maybe it's related to using a portable version of Kodi, assets included per your instructions before.

Yes, having a portable installation is affecting the scanner. For example, the game Agony (Europe).zip is currently stored as

Code:
special://home\..\..\..\..\..\collections\Commodore Amiga\roms\Agony (Europe).zip

but in the current scanner the file name is

Code:
D:\Frontends station\frontends\Kodi_test\App\Kodi\portable_data\..\..\..\..\..\collections\Commodore Amiga\roms\Agony (Europe).zip

You must change the ROM path from the current

Code:
ROM path       "D:\Frontends station\frontends\Kodi_test\App\Kodi\portable_data\..\..\..\..\..\collections\Commodore Amiga\roms"

to

Code:
ROM path       "special://home\..\..\..\..\..\collections\Commodore Amiga\roms"

That should make the scanner to work correctly.
Reply
(2020-05-26, 09:08)Wintermute0110 Wrote:
(2020-05-25, 20:38)Zastava Wrote:
(2020-05-25, 14:21)Wintermute0110 Wrote: The scanner must work in a bullet-proof way. I need a debug log as instructed in the first post to track the problem. 

@Wintermute0110 here: uyolidijaw.kodi (paste)

And thank you so much again in advance.

For this test just scanned again the Commodore Amiga launcher and it just duplicated the same games/roms already there. Maybe it's related to using a portable version of Kodi, assets included per your instructions before.  

Yes, having a portable installation is affecting the scanner. For example, the game Agony (Europe).zip is currently stored as
Code:
special://home\..\..\..\..\..\collections\Commodore Amiga\roms\Agony (Europe).zip

but in the current scanner the file name is
Code:
D:\Frontends station\frontends\Kodi_test\App\Kodi\portable_data\..\..\..\..\..\collections\Commodore Amiga\roms\Agony (Europe).zip

You must change the ROM path from the current
Code:
ROM path "D:\Frontends station\frontends\Kodi_test\App\Kodi\portable_data\..\..\..\..\..\collections\Commodore Amiga\roms"

to
Code:
ROM path "special://home\..\..\..\..\..\collections\Commodore Amiga\roms"

That should make the scanner to work correctly.  

The weird thing is that I already have that in the launcher settings, the portable paths. But it seems the scanner always put absolute paths to files after scanning. Then I need to change them in AEL related files to relative/portable as you show. So maybe it duplicates the files that were already scanned before because it doesn't recognize the portable paths?
Reply
(2020-05-26, 12:31)Zastava Wrote: The weird thing is that I already have that in the launcher settings, the portable paths. But it seems the scanner always put absolute paths to files after scanning. Then I need to change them in AEL related files to relative/portable as you show. So maybe it duplicates the files that were already scanned before because it doesn't recognize the portable paths?

If you go to the Launcher context menu, go to "View Launcher", "View Launcher data". The rompath field there starts with special://... or D:\Frontends station\?
Reply
(2020-05-27, 05:37)Wintermute0110 Wrote:
(2020-05-26, 12:31)Zastava Wrote: The weird thing is that I already have that in the launcher settings, the portable paths. But it seems the scanner always put absolute paths to files after scanning. Then I need to change them in AEL related files to relative/portable as you show. So maybe it duplicates the files that were already scanned before because it doesn't recognize the portable paths?

If you go to the Launcher context menu, go to "View Launcher", "View Launcher data". The rompath field there starts with special://... or D:\Frontends station\
First one, the portable path with special://...
Reply
  •   
  • 1
  • 130
  • 131
  • 132
  • 133
  • 134(current)
 
Thread Rating:
  • 12 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Advanced Emulator Launcher - Multi-emulator frontend for Kodi512
This forum uses Lukasz Tkacz MyBB addons.