Do not scan inside archives

I have the habit of saving music I digitally bought into a zip file (or save the zip file that I downloaded). The extractet music file I normalize according to my naming scheme etc. Therefore I have stores some music twice. Kodi scans inside archives, which makes the music also appears twice in the library.

How can I disable scanning inside archives?

it can be controlled through an advancedsettings file.

the 'excludefromscan' option should do what you need:

another option that might work is to remove the .zip extension for music files:
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.


Works fine.

But it also seems to have an effect on removing music. That's what I did:

- Quit Kodi
- Modify (create) advancedsettings.xml
- Refresh / Cleanup library -> No effect
- Remove source -> All tracks were removed, only the ones inside the zip file not.
- Delete ~/.kodi/userdata/Database/MyVideos99.db
- Readd source, rescan, no tracks from inside zip files anymore.

Seems to work...

Logout Mark Read Team Forum Stats Members Help
Do not scan inside archives0
This forum uses Lukasz Tkacz MyBB addons.