Linux Can't detect CEC signal on screen
#1
Hello,

My TV is a SAMSUNG UE55D8000.
My PC is an Intel NUC D34010WYK 120SSD 4GB RAM with Kodi on Ubuntu 14.04
My CEC adapter is the external USB one from Pulse-Eight.

I can't get CEC to work with Kodi.

When I start the system, I see nothing on the TV screen. If I SSH into the Linux System below Kodi, I actually can see that the PC is detecting the CEC signal, but why isn't it shown on screen?

Can you help?

Thanks.


Code:
:~$ cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 3.0.1
no serial port given. trying autodetect:
path:     /sys/devices/pci0000:00/0000:00:14.0/usb2/2-3
com port: /dev/ttyACM0

opening a connection to the CEC adapter...
DEBUG:   [              16]    Broadcast (F): osd name set to 'Broadcast'
DEBUG:   [              16]    connection opened, clearing any previous input and waiting for active transmissions to end before starting
DEBUG:   [              16]    communication thread started
DEBUG:   [              27]    turning controlled mode on
NOTICE:  [              48]    connection opened
DEBUG:   [              48]    processor thread started
DEBUG:   [              48]    << Broadcast (F) -> TV (0): POLL
TRAFFIC: [              48]    << f0
DEBUG:   [              48]    setting the line timeout to 3
DEBUG:   [              84]    >> POLL sent
DEBUG:   [              84]    TV (0): device status changed into 'present'
DEBUG:   [              84]    << requesting vendor ID of 'TV' (0)
TRAFFIC: [              84]    << f0:8c
TRAFFIC: [             282]    >> 0f:87:00:00:f0
DEBUG:   [             282]    TV (0): vendor = Samsung (0000f0)
DEBUG:   [             282]    >> TV (0) -> Broadcast (F): device vendor id (87)
DEBUG:   [             282]    expected response received (87: device vendor id)
DEBUG:   [             282]    replacing the command handler for device 'TV' (0)
NOTICE:  [             282]    registering new CEC client - v3.0.1
DEBUG:   [             282]    detecting logical address for type 'recording device'
DEBUG:   [             282]    trying logical address 'Recorder 1'
DEBUG:   [             282]    << Recorder 1 (1) -> Recorder 1 (1): POLL
TRAFFIC: [             282]    << 11
DEBUG:   [             318]    CEC transmission - received response - TRANSMIT_FAILED_ACK
TRAFFIC: [             318]    << 11
DEBUG:   [             355]    CEC transmission - received response - TRANSMIT_FAILED_ACK
DEBUG:   [             355]    >> POLL not sent
DEBUG:   [             355]    using logical address 'Recorder 1'
DEBUG:   [             355]    Recorder 1 (1): device status changed into 'handled by libCEC'
DEBUG:   [             355]    Recorder 1 (1): power status changed from 'unknown' to 'on'
DEBUG:   [             355]    Recorder 1 (1): vendor = Pulse Eight (001582)
DEBUG:   [             355]    Recorder 1 (1): CEC version 1.4
DEBUG:   [             355]    AllocateLogicalAddresses - device '0', type 'recording device', LA '1'
DEBUG:   [             355]    setting ackmask to  2
DEBUG:   [             360]    Recorder 1 (1): osd name set to 'CECTester'
DEBUG:   [             361]    Recorder 1 (1): menu language set to 'eng'
DEBUG:   [             361]    GetPhysicalAddress - trying to get the physical address via ADL
DEBUG:   [             361]    GetPhysicalAddress - ADL returned physical address 0000
DEBUG:   [             361]    GetPhysicalAddress - trying to get the physical address via nvidia driver
DEBUG:   [             361]    GetPhysicalAddress - nvidia driver returned physical address 0000
DEBUG:   [             361]    GetPhysicalAddress - trying to get the physical address via drm files
DEBUG:   [             361]    GetPhysicalAddress - drm files returned physical address 0000
DEBUG:   [             361]    GetPhysicalAddress - trying to get the physical address from the OS
DEBUG:   [             361]    GetPhysicalAddress - OS returned physical address 0000
NOTICE:  [             361]    setting HDMI port to 1 on device TV (0)
DEBUG:   [             361]    Recorder 1 (1): physical address changed from ffff to 1000
DEBUG:   [             361]    << Recorder 1 (1) -> broadcast (F): physical adddress 1000
TRAFFIC: [             361]    << 1f:84:10:00:01
DEBUG:   [             496]    using persisted autonomous mode setting: 'enabled'
DEBUG:   [             501]    using persisted CEC version setting: '1.4'
DEBUG:   [             506]    using persisted logical address setting: 'Recorder 1'
DEBUG:   [             512]    using persisted device type setting: 'recording device'
DEBUG:   [             517]    using persisted logical address mask setting: '206'
DEBUG:   [             532]    using persisted device name setting: 'CECTester'
DEBUG:   [             537]    using persisted physical address setting: '1000'
NOTICE:  [             538]    CEC client registered: libCEC version = 3.0.1, client version = 3.0.1, firmware version = 7, firmware build date: Wed Apr 13 10:36:11 2016 +0000, logical address(es) = Recorder 1 (1) , base device: TV (0), HDMI port number: 1, physical address: 1.0.0.0,  compiled on Fri Jul  3 17:23:36 UTC 2015 by [email protected] on Linux 3.19.0-21-generic (x86_64), features: P8_USB, P8_detect, randr
DEBUG:   [             538]    << Recorder 1 (1) -> TV (0): OSD name 'CECTester'
TRAFFIC: [             538]    << 10:47:43:45:43:54:65:73:74:65:72
DEBUG:   [             813]    << requesting power status of 'TV' (0)
TRAFFIC: [             813]    << 10:8f
TRAFFIC: [             964]    >> 01:90:00
waiting for input
DEBUG:   [             964]    TV (0): power status changed from 'unknown' to 'on'
DEBUG:   [             964]    expected response received (90: report power status)
DEBUG:   [             964]    >> TV (0) -> Recorder 1 (1): report power status (90)
TRAFFIC: [            3955]    >> 01:44:04
DEBUG:   [            3955]    key pressed: right (4)
DEBUG:   [            3955]    making Recorder 1 (1) the active source
DEBUG:   [            3955]    marking the adapter as active source
DEBUG:   [            3955]    >> TV (0) -> Recorder 1 (1): user control pressed (44)
NOTICE:  [            3961]    >> source activated: Recorder 1 (1)
TRAFFIC: [            4179]    >> 01:45
DEBUG:   [            4179]    key released: right (4)
DEBUG:   [            4179]    >> TV (0) -> Recorder 1 (1): user control release (45)
TRAFFIC: [            4799]    >> 01:44:04
DEBUG:   [            4799]    key pressed: right (4)
DEBUG:   [            4799]    >> TV (0) -> Recorder 1 (1): user control pressed (44)
TRAFFIC: [            5028]    >> 01:45
DEBUG:   [            5028]    key released: right (4)
DEBUG:   [            5028]    >> TV (0) -> Recorder 1 (1): user control release (45)
TRAFFIC: [          253321]    >> 01:44:04
DEBUG:   [          253321]    key pressed: right (4)
DEBUG:   [          253321]    >> TV (0) -> Recorder 1 (1): user control pressed (44)
TRAFFIC: [          253545]    >> 01:45
DEBUG:   [          253545]    key released: right (4)
DEBUG:   [          253545]    >> TV (0) -> Recorder 1 (1): user control release (45)
Reply



Logout Mark Read Team Forum Stats Members Help
Can't detect CEC signal on screen0
This forum uses Lukasz Tkacz MyBB addons.