• 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7
v17 Auto de-interlacing (in PVR streams) does not always work
#16
Great how you are trying to help me out! However, I tried the new test build, but I'm not sure anything has changed.

Here is a debug log: http://pastebin.com/n2R2rN0w
I tried a few channels, then settled on BBC World News HD, from 20:01:21. I did the same as before: watch tv (interlaced), enter video menu, set de-interlacing to off, the back to DXVA, then TV picture is great.

As you can see in the log, I made two screenshots.
screenshot009.png (bad): http://imgur.com/a/Z5nwf (zoom in 100% on the text in the bottom)
screenshot010:png (great): http://imgur.com/a/et1ns



However - and I may be imagining this - I think I noticed the following:
I watched the TV channel, saw it was not de-interlaced properly, then I set de-interlacing to Off (in the video menu), and I think I noticed the de-interlacing get worse! It's a moving picture so I can't really compare, but I think the edges got a little more jagged in movement. When I turned the de-interlacing to DXVA, everything was OK. Like I said, I'm not sure, and maybe that also happened with the previous nightlies I used, but then again, maybe it's a clue about where the bug is. Could there be more than one way of de-interlacing with DXVA, a good one and a sub-average one -- and that Kodi and/or the driver have difficulty choosing the right way? But I guess you'll know better than me.
Reply
#17
could you test this build please: http://mirrors.kodi.tv/test-builds/win32...a-dxva.exe when it will be available at the mirrors.
Reply
#18
Okay, I tried that build. I've only had time to test it for about 10 minutes. So far, so good! No de-interlacing problems in live TV.

However, with the previous nightlies, there were also periods in which there was no problem. I'll check more later tonight or maybe tomorrow.

If I find anything, I'll report back. For now, I'm (cautiously) optimistic that this has fixed it!


Just curious, what have you changed?
Reply
#19
I will try to explain without a lot of technical words...

To proper deinterlacing the driver requires a set of past or/and future frames. At the start of playback Kodi has not enough past/future frames and seems AMD driver decides that video is progressive even if the flag has an interlaced value. The main issue in that the driver ignore flag value till it will be changed (You are changing it's value through OSD settings). The workaround is resetting flag value for every frame (set it to progressive and then back to interlaced).
Reply
#20
So far I haven't seen the obvious failing de-interlacing again. So, I guess this has fixed it! Thanks!
Reply
#21
I was just about to start a new thread on this problem, glad to see it's already been looked into. I'm running Krypton Beta3 on an Intel NUC (so Intel integrated GPU) and have had this problem since upgrading from Jarvis. Any time I watch a 1080i broadcast that needs deinterlacing, I have to bring up the video OSD and toggle deinterlacing from DXVA to Off to DXVA again and then it works.

I'll try this test build when I get home from work and let you know if it fixes it here too.
Reply
#22
Well I didn't have much time to test but from the brief test I did do, this fix seems to have done the trick on the NUC. On beta3, most channels whether H264 or MPEG2 would produce immediately obvious interlacing artefacts whereas with this build I couldn't spot any. Thank you afedchin for this, it was a fairly serious issue which was making me consider rolling back to Jarvis but you've saved me from that.
Reply
#23
Hi,
I must confirm a problem in beta 3 with deinterlacing in PVR streams. I try http://mirrors.kodi.tv/test-builds/win32...a-dxva.exe - no improvement.
After returning to beta 2 is OK.

My hardware:
Wintel Pro W8 PRO Intel Z8300
Windows10 64bit
CPU: Intel Atom x5-Z8300 Cherry Trail (quad-core, up to 1.8GHz)
GPU: Intel HD Gen8 Graphics

Regards,
MariuCh
Reply
#24
Is there any way to tell when this fix has made it into a nightly build or is that not on the cards yet?
Reply
#25
(2016-10-11, 22:45)MariuCh Wrote: Hi,
I must confirm a problem in beta 3 with deinterlacing in PVR streams. I try http://mirrors.kodi.tv/test-builds/win32...a-dxva.exe - no improvement.
After returning to beta 2 is OK.

My hardware:
Wintel Pro W8 PRO Intel Z8300
Windows10 64bit
CPU: Intel Atom x5-Z8300 Cherry Trail (quad-core, up to 1.8GHz)
GPU: Intel HD Gen8 Graphics

Regards,
MariuCh

If you want to delay a solution for this bug, please continue to not post any debuglogs ...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#26
Hopefully these logs will help. The first one https://paste.ee/r/YwRIH i started a pvr channel as normal you can see it doing the proper deinterlacing for about 5 seconds or so then it just stops deinterlacing and the picture goes back to be awful. The second https://paste.ee/r/KqeFV same again started the same channel and let it do its thing, then after about 15 seconds i opened video settings and turned it from DXVA to off and back to DXVA which resulted in me having a better viewing experience.

KodiSetup-20161016-63b8843-master
AMD 390x
Whatever the latest crappy AMD drivers

EDIT: tested using HD cable channels not satellite not sure if it make a difference, i can retest using SD channels if needed
Reply
#27
(2016-10-16, 13:45)komplex Wrote: Hopefully these logs will help. The first one https://paste.ee/r/YwRIH i started a pvr channel as normal you can see it doing the proper deinterlacing for about 5 seconds or so then it just stops deinterlacing and the picture goes back to be awful. The second https://paste.ee/r/KqeFV same again started the same channel and let it do its thing, then after about 15 seconds i opened video settings and turned it from DXVA to off and back to DXVA which resulted in me having a better viewing experience.

KodiSetup-20161016-63b8843-master
AMD 390x
Whatever the latest crappy AMD drivers

EDIT: tested using HD cable channels not satellite not sure if it make a difference, i can retest using SD channels if needed

So, especially for you - it should be working fine using the build @afedchin posted, right?
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#28
(2016-10-16, 16:17)fritsch Wrote: So, especially for you - it should be working fine using the build @afedchin posted, right?

No, i have the same issue as above with the build from afedchin and the latest nightlies. I can do the same test with the build from afedchin if you want to take a look

EDIT: Done exactly the same as the tests above just with the build from afedchin and got the same result as with the nightlies, here's the logs
1. https://paste.ee/r/r9paB
2. https://paste.ee/r/s5PAS
Reply
#29
Some with a recording? Can you post the recording? (100 MB?)

Here is a testfile for you: http://solidrun.maltegrosse.de/~fritsch/1080i50_h264.ts
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#30
Does seem weird that he is still having issues seeing as my TV source is UK satellite too and the fix works here. I don't have access to subscription HD channels but I certainly noticed the original problem on FTA channels. Does komplex have the issue with BBC/ITV channels?
Reply
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7

Logout Mark Read Team Forum Stats Members Help
Auto de-interlacing (in PVR streams) does not always work1
This forum uses Lukasz Tkacz MyBB addons.