•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   
v17 Auto de-interlacing (in PVR streams) does not always work
#61
Going right back to the original question, I've become completely confused by the deinterlacing options in Kodi 17, can someone straighten this out for me?

I only seem to be able to either force deinterlacing on for everything or have it off for everything. I have no 'Auto' option. With render method set to Auto or DXVA, my only deinterlacing options are 'DXVA' or 'Off'.

With render method set to 'Software', I only have 'Off', 'Deinterlace (half)' and 'Deinterlace (full)'

Once I noticed the problem, I see that with hardware acceleration on, everything I play whether it be 1080i HDTV from satellite or a 24p Blu-ray movie, if I bring up the video OSD, deinterlacing is set to 'DXVA'. If I change this to 'Off' for a 24p movie, it reverts to DXVA again when I play something else. If I set deinterlacing to 'Off' then 'set as default for all media' it does just that. Deinterlacing is now always off, even for 1080i HDTV and I must manually enable it to fix the combing. I'm sure I used to have an Auto option for deinterlacing, was this as far back as Jarvis? I honestly can't remember! Any guidance on this would be most appreciated.
Reply
#62
You can't force deinterlacing. You can turn it off or set an algo that is used only if content is interlaced.
Reply
#63
As FernetMenta said de-interlacing is used only if content is interlaced. Deinterlace progressive content doesn't make sense. 'Auto' option called now 'DXVA' to remove misunderstandings. because no all understand what 'Auto' means. There is no functional changes, just a renaming.
Reply
#64
(2016-11-11, 09:13)afedchin Wrote: There is no functional changes, just a renaming.

This makes me puzzled then...because in Jarvis I didn't have the issue of some video not de-interlaced...

Weekend is coming...hope I will have time to report you with a log. Wink
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#65
(2016-11-11, 11:51)axlt2002 Wrote:
(2016-11-11, 09:13)afedchin Wrote: There is no functional changes, just a renaming.

This makes me puzzled then...because in Jarvis I didn't have the issue of some video not de-interlaced...

Weekend is coming...hope I will have time to report you with a log. Wink

You mix up two different things. The "not de-interlaced" issue has nothing to do with settings. As already mentioned in this thread: kodi does instruct the driver to deinterlace but the driver seems to ignore for some unknown reason.
Reply
#66
(2016-11-11, 16:49)FernetMenta Wrote:
(2016-11-11, 11:51)axlt2002 Wrote:
(2016-11-11, 09:13)afedchin Wrote: There is no functional changes, just a renaming.

This makes me puzzled then...because in Jarvis I didn't have the issue of some video not de-interlaced...

Weekend is coming...hope I will have time to report you with a log. Wink

You mix up two different things. The "not de-interlaced" issue has nothing to do with settings. As already mentioned in this thread: kodi does instruct the driver to deinterlace but the driver seems to ignore for some unknown reason.

Thanks for your answer FernetMenta.

Sorry, may be I was not clear. My point is: Jarvis 16.1 works while Krypton Nightly don't...using the exact same driver. So it seems that something has changed in how Krypton communicates with the driver...

Am I missing something?
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#67
We don't know the reason, that's why I said:

Quote:but the driver seems to ignore for some unknown reason
There were a lot of changes between v16 and v17 that could have caused this. Maybe it is some timing issue or maybe something else. What we know for sure is that we instruct the driver to deinterlace.
Reply
#68
(2016-11-11, 16:59)axlt2002 Wrote: Sorry, may be I was not clear. My point is: Jarvis 16.1 works while Krypton Nightly don't...using the exact same driver. So it seems that something has changed in how Krypton communicates with the driver...

Am I missing something?
In same time I have no issue with deintelacing with same v17 and v16

Edit:
@axlt2002, can you please provide a debug log, I need to check something
Reply
#69
As I posted before, I have been having the same issue with an intel machine with integrated graphics.

I have just tried switching to software render method in the video processing settings. Testing with live and recorded C4 HD interlaced PVR streams this seems to have fixed the problem for me. The video settings when playing still has the DXVA option but I don't need to toggle to deinterlace. Also, there is negligible CPU use when playing with these settings. Don't know if this is any help but I can provide logs if helpful? I've never done logs before but am sure I could work it out...


Sent from my iPhone
Reply
#70
Switching to SW render mode doesn't make sense if hw acceleration is used, because for hw accelerated videos render mode is DXVA in any case. You can also provide a Debug Log.
Reply
#71
(2016-11-12, 16:28)afedchin Wrote: Switching to SW render mode doesn't make sense if hw acceleration is used, because for hw accelerated videos render mode is DXVA in any case. You can also provide a Debug Log.


Yes, that's what I thought but it seems that the graphics driver is performing hardware rendering despite the software setting, but I may be very mistaken. I will provide a log.


Sent from my iPhone
Reply
#72
(2016-11-12, 16:30)Deebutt Wrote:
(2016-11-12, 16:28)afedchin Wrote: Switching to SW render mode doesn't make sense if hw acceleration is used, because for hw accelerated videos render mode is DXVA in any case. You can also provide a Debug Log.


Yes, that's what I thought but it seems that the graphics driver is performing hardware rendering despite the software setting, but I may be very mistaken. I will provide a log.


Sent from my iPhone (typie typie)


http://www.pastebin.com/10rTv8ah


Sent from my iPhone
Reply
#73
thanks. I think I know how fix the issue. let's wait a test build
Reply
#74
please try this build http://mirrors.kodi.tv/test-builds/win32...vc_wip.exe when it will be available on mirrors.
Reply
#75
(2016-11-12, 18:40)afedchin Wrote: please try this build http://mirrors.kodi.tv/test-builds/win32...vc_wip.exe when it will be available on mirrors.


This seems to have fixed it for me, deinterlacing kicks in after a few seconds even when the processing mode is set back to auto (rather than software as I did before).

Thanks!

The only issue is that my HDMI-CEC has stopped working so I will have to roll back to the beta...


Sent from my iPhone
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  •   



Logout Mark Read Team Forum Stats Members Help
Auto de-interlacing (in PVR streams) does not always work1
This forum uses Lukasz Tkacz MyBB addons.