v16 Commodore SID tune support
#16
Doh, I should have thought of that
Reply
#17
Quote:hi, i'm notspiff. you have to install and activate the audiodecoder.sidplay audio decoder add-on. sid files will then automagically show up in the browser, you don't have to add extensions manually or do anything else. for some reason i cannot fathom team kodi has chosen to deactivate all add-ons by default. you have to go into the add-on browser, browse your way to the audio decoder, open info then hit 'enable'. KISS my backend.

well, i'm having the exact problem! Sid files wont play
i'm using KODI 17.6 (build nov 19 2017).

i go into SYSTEM -> ADD-ons -> My add-ons -> Audio decoders -> Sidplay audio Decoder.
Then enable it. (it's version 1.1.0)

Then i go into a folder where i have a bunch of sid files. I can see the files, so that's good.
When i select a file, it wont play ("one or more items failed to play. Check the log for more information about this message")

When i go into context menu, and choose "Play using...", i can only select "PAPlayer (default)" or "Videoplayer". So, no sidplay or something to select.

I have kodi running on a nvidia shield TV.

What am i doing wrong?
Why are these sid files not playing?

Any help appreciated Smile
Reply
#18
do what it tells you to (check the log).
Reply
#19
log says:

ERROR: ADDON : Could not locate libaudiodecoder.sidplay.so
ERROR: CAudioDecoder: Unable to init Codec while loading file

for some reason it cannot find the sidplay audio decoder (while it is enabled), so it cannot play it.

Not sure why it's not located, while i enabled it in Addons

Do you have any ideas?
Reply
#20
@JRLS

Best you provide the full log to spiff or your questions will remain unresolved. See link in My Signature below.
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#21
for some reason pastebin.com is refusing my paste of my kodi.log, so i put it on my own server.

anyway, here is the debug log:

http://jrxs.net/pastebin/kodi.log.txt
Reply
#22
basically it looks like your installation of the add-on is broken. i'm not entirely sure how the android stuff is setup wrt noexec and such. the so file needs to sit in a particular location - the app installation folder - as that's the only filesystem mounted with exec.
Reply
#23
(2018-09-07, 13:40)JRLS Wrote: http://jrxs.net/pastebin/kodi.log.txt
According to that log you're running a banned repository (Super Repo), according to forum rules Official:Forum rules/Banned add-ons (wiki) it's likely you have data that is stomping existing code which will adversely effect the operation of Kodi and your support limited.
Reply
#24
Hello,

I have been following this thread for quite a while in the desperate hope I would find an answer to my problem...

I am using KODI on a Raspberry Pi using the Libreelec Distribution (Version 9.0.2 / KODI 17.2 Leia). I have been able to reproduce all the steps mentioned and thus far I found all the required settings.
As soon as I enable the required audio decoder (Version 1.1.3.3) and enter a folder containing a SIDfile - the screen goes black and KODI seems to re-start. Is there anything I am missing ?? As far as I can see the logs do not provide anything useful...

Regards,
Vorph
Reply
#25
(2019-07-06, 17:22)Vorph Wrote: As far as I can see the logs do not provide anything useful...
Maybe you do not have the same understanding of logs that we do? Possibly a good idea to provide one?
My Signature
Links to : Forum rules (wiki) | Banned_Add-ons (wiki) | Debug Log (wiki)
Links to : HOW-TO:Create_Music_Library (wiki) | HOW-TO:Create_Video_Library (wiki) || Artwork (wiki) | Basic controls (wiki) | Import-export library (wiki) | Movie sets (wiki) | Movie universe (wiki) | NFO files (wiki) | Quick start guide (wiki)
Reply
#26
(2019-07-06, 21:57)Karellen Wrote:
(2019-07-06, 17:22)Vorph Wrote: As far as I can see the logs do not provide anything useful...
Maybe you do not have the same understanding of logs that we do? Possibly a good idea to provide one? 
Oh... I am pretty sure about this  Rofl The next question that comes in mind is, how is the proper way of creating a debug file that hopefully provides some information. If you can please give me hint if:

- the kodi.log / kodi.old.log is sufficient
- there is a way to enable a more "deep" logging

I will happily provide all the information you need...

Regards,
Vorph
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Commodore SID tune support00