18 Nov 2019- TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

Win Can 24fps be played back smoothly @ 60Hz Refresh Rate?
#1
I'm facing a severe problem which actually doesn't have anything to do with Kodi as such, but unfortunately impacts Kodi directly.

I recently built an HTPC/Steam rig with Intel i7-6800K, GTX 1080 (Asus Rog Strix), 16GB DDR4, Intel 600p NVMe SSD on the Asus X99-A II motherboard.

My HTPC is connected to Yamaha RX-A2000 receiver, which is connected to Epson 5010 Projector.

The bottomline is this:

If I don't enable Stereoscopic 3D in nVidia Control Panel, I do get the option to set 1080p @ 24Hz under Resolution/Refresh Rate. However, 3D does not play on my projector then. Everything is 2D only.

If I do enable Stereoscopic 3D in nVidia Control Panel, 3D plays 1080p @ 24Hz, however, I don't get the option to set 1080p @ 24Hz for 2D content - I only get 50Hz, 59Hz & 60Hz - which produces horrible judder/stutter for 24 fps media.

All my HD media plays back absolutely smooth @ 24Hz refresh rate, but doesn't @ 60Hz refresh rate. So in nvidia control panel, I can either have NO 3D but 1080p @ 24Hz, or HAVE 3D, but 1080p @ 60Hz.

I'm essentially leaving Stereoscopic 3D "Disabled" in nvidia control panel, and setting my HTPC to 1080p 24Hz so all my 2D media plays back smoothly. I have to "Enable" Stereoscopic 3D in the nvidia control panel anytime I want to watch 3D, which is obviously a Royal Pain!

So my questions comes down to this, in order to have 3D enabled, if my Refresh Rate cannot be set to 24Hz but has to stay on 60Hz, is there any way to playback 24fps media WITHOUT judder/stutter and basically smooth on 60Hz refresh rate?

Either that - or someone with some remarkable experience here can help me resolve the above nvidia control panel issue so I can have 24Hz available for both 3D & 2D.

Thanks!
Reply
#2
Say a thanks to nvidia driver authors.

The Koid has a workaround for this issue:
please add to your advancedsettings.xml the following option:
Code:
<advancedsettings>
  <video>
    <usedisplaycontrolhwstereo>true</usedisplaycontrolhwstereo>
  </video>
</advancedsettings>
also please read more about AdvancedSettings at our wiki - http://kodi.wiki/view/Advancedsettings.xml
Reply
#3
(2016-10-03, 15:29)afedchin Wrote: Say a thanks to nvidia driver authors.

The Koid has a workaround for this issue:
please add to your advancedsettings.xml the following option:
Code:
<advancedsettings>
  <video>
    <usedisplaycontrolhwstereo>true</usedisplaycontrolhwstereo>
  </video>
</advancedsettings>
also please read more about AdvancedSettings at our wiki - http://kodi.wiki/view/Advancedsettings.xml

Thank you so much for your response.

I just want to understand this a little bit.

I actually do have an "advancesettings.xml" in my Userdata folder, being used for both Path Substitution (for a Client/Server setup) and also for launching an Extrenal Player for all my BD ISO's (PowerDVD).

So are you saying I can disable the Stereoscopic 3D in the nVidia Control Panel, thereby get the option to keep my desktop resolution at 1080p, 1920 X 1080 @ 24Hz Refresh Rate ... and then by adding the line above in "advancesettings.xml", when I do play 3D ISO, I will be able to play 3D?

Or am I not understanding this correctly?

Thanks again!
Reply
#4
24fps material plays fine on a 60hz display if you enable "sync playback to display". For versions < v17 you need to explicitly disable passthrough audio (as long as your audio stream is not Dolby Atmos, you don't have any advantage from passthrough anyway).
Reply
#5
(2016-10-03, 19:20)FernetMenta Wrote: 24fps material plays fine on a 60hz display if you enable "sync playback to display". For versions < v17 you need to explicitly disable passthrough audio (as long as your audio stream is not Dolby Atmos, you don't have any advantage from passthrough anyway).

Assuming you have a powerfull enough machine to decode video and audio at the same time, it may be true if kodi's audio decoding was good
Moanbag is in da place!
Reply
#6
(2016-10-03, 15:29)afedchin Wrote: Say a thanks to nvidia driver authors.

The Koid has a workaround for this issue:
please add to your advancedsettings.xml the following option:
Code:
<advancedsettings>
  <video>
    <usedisplaycontrolhwstereo>true</usedisplaycontrolhwstereo>
  </video>
</advancedsettings>
also please read more about AdvancedSettings at our wiki - http://kodi.wiki/view/Advancedsettings.xml

I'm sorry, I tried this but it didn't do anything. Unless I'm not understanding the function correctly.
I left Stereoscopic 3D disabled in nVidia Control Panel, leaving my HTPC resolution at 1080p, 1920 X 1080 @ 24Hz Refresh Rate.

I added the above to my "advancesettings.xml".

All 2D media played back smooth @ 24Hz.

However, when I launced a 3D Blu-ray ISO, my display did not switch to 3D. Continued playing at 1080p 24Hz 2D.

Like I said, I may not have understood the usage correctly.


(2016-10-03, 19:20)FernetMenta Wrote: 24fps material plays fine on a 60hz display if you enable "sync playback to display". For versions < v17 you need to explicitly disable passthrough audio (as long as your audio stream is not Dolby Atmos, you don't have any advantage from passthrough anyway).

If I have Stereoscopic 3D enabled, and my HTPC resolution at 1080p @ 60Hz, if I enable "sync playback to display", my display turns to 3D Display even for 2D Media. Basically because 1080p @ 24Hz is no longer available in my system for 2D, it recognizes anything at 24Hz to be 3D.

If you Google this particular nVidia issue online, you'll find the above info well documented. It happens to everyone in my scenario. You'll actually find the above right here in Kodi Community happening to other people.

Also, if I enable "sync playback to display", I get PCM on my receiver, I don't get DTS, Dolby Digital, DTS-HD Master or Dolby TrueHD anymore. I only get that if "sync playback to display" is disabled.

To be honest, I'd rather have the HTPC resolution @ 1080p 24Hz rather than 1080p 60Hz, because I've noticed when I'm playing games, during the cut scenes -- the video has judder/stutter if I leave my HTPC @ 60Hz, but it plays back smooth if I leave HTPC @ 24Hz.

I don't know if "sync playback to display" is necessarily going to fix my issue.

--------

Scouring the Internet, I was able to find a solution on Anandtech forums, as I've mentioned earlier, this nVidia 24hz issue is very well known and documented across the Internet.

The solution isn't very pretty, but fwiw, it's working and I can probably live with it -- seeing there is no other hope -- unless nVidia itself fixed this at some point.

I created 2 batch files, one for Enabling Stereoscopic 3D, one for Disabling Stereoscopic 3D, and very fortunately, if you leave your HTPC at 1080p 24Hz, when you enable Stereoscopic 3D, the resolution switches to 1080p 24Hz 3D, and when you disable Stereoscopic 3D, it switches back to 1080p 24hz (Not 60Hz or something).

I mapped the 2 batch files to a button on my remote control.

So basically:

- My HTPC runs at 1080p 24Hz all the time. All 2D Media plays back Smooth!
- If I want to watch 3D, just before I hit "Play", I hit the Yellow Button on my Remote Control. It enables Stereoscopic 3D in nVidia, and switches my desktop to 1080p 24Hz 3D ... and now my 3D Blu-ray ISO plays in 3D.
- After movie finishes, and right after I hit "Stop", I hit the Blue Button on my Remote Control. It disables Stereoscopic 3D in nVidia, and switches my desktop to 1080p 24Hz. All 2D Media plays back Smooth!

In this way, I'm not interacting with my HTPC using mouse/keyboard or going into nVidia Control panel, etc.

Only pain is hitting Yellow Button before watching 3D. Hitting Blue button after watching 3D. I'll live with it.

For anyone who needs it ...

ENABLE3D.bat
Code:
@echo off
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable
exit

DISABLE3D.bat
Code:
@echo off
"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable
exit

Irremote.Ini
Code:
YELLOW={run("C:\Windows\ENABLE3D.bat")}{mode(Default)}
BLUE={run("C:\Windows\DISABLE3D.bat")}{mode(Default)}
Reply
#7
(2016-10-03, 20:10)luci5r Wrote: I'm sorry, I tried this but it didn't do anything. Unless I'm not understanding the function correctly.
I left Stereoscopic 3D disabled in nVidia Control Panel, leaving my HTPC resolution at 1080p, 1920 X 1080 @ 24Hz Refresh Rate.

I added the above to my "advancesettings.xml".

All 2D media played back smooth @ 24Hz.

However, when I launced a 3D Blu-ray ISO, my display did not switch to 3D. Continued playing at 1080p 24Hz 2D.

Like I said, I may not have understood the usage correctly.
I said nothing about ISO 3D. Kodi doesn't support ISO 3D yet.

With this new option in advancedsetting you can enable Stereoscopic 3D in NVIDIA Control Panel and when you will play 24p content with "Adjust Display Refresh Rate" settings enabled your display will not switch to stereo 3D mode for 2D media and WILL switch to stereo 3D mode for 3D media only (except MVC content).

This option causes Kodi switch off Stereoscopic 3D in Windows Control Panel for all non 3D media.
Reply
#8
If everything is properly setup you should not have any of these problems.
I suspect you have missed something or added something that is a conflict.
You have two choices:
Use afedchin build or use normal Kodi build with your PDVD.
Each is setup completely different than the other.
Each has it's advantages and disadvantages and each works perfectly depending on your hardware IE: 1080p vs. 2160p.

Fwiw, you always want your Kodi GUI to run at 60Hz.
You want your frame rate to automatically match and change to your content.

I know you've been fighting this but at least you've been trying.
If you are truly stuck and would like some help, PM me and I'll remote into you and set things up for you.
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10/1903 MPC-BE\HC PDVD19 DVDFab3&5 KODI 19 PotPlayer 960-4GB/RGB 4:4:4/Desktop=60Hz/Video=Matched Refresh rates 8bit/65JS8500 UHD HDR 3D
Reply
#9
brazen1, if you do that, and find any solution, let us know.
There is nothing wrong with op's setup, what he describes is a known issue for nvidia gpus, since like forever.
Of course it affects only frame packed 3D (mvc and such), as it's the mode that requires Stereoscopic 3D to be enabled in nvidia cp. SBS/TAB work fine without that option enabled.
But that's not kodi related at all, since mvc isn't supported anyway.
Maybe through nvidia's custom resolution feature something could be done, but I haven't really bothered.
Reply
#10
I understand the problem.
I ran into it myself years ago.
That's why I came up with crude solutions and created a guide, so others wouldn't struggle as hard as I did.
It's probably difficult to understand or follow and why no one cares or uses it but myself and why I have not updated it.
To this day, my setup is 100% reliable and continues to perform perfectly imo and no reason anyone else's can't as well.

Windows desktop and Kodi run at 60Hz, as they should.
All my titles are 23.976 frame rates complete full ripped bdmv's in iso container and a handful of stripped mkv's, HEVC, 2D and 3D.
Match frame rate on start and stop is enabled.
Nvidia switches from 60Hz to 23/24 Hz when I press play, matching my titles frame rate.
When the title ends, Nvidia switches back to 60Hz and stays that way until another title is started.
When Kodi quits, to Windows desktop, it remains 60Hz, as it should.
I pass all audio including Atmos and DTS:X.
There is zero dropped or skipped frames and no micro stutter or any of the other complaints I read.
There is no interaction on my part required at all. This is all automated. Of course there is an option to manually intervene on the fly at any time.

3D is always enabled globally.
2D titles do not initiate any 3D modes.
3D titles do initiate the proper 3D mode be it SBS, TAB, or Frame Packed MVC, automatically.
I just press the on button for my glasses and sit back and enjoy.

If you use afedchin build, he has done everything required for the internal player.
I have problems using it with 4k hardware and Nvidia GTX 960 so I'm using Kodi nightlies with an external player, problem free.
Extra files must be created to automate the whole process but it is 100% seamless, meaning, just press play and the code(s) take care of the rest.
If it works for me, I'm damn sure it will work for others.

So, as far as letting you know about a solution, you'll find the guide in my signature. I know it needs updating. It's a couple years old now. Enough demand and I might do that. Waiting for W7, W8 users to get state of the art and use W10.
One major change is that nvstlink interaction is no longer required. No Nvidia mods are ever needed after setup of the drivers once. No mapping nvstlink on/off required anymore.
That alone is one thing wrong with the OP's setup and why I offered to help him.
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10/1903 MPC-BE\HC PDVD19 DVDFab3&5 KODI 19 PotPlayer 960-4GB/RGB 4:4:4/Desktop=60Hz/Video=Matched Refresh rates 8bit/65JS8500 UHD HDR 3D
Reply
#11
(2016-10-03, 20:45)afedchin Wrote:
(2016-10-03, 20:10)luci5r Wrote: I'm sorry, I tried this but it didn't do anything. Unless I'm not understanding the function correctly.
I left Stereoscopic 3D disabled in nVidia Control Panel, leaving my HTPC resolution at 1080p, 1920 X 1080 @ 24Hz Refresh Rate.

I added the above to my "advancesettings.xml".

All 2D media played back smooth @ 24Hz.

However, when I launced a 3D Blu-ray ISO, my display did not switch to 3D. Continued playing at 1080p 24Hz 2D.

Like I said, I may not have understood the usage correctly.
I said nothing about ISO 3D. Kodi doesn't support ISO 3D yet.

With this new option in advancedsetting you can enable Stereoscopic 3D in NVIDIA Control Panel and when you will play 24p content with "Adjust Display Refresh Rate" settings enabled your display will not switch to stereo 3D mode for 2D media and WILL switch to stereo 3D mode for 3D media only (except MVC content).

This option causes Kodi switch off Stereoscopic 3D in Windows Control Panel for all non 3D media.

Understood. However, I'm using an external player for Blu-ray 3D ISO playback and therefore your solution would not apply to me. I do thank you though. I had a feeling I wasn't clear on what you're suggesting, but I do understand it now.

(2016-10-03, 20:59)brazen1 Wrote: If everything is properly setup you should not have any of these problems.
I suspect you have missed something or added something that is a conflict.
You have two choices:
Use afedchin build or use normal Kodi build with your PDVD.
Each is setup completely different than the other.
Each has it's advantages and disadvantages and each works perfectly depending on your hardware IE: 1080p vs. 2160p.

Fwiw, you always want your Kodi GUI to run at 60Hz.
You want your frame rate to automatically match and change to your content.

I know you've been fighting this but at least you've been trying.
If you are truly stuck and would like some help, PM me and I'll remote into you and set things up for you.

brazen1 - your expertise & knowledge on these matters is legendary. More then half of what I know and learned in setting up Kodi on my machines came in part from you. However, I was about to respond to your post with pretty much word-to-word on what host505 responded below.

My issue is actually very existent w/ Nvidia. It's well documented, well reported, and well known across the globe. I have been in communication with Nvidia's tech support themselves and they have admitted to the limitation. This has absolutely nothing to with Kodi, PowerDVD or how I have my machine setup.

With nVidia, you can either have Stereoscopic 3D enabled and your 1080p, 1920 X 1080 2D resolutions limited to 60Hz without the 24Hz option; or you can have Stereoscopic 3D disabled, and get the 24Hz option.

The solution I found for this is also being used quite universally at this point, as I'm understanding, by most in my situation - as is there is no other known solution.

You may have misunderstood the issue, I'm not sure. Kodi itself works flawless; so does PowerDVD as external player for ISO's (Especially 3D), and so does media playback within Kodi.

If I had an Intel HD or AMD card - I would not be having this issue. This is specific to Nvidia.

(2016-10-03, 22:16)host505 Wrote: brazen1, if you do that, and find any solution, let us know.
There is nothing wrong with op's setup, what he describes is a known issue for nvidia gpus, since like forever.
Of course it affects only frame packed 3D (mvc and such), as it's the mode that requires Stereoscopic 3D to be enabled in nvidia cp. SBS/TAB work fine without that option enabled.
But that's not kodi related at all, since mvc isn't supported anyway.
Maybe through nvidia's custom resolution feature something could be done, but I haven't really bothered.

I agree. Thanks.
Reply
#12
(2016-10-04, 00:59)brazen1 Wrote: I understand the problem.
I ran into it myself years ago.
That's why I came up with crude solutions and created a guide, so others wouldn't struggle as hard as I did.
It's probably difficult to understand or follow and why no one cares or uses it but myself and why I have not updated it.
To this day, my setup is 100% reliable and continues to perform perfectly imo and no reason anyone else's can't as well.

Windows desktop and Kodi run at 60Hz, as they should.
All my titles are 23.976 frame rates complete full ripped bdmv's in iso container and a handful of stripped mkv's, HEVC, 2D and 3D.
Match frame rate on start and stop is enabled.
Nvidia switches from 60Hz to 23/24 Hz when I press play, matching my titles frame rate.
When the title ends, Nvidia switches back to 60Hz and stays that way until another title is started.
When Kodi quits, to Windows desktop, it remains 60Hz, as it should.
I pass all audio including Atmos and DTS:X.
There is zero dropped or skipped frames and no micro stutter or any of the other complaints I read.
There is no interaction on my part required at all. This is all automated. Of course there is an option to manually intervene on the fly at any time.

3D is always enabled globally.
2D titles do not initiate any 3D modes.
3D titles do initiate the proper 3D mode be it SBS, TAB, or Frame Packed MVC, automatically.
I just press the on button for my glasses and sit back and enjoy.

If you use afedchin build, he has done everything required for the internal player.
I have problems using it with 4k hardware and Nvidia GTX 960 so I'm using Kodi nightlies with an external player, problem free.
Extra files must be created to automate the whole process but it is 100% seamless, meaning, just press play and the code(s) take care of the rest.
If it works for me, I'm damn sure it will work for others.

So, as far as letting you know about a solution, you'll find the guide in my signature. I know it needs updating. It's a couple years old now. Enough demand and I might do that. Waiting for W7, W8 users to get state of the art and use W10.
One major change is that nvstlink interaction is no longer required. No Nvidia mods are ever needed after setup of the drivers once. No mapping nvstlink on/off required anymore.
That alone is one thing wrong with the OP's setup and why I offered to help him.

Ok - I take everything I said in the previous post back. I believe you do understand the issue, and it looks like you do have workarounds for this. At this moment I'm ridiculously tied up with work, but I'm most certainly going to need your help in implementing the solution - so I will touch base with you.

Thank you.
Reply
#13
I see we crossed posted....

Quote:With nVidia, you can either have Stereoscopic 3D enabled and your 1080p, 1920 X 1080 2D resolutions limited to 60Hz without the 24Hz option; or you can have Stereoscopic 3D disabled, and get the 24Hz option.

I too have read across the globe of this problem. I must be the luckiest person in the world to not experience it........... anymore.
Why do you think I crudely devised a workaround?
I can assure you, I have 3D enabled and never turn it off.
Windows and Kodi GUI are running at 60Hz.
When I start a 2D title, mkv or iso, it does not kick in any 3D mode at all.
The title starts playing, I press INFO for my display.
It says 3840 x 2160p @ 24Hz.
I stop the title and press INFO on the display.
It says 3840 x 2160p @ 60Hz.
This is in KODI or PDVD launched from Kodi.

I start a 3D title.
PDVD mounts all iso's.
Kodi internal player launches SBS's or TAB's.
3D mode switches to SBS, TAB, or MVC depending what the title was ripped to and launches the appropriate player.
I press INFO on my display.
It says 1920 x 1080 @ 24Hz.
I stop the title, KODI returns to 60Hz.
I quit KODI, Windows desktop is at 60Hz.

I don't know what else to tell you other than it does indeed work, perfectly.
I'm not an Nvidia rep or anything of the kind.
I'm just a user with a hobby.
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10/1903 MPC-BE\HC PDVD19 DVDFab3&5 KODI 19 PotPlayer 960-4GB/RGB 4:4:4/Desktop=60Hz/Video=Matched Refresh rates 8bit/65JS8500 UHD HDR 3D
Reply
#14
(2016-10-04, 01:34)brazen1 Wrote: I see we crossed posted....

Quote:With nVidia, you can either have Stereoscopic 3D enabled and your 1080p, 1920 X 1080 2D resolutions limited to 60Hz without the 24Hz option; or you can have Stereoscopic 3D disabled, and get the 24Hz option.

I too have read across the globe of this problem. I must be the luckiest person in the world to not experience it........... anymore.
Why do you think I crudely devised a workaround?
I can assure you, I have 3D enabled and never turn it off.
Windows and Kodi GUI are running at 60Hz.
When I start a 2D title, mkv or iso, it does not kick in any 3D mode at all.
The title starts playing, I press INFO for my display.
It says 3840 x 2160p @ 24Hz.
I stop the title and press INFO on the display.
It says 3840 x 2160p @ 60Hz.
This is in KODI or PDVD launched from Kodi.

I start a 3D title.
PDVD mounts all iso's.
Kodi internal player launches SBS's or TAB's.
3D mode switches to SBS, TAB, or MVC depending what the title was ripped to and launches the appropriate player.
I press INFO on my display.
It says 1920 x 1080 @ 24Hz.
I stop the title, KODI returns to 60Hz.
I quit KODI, Windows desktop is at 60Hz.

I don't know what else to tell you other than it does indeed work, perfectly.
I'm not an Nvidia rep or anything of the kind.
I'm just a user with a hobby.

brazen1: I don't know if you already saw my post above, [Link]; I completely agree - I believe you do understand the issue and have created workarounds. I've rescinded my previous comments in regards to your original post. I'm very, very interested in using your solutions to see if I can implement the same on my machine. Please bear with me as I'm extremely tied up today & tomorrow, but I will be reaching out to you for support on this issue. Thanks again for chipping in and for the wealth of knowledge you share. I appreciate it.
Reply
#15
(2016-10-03, 19:46)Gracus Wrote:
(2016-10-03, 19:20)FernetMenta Wrote: 24fps material plays fine on a 60hz display if you enable "sync playback to display". For versions < v17 you need to explicitly disable passthrough audio (as long as your audio stream is not Dolby Atmos, you don't have any advantage from passthrough anyway).

Assuming you have a powerfull enough machine to decode video and audio at the same time, it may be true if kodi's audio decoding was good

We decode and process lossless.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Can 24fps be played back smoothly @ 60Hz Refresh Rate?00