Hevc jerky in windows but totally fine in openelec
#1
Hi,
I wanted to move from openelec that i used for a long time to windows 10, i have a low end NUC with intel n2810 and 2gb ram.
So same hardware same video file same everything, in openelec 720p hevc plays perfectly fine, but in windows 10 its unsmooth video and audio is unsync with video. I tried to change advancedsettings.xml cache, it might helpd a little but still when the scene is fast the audio is comletly out of sync with video, tried with/without passthro, didnt notice a change.
In openelec i had kodi 15.2 and in windows kodi 17, so tried 15.2 in winsows - was exacly the same.

I also played the same video file in my old i3 laptop with windows 10 and there it was smooth and nice.

So how can i (try to) fix the playback in windows 10 in the nuc?

Thanks
Reply
#2
Get a faster NUC or run openelec. Windows 10 uses a lot of resources that Kodi would need to play hevc smoothly. Openelec is a lightweight system and frees up more resources for Kodi that it needs to play smooth hevc on low powered systems.
Reply
#3
I saw in other thread that 64 bit is much better for hevc and that windows version of kodi is 32 bit only (and my windows was 32bit, the openelec was 64) so i gave ubuntu a try, and its as fast as openelec, the video is running smoothly there.
So i guees i will use ubuntu instead of windows
Reply
#4
(2016-10-03, 14:54)liorwohl Wrote: Hi,
I wanted to move from openelec that i used for a long time to windows 10, i have a low end NUC with intel n2810 and 2gb ram.
So same hardware same video file same everything, in openelec 720p hevc plays perfectly fine, but in windows 10 its unsmooth video and audio is unsync with video. I tried to change advancedsettings.xml cache, it might helpd a little but still when the scene is fast the audio is comletly out of sync with video, tried with/without passthro, didnt notice a change.
In openelec i had kodi 15.2 and in windows kodi 17, so tried 15.2 in winsows - was exacly the same.

I also played the same video file in my old i3 laptop with windows 10 and there it was smooth and nice.

So how can i (try to) fix the playback in windows 10 in the nuc?

Thanks

I agree with lobsta. You should run openelec. It's a cool system and gives more capabilities for Kodi. Nod
Reply
#5
I wanted a browser and Transmission (that actually work) so openelec wasn't enough, as I said Ubuntu gives good performance like openelec so this is my solution.
Reply
#6
(2016-10-03, 19:06)liorwohl Wrote: I saw in other thread that 64 bit is much better for hevc and that windows version of kodi is 32 bit only (and my windows was 32bit, the openelec was 64) so i gave ubuntu a try, and its as fast as openelec, the video is running smoothly there.
So i guees i will use ubuntu instead of windows

This is the answer. Specifically, 32bit FFMPEG is not nearly as efficient at HEVC than the 64bit version used in OpenELEC. I had a thread trying to sort it out with some devs a while ago. You can also replicate the same issue using anything else using a 32bit version of FFMPEG.
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Hevc jerky in windows but totally fine in openelec51