[SOLVED] [Krypton] Passthrough not working
#1
I recently upgraded from Kodi 16.1 to 17 Beta 2 and noticed the passthrough audio setting was not working.

OS: Windows 10 (anniversary update)
CPU: Intel i7 4790 3.6 GHz
GPU: Intel HDGraphics 4600
Audio Device: WASAPI HDMI-PR-SC5509
Passthrough device: same

HDMI connected to Onkyo PR-SC5509 AVR receiver

Source: bluray disc DTS-HD 7.1

On the controller it shows: Multich PCM 7.1 (so the input is PCM and not DTS)
On the PC while the movie is playing (O key): DCA 32 bit 48000 bits (appears to be decoding the DTS audio track)

I had upgraded from JRiver to Kodi a year or so ago and so I tried it, the passthrough worked perfectly.

I then uninstalled Kodi 17 and reinstalled Kodi 16.1 and enabled passthrough.

For the same source I now get:

Onkyo: DTS HD Master 48kHz 7.1 (which means it is now getting a DTS bitstream from the PC)

So both JRiver and Kodi 16.1 passthrough work perfectly, so the problem is not windows or the drivers, but is definitely something in Krypton. I am using the same system, video and audio settings in both versions so I don't think it is that. I have reverted back to Kodi 16.1 and hoping that someday Krypton passthrough will work on this system. I am willing to assist in locating the problem if needed but for now thought I would simply report it to the development team. Didn't have any problems with Krypton, looking forward to returning to it.
Reply
#2
Take a look at this thread, you may find some answers there.
279185 (thread)
Reply
#3
Thanks Pasado, didn't see anything there, though I do agree that passthrough (bitstreaming) should pass the 'raw' audio stream directly out the HDMI port to the external controller. If PCM is being passed then it means the DTS audio is being decoded into analog PCM data and sent over the HDMI connection, which is why the controller displays PCM. In that case the PCM signal can be operated on by Kodi including the volume. But in passthrough the raw digital audio stream (DTS in this case) is not decoded and passed directly from the source to the destination, where it is then decoded in the external controller. Which means effects like volume adjustment cannot be made because it is still a DTS compressed signal.

My guess is something in Krypton is either ignoring the passthrough setting or it is incorrectly determining that the audio device cannot support bitstreaming and therefore the DTS decode is done in Kodi and sent out as a PCM stream. The good thing here is that Kodi 16.1 does work okay, so we can eliminate any OS problems or driver problems.
Reply
#4
(2016-10-04, 10:07)CraigNZ Wrote: Thanks Pasado, didn't see anything there, though I do agree that passthrough (bitstreaming) should pass the 'raw' audio stream directly out the HDMI port to the external controller. If PCM is being passed then it means the DTS audio is being decoded into analog PCM data and sent over the HDMI connection, which is why the controller displays PCM. In that case the PCM signal can be operated on by Kodi including the volume. But in passthrough the raw digital audio stream (DTS in this case) is not decoded and passed directly from the source to the destination, where it is then decoded in the external controller. Which means effects like volume adjustment cannot be made because it is still a DTS compressed signal.

My guess is something in Krypton is either ignoring the passthrough setting or it is incorrectly determining that the audio device cannot support bitstreaming and therefore the DTS decode is done in Kodi and sent out as a PCM stream. The good thing here is that Kodi 16.1 does work okay, so we can eliminate any OS problems or driver problems.

I'm afraid all that went way over my head haha, hopefully you will get help from someone who is more technically minded than myself
Reply
#5
If Sync Playback to display is enabled PT gets automatically disabled.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#6
Is the "Sync playback to display" tie to passthrough a Krypton feature? I just checked Kodi 16.1 and I have Sync enabled, but passthrough is working okay. But I do remember in Krypton having Sync also set. Maybe this feature didn't work correctly in 16.1 but now works in Krypton?
Reply
#7
Fritsch,

To test this I uninstalled Kodi 16.1 and installed 17 Beta 2 (Krypton). I then left "Sync playback to display" unchecked, enabled passthrough and then tested a couple of movies. You are correct, that was the problem. I can see how that would be required to work properly, looks like it didn't work in 16.1 and has been fixed in 17.

Thanks heaps for your help,
Reply
#8
With "Sync playback to display" enabled, in order for Kodi to maintain a/v sync sometimes audio will have to be resampled if there's any drift between the video clock and the audio clock, therefore the decision was taken that when "Sync playback to display" is enabled passthrough gets disabled to allow resampling to occur.
Reply
#9
Were do i find the setting sync playback to display?
Reply
#10
Thank you...This audio thing has been driving me nuts for a couple of days...I guess my theory was right that Kodi was decoding before it sent the signal to the AVR...
Reply
#11
This was driving me crazy too. Perhaps add a note in the audio menu that passthrough is disabled in this scenario? I don't remember Kodi operating this way - is this new?
Reply
#12
(2017-01-04, 12:55)deletedpenguin Wrote: This was driving me crazy too. Perhaps add a note in the audio menu that passthrough is disabled in this scenario? I don't remember Kodi operating this way - is this new?

Mmmh.....add a note?

And what about just reading?

Image
Moanbag is in da place!
Reply
#13
(2017-01-04, 16:48)Gracus Wrote:
(2017-01-04, 12:55)deletedpenguin Wrote: This was driving me crazy too. Perhaps add a note in the audio menu that passthrough is disabled in this scenario? I don't remember Kodi operating this way - is this new?

Mmmh.....add a note?

And what about just reading?

Image

Sorry if I wasn't clear. I meant add a note on the Audio menu where you can enable passthrough audio, similar to the one you've outlined there. At least for me, when passthrough wasn't working, I was looking in the audio menu - I didn't even think to look at the playback menu.
Reply
#14
...or better yet, implement functionality where if sync to display is enabled, it auto disables passthrough audio in the audio menu so we're not let to believe that it's working.
Reply
#15
(2017-01-04, 22:50)deletedpenguin Wrote: Sorry if I wasn't clear. I meant add a note on the Audio menu where you can enable passthrough audio, similar to the one you've outlined there. At least for me, when passthrough wasn't working, I was looking in the audio menu - I didn't even think to look at the playback menu.

There already is one there as well.
Reply
 
Thread Rating:
  • 3 Vote(s) - 4.33 Average



Logout Mark Read Team Forum Stats Members Help
[SOLVED] [Krypton] Passthrough not working4.333