•   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 13
  •   
Release FOX Sports GO - available in the official repository
(2017-02-17, 15:57)emilsvennesson Wrote:
(2017-02-14, 19:25)japes Wrote: Seems like foxsportsgo is still having issues. My system that I was able to log in the other day when we spoke is fine but now trying to validate the other installs are having the same issue the first one did. I guess I just need to keep trying and hope it works eventually.

Are you still having issues? It works fine for me now.

Yes, On my OSMC Raspberry Pi3 setup I still can't get it to activate. I've tried activating it and waiting 15 minutes before going back and hitting ok to make sure the full activation went through and it still didn't work. I just tried two more times. The first time it said to make sure I waited and ask me to retry and I did. The second time it acted as if it would work but then I got a error, check log message.

Code:
"/home/osmc/.kodi/addons/plugin.video.fsgo/default.py", line 5, in <module>
                                                addon.run()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 423, in run
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 387, in authenticate
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 372, in authenticate
                                                fsgo.login(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 272, in login
                                                self.get_access_token(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 107, in get_access_token
                                                reg_dict = json.loads(reg_data)
                                              File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
                                                return _default_decoder.decode(s)
                                              File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
                                                obj, end = self.raw_decode(s, idx=_w(s, 0).end())
                                              File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
                                                raise ValueError("No JSON object could be decoded")
                                            ValueError: No JSON object could be decoded
                                            -->End of Python script error report<--
16:35:21.176 T:1958294448   ERROR: GetDirectory - Error getting plugin://plugin.video.fsgo/
16:35:21.178 T:1958294448   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.fsgo/) failed
unRaid v6 pro:
ECS A885GM-A2 (V1.1) AM3 AMD 880G Motherboard
AMD Sempron 145 Sargas Single-Core 2.8 GHz
2GB RAM
Dockers: Kodi Headless and MariaDB for a centralized DB. MythTV or TVheadend (Still experimenting)
--
HTPC Win7:
Intel Core I3-2105 Dual-Core Processor 3.1 GHz 3 MB Cache LGA 1155
4GB (2 x 2GB) RAM
--
Extenders: RPI3 w/OSMC
Reply
(2017-02-24, 00:41)japes Wrote: Yes, On my OSMC Raspberry Pi3 setup I still can't get it to activate. I've tried activating it and waiting 15 minutes before going back and hitting ok to make sure the full activation went through and it still didn't work. I just tried two more times. The first time it said to make sure I waited and ask me to retry and I did. The second time it acted as if it would work but then I got a error, check log message.

Code:
"/home/osmc/.kodi/addons/plugin.video.fsgo/default.py", line 5, in <module>
                                                addon.run()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 423, in run
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 387, in authenticate
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 372, in authenticate
                                                fsgo.login(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 272, in login
                                                self.get_access_token(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 107, in get_access_token
                                                reg_dict = json.loads(reg_data)
                                              File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
                                                return _default_decoder.decode(s)
                                              File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
                                                obj, end = self.raw_decode(s, idx=_w(s, 0).end())
                                              File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
                                                raise ValueError("No JSON object could be decoded")
                                            ValueError: No JSON object could be decoded
                                            -->End of Python script error report<--
16:35:21.176 T:1958294448   ERROR: GetDirectory - Error getting plugin://plugin.video.fsgo/
16:35:21.178 T:1958294448   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.fsgo/) failed

It doesn't look like you have activated debug logging in the Kodi settings. Could you go to System settings -> Logging -> Enable debug logging and repost a log please?
Reply
[/quote]

Sure, you can hit me up on IRC (#kodi-dev at irc.freenode.net). Wink
[/quote]

tried going on there, but couldnt see you
Reply
Are you sure you're in the right channel/network? I'm using an IRC bouncer so I should always be in the channel. Wink
Reply
(2017-02-25, 23:40)emilsvennesson Wrote:
(2017-02-24, 00:41)japes Wrote: Yes, On my OSMC Raspberry Pi3 setup I still can't get it to activate. I've tried activating it and waiting 15 minutes before going back and hitting ok to make sure the full activation went through and it still didn't work. I just tried two more times. The first time it said to make sure I waited and ask me to retry and I did. The second time it acted as if it would work but then I got a error, check log message.

Code:
"/home/osmc/.kodi/addons/plugin.video.fsgo/default.py", line 5, in <module>
                                                addon.run()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 423, in run
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 387, in authenticate
                                                authenticate()
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 380, in authenticate
                                                authenticate(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/addon.py", line 372, in authenticate
                                                fsgo.login(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 272, in login
                                                self.get_access_token(reg_code)
                                              File "/home/osmc/.kodi/addons/plugin.video.fsgo/resources/lib/fsgo.py", line 107, in get_access_token
                                                reg_dict = json.loads(reg_data)
                                              File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
                                                return _default_decoder.decode(s)
                                              File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
                                                obj, end = self.raw_decode(s, idx=_w(s, 0).end())
                                              File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
                                                raise ValueError("No JSON object could be decoded")
                                            ValueError: No JSON object could be decoded
                                            -->End of Python script error report<--
16:35:21.176 T:1958294448   ERROR: GetDirectory - Error getting plugin://plugin.video.fsgo/
16:35:21.178 T:1958294448   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.fsgo/) failed

It doesn't look like you have activated debug logging in the Kodi settings. Could you go to System settings -> Logging -> Enable debug logging and repost a log please?

You're right. I was in a hurry and didn't even realize. I'll try and grab it when I get home.
unRaid v6 pro:
ECS A885GM-A2 (V1.1) AM3 AMD 880G Motherboard
AMD Sempron 145 Sargas Single-Core 2.8 GHz
2GB RAM
Dockers: Kodi Headless and MariaDB for a centralized DB. MythTV or TVheadend (Still experimenting)
--
HTPC Win7:
Intel Core I3-2105 Dual-Core Processor 3.1 GHz 3 MB Cache LGA 1155
4GB (2 x 2GB) RAM
--
Extenders: RPI3 w/OSMC
Reply
This add-on crashes just like two other add-ons from emilsvennesson.
Reply
(2017-03-09, 22:07)UserFI Wrote: This add-on crashes just like two other add-ons from emilsvennesson.

is that your polite way of asking for help!
it's working fine for me and not crashed once, plus not many others complaining
Reply
(2017-03-09, 23:32)morph78 Wrote:
(2017-03-09, 22:07)UserFI Wrote: This add-on crashes just like two other add-ons from emilsvennesson.

is that your polite way of asking for help!
it's working fine for me and not crashed once, plus not many others complaining

I'm not blaming the author. YouTube Plug-in is also crashing here.
Perhaps some Linux update messed things up.
Reply
All four add-ons working after "sudo pip uninstall pyopenssl". Smile
Reply
(2017-03-10, 00:54)UserFI Wrote: All four add-ons working after "sudo pip uninstall pyopenssl". Smile

Yep, thought the suggestion I posted in the YouTube thread might fix this one for you too.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
(2017-03-10, 01:13)MetalChris Wrote:
(2017-03-10, 00:54)UserFI Wrote: All four add-ons working after "sudo pip uninstall pyopenssl". Smile

Yep, thought the suggestion I posted in the YouTube thread might fix this one for you too.

Maybe you could help me with Viaplay add-on.
Streams stop working suddenly.

"No valid stream URL was found."

ERROR: /home/kodi/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/connectionpool.py:843: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest...l-warnings
Reply
(2017-02-25, 23:40)emilsvennesson Wrote:
(2017-02-24, 00:41)japes Wrote: Yes, On my OSMC Raspberry Pi3 setup I still can't get it to activate. I've tried activating it and waiting 15 minutes before going back and hitting ok to make sure the full activation went through and it still didn't work. I just tried two more times. The first time it said to make sure I waited and ask me to retry and I did. The second time it acted as if it would work but then I got a error, check log message.

It doesn't look like you have activated debug logging in the Kodi settings. Could you go to System settings -> Logging -> Enable debug logging and repost a log please?

Sorry I've been busy with unrelated issues.

https://paste.ubuntu.com/24237218/
unRaid v6 pro:
ECS A885GM-A2 (V1.1) AM3 AMD 880G Motherboard
AMD Sempron 145 Sargas Single-Core 2.8 GHz
2GB RAM
Dockers: Kodi Headless and MariaDB for a centralized DB. MythTV or TVheadend (Still experimenting)
--
HTPC Win7:
Intel Core I3-2105 Dual-Core Processor 3.1 GHz 3 MB Cache LGA 1155
4GB (2 x 2GB) RAM
--
Extenders: RPI3 w/OSMC
Reply
So I must not understand this app and could use some help, I have Centurylink Prism TV.
I have kodi installed on multiple devices and found this app but can not figure out the activation part.

When I start the app it directs me to enter the activation code at the url provided so I do this it takes me to
the enter code page, I do this and am re-directed to the choose provider, I do this, I am already logged into
FOXSPORTSGO so am then redirected to SUCCESS! You have successfully activated FOX Sports GO.

I return to Kodi hit OK and get Working spinning top right after a moment I get an Error Message to check log for more info.
I have no idea what I am looking at here so hope someone can help.

note: this addon was added with a build and had been activated as it would work when clicked on I would get a short meny
todays events and so on maybe 5 items when I checked the credentials it said something about access and it looked limited.
So I decided to do my own login and this is the result. (so it did work)

Code without debugging.

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ValueError'>
Error Contents: No JSON object could be decoded
Traceback (most recent call last):
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\default.py", line 5, in <module>
addon.run()
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 423, in run
authenticate()
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 380, in authenticate
authenticate(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 372, in authenticate
fsgo.login(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\resources\lib\fsgo.py", line 272, in login
self.get_access_token(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\resources\lib\fsgo.py", line 107, in get_access_token
reg_dict = json.loads(reg_data)
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\__init__.py", line 339, in loads
return _default_decoder.decode(s)
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 364, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 382, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
-->End of Python script error report<--
21:48:02.187 T:6708 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.fsgo/?action=show_auth_details
21:48:02.188 T:6708 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.fsgo/?action=show_auth_details) failed



Code with Debugging:

22:05:36.885 T:6708 DEBUG: ------ Window Deinit (DialogConfirm.xml) ------
22:05:36.899 T:12960 DEBUG: [fsgolib]: Not (yet) logged in.
22:05:36.899 T:12960 DEBUG: [fsgolib]: Request URL: https://activation-adobe.foxsportsgo.com...o.validate
22:05:41.694 T:6708 DEBUG: ------ Window Deinit (Pointer.xml) ------
22:05:52.620 T:12960 DEBUG: [fsgolib]: Response code: 504
22:05:52.620 T:12960 DEBUG: [fsgolib]: Response:
22:05:52.625 T:12960 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ValueError'>
Error Contents: No JSON object could be decoded
Traceback (most recent call last):
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\default.py", line 5, in <module>
addon.run()
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 423, in run
authenticate()
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 380, in authenticate
authenticate(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\addon.py", line 372, in authenticate
fsgo.login(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\resources\lib\fsgo.py", line 272, in login
self.get_access_token(reg_code)
File "C:\Users\tdr17\AppData\Roaming\Kodi\addons\plugin.video.fsgo\resources\lib\fsgo.py", line 107, in get_access_token
reg_dict = json.loads(reg_data)
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\__init__.py", line 339, in loads
return _default_decoder.decode(s)
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 364, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "C:\Program Files (x86)\Kodi\system\python\Lib\json\decoder.py", line 382, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
-->End of Python script error report<--
22:05:52.629 T:6708 DEBUG: ------ Window Init (DialogNotification.xml) ------
22:05:52.729 T:12960 INFO: Python script stopped
22:05:52.729 T:12960 DEBUG: Thread LanguageInvoker 12960 terminating
22:05:52.745 T:6708 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.fsgo/
22:05:52.746 T:6708 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.fsgo/) failed


Thanks in advance to anyone who has details and can help.
Reply
(2017-03-28, 04:14)tdr170 Wrote: note: this addon was added with a build

Don't use builds. Download Kodi from the link at the top left of this page. Do a clean install and add Fox Sports Go from the official repository. If you continue to have problems, post a link to a full debug log.
Kodi 17.6 on Dell Optiplex 980 Lubuntu 18.04 | Kodi 18 on HTPC Lubuntu 18.04 | My Add-ons | My Repo
Reply
For the record I'm using century link prism as well and I'm NOT using a build. You may have missed my log link
unRaid v6 pro:
ECS A885GM-A2 (V1.1) AM3 AMD 880G Motherboard
AMD Sempron 145 Sargas Single-Core 2.8 GHz
2GB RAM
Dockers: Kodi Headless and MariaDB for a centralized DB. MythTV or TVheadend (Still experimenting)
--
HTPC Win7:
Intel Core I3-2105 Dual-Core Processor 3.1 GHz 3 MB Cache LGA 1155
4GB (2 x 2GB) RAM
--
Extenders: RPI3 w/OSMC
Reply
  •   
  • 1
  • 7
  • 8
  • 9(current)
  • 10
  • 11
  • 13
  •   



Logout Mark Read Team Forum Stats Members Help
FOX Sports GO - available in the official repository3
This forum uses Lukasz Tkacz MyBB addons.