Thread Rating:
  • 0 Vote(s) - 0 Average
CEC Support Krypton Beta
#1
Hi,

Need some help with CEC in Krypton. I am running Kodi on Windows 7, Mac Mini, and have a pulse-eight USB adapter. Everything was working as it should in Kodi V16 but since upgrading to Krypton there is no support? In Kodi > Settings > System> Input Devices > Peripherals, there is no CEC Adapter showing.

Where do I start? Is a log file going to help?

Thanks
Reply
#2
Still no takers out there to point me in the right directionHuh?​
Reply
#3
Same here on 16.1: on startup kodi shows the pulse eight adapter is connected msg,
but there is no entry at Settings > System> Input Devices > Peripherals, there is no CEC Adapter showing.
Reply
#4
Yay, it's not just me . . . . . .
Hopefully someone we be able to help us fix this issue.

log file here

http://pastebin.com/rMtnWfmy
Reply
#5
Same here...
I contacted Pulse8 and tried to update libcec, but nothing higher than libcec 3.0.0 is working with my usb adapter (win7).
After a few emails Pulse8 stopped answering...
Reply
#6
I added a ticket here so hopefully we can get some feedback going

http://trac.kodi.tv/ticket/17137
Reply
#7
Looks like this might have been fixed at the Pulse-Eight end? Just need it added to a nightly to test?

https://github.com/Pulse-Eight/libcec/issues/276
Reply
#8
No, I tried a nightly of 07.01.2017.
The CEC Adabter is not working.
The message is: no libCEC found.

Before it was faild to initialize.

Kodi 16.1 is working without any problem.
Reply
#9
(2017-01-08, 14:06)Portisch Wrote: No, I tried a nightly of 07.01.2017.
The CEC Adabter is not working.
The message is: no libCEC found.

Before it was faild to initialize.

Kodi 16.1 is working without any problem.

Yep, same for me.......

This from the log file
WARNING: PERIPHERALS::CPeripherals::CreatePeripheral - libCEC support has not been compiled in, so the CEC adapter cannot be used.

I added a noted to the bottom of my ticket but the issue has been closed. Hopefully someone will pick this up or I will log new ticket.

http://trac.kodi.tv/ticket/17137
Reply
#10
Kodi 17 uses libcec4. All that is available on the pulse eight website is libcec3. libcec 4 is available on the pulse eight github page but needs t be compiled.
Reply
#11
(2017-01-09, 07:53)teeedubb Wrote: Kodi 17 uses libcec4. All that is available on the pulse eight website is libcec3. libcec 4 is available on the pulse eight github page but needs t be compiled.

As a muppet, I know nothing about how to compile a working version. If someone can compile a working WIN32 version for us broken people that would be great.
Reply
#12
I'm hoping that the people we bought it from compile a version for us soon. I've asked for a ETA in the pulse eight CEC
Reply
#13
I compiled a 4.0.1 Windows version of libCEC by myself without Eventghost support.
After install the setup the message is still the same: no libCEC found.

So how to fix this issue?

EDIT:
Here the 4.0.1 Windows Setup (Eventghost is not included!):
http://www.file-upload.net/download-1223...1.exe.html

But as I told you, it is not working for me...

EDIT2:
http://trac.kodi.tv/ticket/17137#comment:11
Reply
#14
There are/where some bugs in kodi & libCEC:

1. https://github.com/xbmc/xbmc/commit/a9a0...e4991d3b7a, already fixed in Github
2. the ibcec-4.0.1-win32-vc140.7z is including a "libcec.dll", but kodi is using a "cec.dll" -> still open, I think this libCEC issue
3. The device detection fails at windows because of this bug: https://github.com/Pulse-Eight/libcec/is...-271988874

With fixing all these errors the Puls Eight CEC is working again in Kodi Krypton!
Reply
#15
Still not working for me in RC3, you able to confirm it's working?​
Reply



CEC Support Krypton Beta00