Intel Kaby Lake Hardware

  Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
GrimGriefer Offline
Junior Member
Posts: 22
Joined: Jan 2012
Reputation: 0
Post: #901
Hi everyone,

Great to see some progress with this issue so I thought I would update on my findings.

Using Milhouses LibreELEC-Generic.x86_64-8.2.0-20170920153419 build
http://milhouse.libreelec.tv/builds/stable/Generic/

Intel-NUC-Kit-NUC7i5BNK (Kaby Lake)
Onkyo TX-NR646 Amplifier with SKS-HT588 speakers (Dolby Atmos and DTS-X supported).

Before no passthru was working at all but with Milhouses build here are my results when playing back a multiple MKV's containing HBR soundtracks.

DTS-HDMA - Working
DTS-X - Working
Dolby TrueHD - Working
Dolby Atmos - Only the TrueHD data is being bitstreamed to the amplifier.

Thanks everyone.
find quote
fritsch Offline
Team-Kodi Developer
Posts: 18,241
Joined: Aug 2011
Reputation: 565
Location: Stuttgart*
Post: #902
(Yesterday 14:58)GrimGriefer Wrote:  Hi everyone,

Great to see some progress with this issue so I thought I would update on my findings.

Using Milhouses LibreELEC-Generic.x86_64-8.2.0-20170920153419 build
http://milhouse.libreelec.tv/builds/stable/Generic/

Intel-NUC-Kit-NUC7i5BNK (Kaby Lake)
Onkyo TX-NR646 Amplifier with SKS-HT588 speakers (Dolby Atmos and DTS-X supported).

Before no passthru was working at all but with Milhouses build here are my results when playing back a multiple MKV's containing HBR soundtracks.

DTS-HDMA - Working
DTS-X - Working
Dolby TrueHD - Working
Dolby Atmos - Only the TrueHD data is being bitstreamed to the amplifier.

Thanks everyone.

Atmos makes me wonder. As we don't cut it out, but keep it in our IEC packages.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
lellokid Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #903
Please tell me how to solve this problem
[Image: 781561ef5fdd82ab3f3f9a8487531029.jpg]

I'm using a NUC7i3BNH with win10 (updated drivers) and kodi 17.4
All the videos in the H265 8 bit format with the hardware acceleration enabled I see this way ...
all other formats are fine
I also installed MPC-HC and I have the same defect so i think it's a windows problem.
no one has detected this defect?
(This post was last modified: Yesterday 18:14 by lellokid.)
find quote
fritsch Offline
Team-Kodi Developer
Posts: 18,241
Joined: Aug 2011
Reputation: 565
Location: Stuttgart*
Post: #904
(Yesterday 18:05)lellokid Wrote:  Please tell me how to solve this problem
[Image: 781561ef5fdd82ab3f3f9a8487531029.jpg]

I'm using a NUC7i3BNH with win10 (updated drivers) and kodi 17.4
All the videos in the H265 8 bit format with the hardware acceleration enabled I see this way ...
all other formats are fine
I also installed MPC-HC and I have the same defect so i think it's a windows problem.
no one has detected this defect?

Driver bug. Was a setting with "contrast" or something in the driver control panel iirc.

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
find quote
lellokid Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #905
(Yesterday 18:25)fritsch Wrote:  Driver bug. Was a setting with "contrast" or something in the driver control panel iirc.



possible solutions?

Finding an Old GPU Driver or Waiting for a New Intel Driver?
find quote
fritsch Offline
Team-Kodi Developer
Posts: 18,241
Joined: Aug 2011
Reputation: 565
Location: Stuttgart*
Post: #906
(Yesterday 18:31)lellokid Wrote:  
(Yesterday 18:25)fritsch Wrote:  Driver bug. Was a setting with "contrast" or something in the driver control panel iirc.



possible solutions?

Finding an Old GPU Driver or Waiting for a New Intel Driver?

Go to the intel driver control panel and disable it. Here: https://software.intel.com/en-us/forums/...pic/714863

"Your most vocal users are not reflective of your userbase" J.M.
"Of course, they [XP Users and people with outdated hardware] need to tell the world about the kind of hero they are, and block innovation for everyone else because their decades old OS / hardware needs to work =p" nevcairiel (ffmpeg)
No Debug Log no issue.
(This post was last modified: Yesterday 19:07 by fritsch.)
find quote
lellokid Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #907
@fritsch
thank you so much if you come to italy from my parts I pay you a drink Smile
really many thanks because I was getting crazy
find quote
Post Reply