Thread Rating:
  • 0 Vote(s) - 0 Average
Libreelec, RPi -> Creation of Processing class failed
#1
i got a problem with libreelec, RPi and ActiveDSP:

Quote:15:47:30 73.237434 T:1961156608 WARNING: CreateLoader - unsupported protocol(sources) in sources://music.tbn
15:47:32 74.747849 T:1939866528 ERROR: ActiveAE DSP - Create - DSP input convert failed
15:47:32 74.748039 T:1939866528 ERROR: ActiveAE DSP - CreateDSPs - Creation of processing class failed

i can't really imagine why that is happening. it's happening when i start do use the speaker correction or my own m/s plugin. even with the unmoded version from the official kodi repository i got that message.
it just stops playing music after a few milliseconds, but i can hear, that the actual ms plugin effect is working for that second.
the failure appears out of nowhere, with a new sd-card build.
My System: Hackintosh OSX 10.11.6; Xcode 8.0 (8A218a), Raspberry Pi 3
Hardware:
Gigabyte GA-Z170X-UD5 TH; Intel Core i7 6700K; 32GB Corsair Vengeance LPX; GeForce 950 GTX
Reply
#2
ADSP doesn't currently work. Make sure it's disabled.
It shipped broken with Jarvis and is still broken in Krypton.
We need to make sure it is fixed or disabled before release.
Reply
#3
@popcornmix,
I will disable it for the final release: https://github.com/xbmc/xbmc/pull/10756

@Melf11:
You could try my latest patches, they're fine under Windows. For more platforms I did not had time for testing. https://github.com/achimturan/xbmc/tree/...core_fixes
Latest news about AudioDSP and my libraries are available on Twitter.

Developers can follow me on Github.
Reply
#4
it's strange, because it works on an image which i created last week and now there is that strange failure.
i will try your last patches!
My System: Hackintosh OSX 10.11.6; Xcode 8.0 (8A218a), Raspberry Pi 3
Hardware:
Gigabyte GA-Z170X-UD5 TH; Intel Core i7 6700K; 32GB Corsair Vengeance LPX; GeForce 950 GTX
Reply
#5
hey,
a bit late but i tried now on my mac, and there it is working well, but in libreelec there is still the same problem.
actually i noticed, that if i start playback the timeline is showing "-33:-15 / 12:25" ...so it's like it starts at -33:-15 minutes. 12:25 is the length of the song.
My System: Hackintosh OSX 10.11.6; Xcode 8.0 (8A218a), Raspberry Pi 3
Hardware:
Gigabyte GA-Z170X-UD5 TH; Intel Core i7 6700K; 32GB Corsair Vengeance LPX; GeForce 950 GTX
Reply



Libreelec, RPi -> Creation of Processing class failed00