PVR addon doesn't load if TV backend server is unreachable
#1
Hello,

I run MediaPortal TVServer backend on a server and access it with various clients around the house. In my set up the clients often use Kodi to watch movies or do things besides watching TV, so when the TV server is not needed it goes to sleep.
I've noticed with all Kodi 17 versions that when I launch Kodi and the TV server is asleep after about 30 seconds I get an error message telling me the PVR addon couldn't be loaded. I'm sure this is because the TV server is unreachable at that time (owing to it being asleep) - but this behaviour is problematic because I don't want to have to wake the TV server up just to load Kodi on a client PC without this error, that's not energy efficient. Also once this error has occured I cannot subsequently wake the TV server and access it from the client until I restart the client. Is there a setting I can change where it doesn't need to check if the server is reachable, the addon just loads as normal like in version 16?

Thanks
Reply
#2
Seems that the add-on does not support "asynchronous connect" which is new for Krypton and required to handle delayed backend availability and proper reconnect after backend connection loss after the add-on had been loaded.

The old mechanism loaded and unloaded the add-on in a loop hoping that in some point in time the add-on would return success. This hacky approach was removed for Krypton on our way to a future proof software architecture for Kodi. It was replaced with the new approach described above.

Thus, the solution for your problem is to encourage the add-on maintainer to implement the missing pieces...
Reply
#3
A workaround might be to disable the pvr addon on shutdown / startup, and have a script to run a wol command then enable it (the pvr addon) linked in favourites, to a remote button or in a skin shortcut (if your skin supports them).
I do that (not the wol bit) for dvbviewer in krypton because I rarely use it (PVR) except on my main build.
Reply
#4
Thanks for replying and for the suggestion, it's a bit over my head to be honest and at present I'm sticking with a stable release for my most used clients. I'm just concerned the issue I mention might get overlooked when Krypton becomes a stable release. I made a new thread in the Mediaportal PVR add-on subforum 295699 (thread) and it looks like this may be a Kodi bug.
Reply
#5
No, this is not a Kodi bug. The add-on needs to be adapted for Krypton.
Reply
#6
No announcement in the PVR development forum, no deprecation warning and no documentation on the new feature => most PVR addons are now broken, so therefore I consider this a regression bug.

Please add the relevant details about this breaking PVR API change and what we need to do to fix our addons to the PVR API change thread and I will try to fix the MediaPortal PVR addon. Unfortunately this will probably not happen anymore before the release of Krypton.
Developer of the MediaPortal PVR addon and retired developer of the Argus-TV PVR-addon.
http://www.scintilla.utwente.nl/~marcelg/xbmc
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
PVR addon doesn't load if TV backend server is unreachable51
This forum uses Lukasz Tkacz MyBB addons.