Bug Local FTP, no Local Fanart or Poster
#1
I have all my movies on an local FTP right now and i would like to have that in the future.

I have nfo, posters and fanart in the separate movie folders, worked fine before moved to the FTP.

I have tried on my pc and on my raspbarry pi 3B with retropie and it is the same issue.

Googled for an hour but didnt find anything that worked.

Example:
Folder: 101 Dalamtiner
Files in folder:
101 Dalamtiner.avi
101 Dalamtiner.nfo
101 Dalamtiner-fanart.jpg
poster.jpg

Any one have a clue?

Tried to search in this forum, but FTP was a to short string.
Reply
#2
Have you tried to enable remote thumbs in advancedsettings.xml? This setting is not documented in the wiki, but it should exist.

Code:
<ftp>
  <remotethumbs>true</remotethumbs>
</ftp>
Reply
#3
You are right. it is something in the advancedsettings.xml but I don't find what.

here is an old thread but the links in it dose not work.
94894 (thread)

Read the wiki but didn't find it like you say. What should I add in the advancedsettings.xml?
Chromebox Libreelec Kodi 17.6,
Chromebox Libreelec Kodi 17.6,
PC Windows 7 Kodi 17.6,
PC Windows XP Kodi 15.2,
Raspberry Pi 3 B+ RetroPie 4.4.
Reply
#4
Sorry, it seems like my post was a bit confusing. The link to the wiki was meant to show you what "advancedsettings.xml" is, in case you've never heard of it. As I said, the setting is undocumented, so you won't find it in there. The link to the source code of kodi, more precisely the code that reads the advancedsettings.xml file, is the proof that the "remotethumbs" setting is actually used by kodi (although undocumented). And the code posted is what you should add in the advancedsettings.xml.
Reply
#5
@sabelstrom
How do you, connect to the ftp share from kodi.
Do you use the "local path"
Or do you use the "Network path", if this is the case check your settings and make sure you have "Permission to write" to the share
Windows and other "OS" most of the time makes the share "read only" when you create it
So check permission make sure you have r/w "read/write"
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#6
This is how i have done:

Code:
<advancedsettings>
<ftp>
  <remotethumbs>true</remotethumbs>
</ftp>
</advancedsettings>

Image

I put the advancedsettings.xml in: AppData\Roaming\Kodi\userdata

Deleted the textures13.db and deleted the source and cleaned the library.

I use the local ip to access the FTP.

Seems to work.
Reply
#7
ohh sry i misread your post as in you where unable to write to the share
Why did you delete the textures13.db?, just curious did it have an effect.
If you are using the "local path" there should not really be any need for the adv.xml, but could be wrong
If kib sees this post he can help you, that guy is a walking encyclopedia on this stuff Big Grin
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#8
1 thing does the *.nfo files point to the new path, meaning you say you can see fanart but not posters
have you edited your nfo file to point to the new loc for the poster, because fanart will show no matter what

But if your nfo file does not point to the new location, but still use the old location, it might be a problem

Making any sense?
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#9
(2016-11-11, 02:13)kimkl Wrote: ohh sry i misread your post as in you where unable to write to the share
Why did you delete the textures13.db?, just curious did it have an effect.
If you are using the "local path" there should not really be any need for the adv.xml, but could be wrong
If kib sees this post he can help you, that guy is a walking encyclopedia on this stuff Big Grin

Well the textures13.db gets created every startup and contains info, so i think it forced kodi to look for nfo and other stuff again, but i cant say i know. But i have read about problem with that file so i deleted it to be sure.

(2016-11-11, 02:28)kimkl Wrote: 1 thing does the *.nfo files point to the new path, meaning you say you can see fanart but not posters
have you edited your nfo file to point to the new loc for the poster, because fanart will show no matter what

But if your nfo file does not point to the new location, but still use the old location, it might be a problem

Making any sense?

This is what my nfos looks like
Code:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<movie>
    <title>101 Dalmatiner</title>
    <runtime>99</runtime>
</movie>
Reply
#10
Well that explains why, you see no artwork , your missing the location to the fanart ill post one of mine then you can see if you can fit it in.
I just need to edit some stuff out that has no relevance
And you can also do something other, you wrote that you keep the artwork on your ftp, you could simply add a imdb link to the nfo then it will use the artwork from imdb.
well ill post both solution you pick what you like best .
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#11
>>>>This if for when using nfo, and if your movies are backed up as folder, VIDEO_TS, you have to save the nfo as VIDEO_TS.nfo and put it into the VIDEO_TS folder.
<movie>
<title>101 Dalmatiner</title>
<runtime>99</runtime>
<id>tt0115433</id>
</movie>

>>>>You can also use a xml file you name it movie.xml and it goes into the root of the folder not into VIDEO_TS but the 101 Dalmatiner folder, And you can just write this
<movie>
<title>101 Dalmatiner</title>
<runtime>99</runtime>
</movie>
http://www.imdb.com/title/tt0115433/

And as i said you name it movie.xml if you have your movies backed up 1:1 with a VIDEO_TS folder
Try both solution you can copy what i wrote the link to imdb is correct
Now ofc this is very basic nfo or xml you can use more tags if you like but this will work you get plot/outline and some artwork

I suggest you read this very helpful stuff
NFO_files (wiki)

If you have trouble understanding, something i wrote you can PM me and just write your Question in Swedish i am from Denmark so we should understand each other perfect Big Grin
Grandpa Simpson: Unfortunately, like all true stories, this one has a crappy ending.
Your story's have an ending?
English is not my native language; please excuse typing errors.
 
Reply
#12
The thing is i have over 1000 kid movies, all in swdish, folders, moviefiles, fanarts, and in the nfo files all in swedish, so i cant just add something.

It all worked local and via samba but not ftp, so it nothing wrong with my library but there was some configuration to get it to work on the ftp.

Now it all works thanks to the advancedsettings.xml.

I have everything on ftp, i just moved everything from a local hdd to an ftp (a external 4tb hdd connected via usb to my router) so i can use it on all computers in the home network, and the kids can connect to it everywhere if they are not home.

And i have made my own fanart to all movies and my own posters om many of them, so i dont want to get it online.

I have read the nfo wiki but it dont help, because i dont what to get anything onine. Everything i have is handmade.

When i started doing my library i didn know i could use VIDEO_TS folders so i converted everything to AVI files. but i have recently started using mkv. But if i use kodi on all devices and dont use a usbstick in the tv i could start using the build of dvds and b-rays.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Local FTP, no Local Fanart or Poster00
This forum uses Lukasz Tkacz MyBB addons.