v17 replaygain doesn't seem to be working
#51
No problem, although I don't know when the door to fixing 17.1 will close, so do want to get this done.

With that in mind, and following discussion with Fernet, I split the PR into a simple fix for the peak not 1.0 situation (that the complaints were about) hopefully to go into 17.1, and a restoring an option of using reduced gain to avoid clipping protection. It was these combined that got tested by @Gracus and @meewmoo, but I doubt that they actually heard the clipping aspects.

Why have a "reduced gain" option? Well playing the track at a lower volume will sound diffrent to letting the audio engine handle clipping just at the places it occurs, and some people may want that. But more than that, AE clipping protection is CPU expensive, so those running Kodi on limited processors will have the AE protection disabled. At least with the "reduced gain" approach those files with rgain and peak can be adjusted not to clip without any expensive processing. But the option to avoid clipping protection by normalising volume will reappear in v18, if my PR is approved.

So just for extra confidence I have a test build of just the simple peak not 1.0 fix (that will be backported) cooking. Anyone able to test that too would be useful.
Reply


Messages In This Thread
RE: replaygain doesn't seem to be working - by DaveBlake - 2017-03-19, 15:08


Logout Mark Read Team Forum Stats Members Help
replaygain doesn't seem to be working0
This forum uses Lukasz Tkacz MyBB addons.