v17 Problem skipping some recordings from TVH
#1
Hello,

I have problems skipping and forwarding some recordings from TVH. Playing the recording without skipping is no problem. But if i skip or forward the recording, kodi will stop playing the recording without an error message.

I'm using the LibreElec v7.90.008 ALPHA with an Intel Apollo Lake chipset. But i also had this problem with an old Nvidia GT430. Now i tried it on my main workstation with windows 10 (Nvidia GTX10170, Kodi Nightly 20161119) and also the same problem Sad But I can play the recording without any problem on windows with vlc or windows mediaplayer. Skipping also works without problems.

I've upload my debug log from my last try on windows 10 (if need i can do the same on the libreelec machine). If needed, i can cut the recording and upload it also.

Playing the recording starts at 19:57:23.564. Shortly after, i skip the recording 1 minute. Then the recording instantly stops.

On the server side i'm using Debian 8.6 with kernel "Linux BRAIN 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux". TVH Version: 4.1-2328~gca5f094~jessie (2016-11-18T01:07:52+0000) .

Here is the log: http://pastebin.com/gSZjvVYA

Thanks in advance.

Best regards
hasenbolle
Reply
#2
Ok. Here is a new log with FFMPEG, Video and Audio logging enabled: http://pastebin.com/U2kUETSD

Skipping starts, i think at 19:27:22.860

Maybe also a problem of TVH and the recording itself. Btw. the same recording a week later on the same channel, went well. No problems with it.
Reply
#3
Looking at the ffmpeg errors you have there, I would guess that it's a reception error - or maybe even a transmission error of some kind. The fact that a later recording of the same programme works suggest the same.

What's in syslog or the tvh log on the backend? Any continuity counter errors, or anything to suggest that the file has errors (e.g. the webUI)?

What if you play the .ts file locally? What if you use .mkv instead? What if you remux the recording from .ts to .mkv (mkvmergeGUI or similar) and play over a network share?

My guess - and it is only that - would be errors in the stream that are causing Kodi to "lose its place" when you skip forward, something to do with PTS/DTS. But I don't know enough to go any further.

Moving to the tvh sub-forum as well, as it's more likely tvheadend-specific than pure Kodi.
Reply
#4
Thanks for your help.

If i play the file locally with vlc or even windows media player all is fine. No problems with skipping. I also tried to split (http://www.videohelp.com/software/TSSplitter) the recording in a 30mb junk to upload a example, but the splited file works then fine. I think the split program does some remuxing. But i dont know.

I thought it would be a kodi/ffmpeg error, because the file plays fine locally.

Btw, here is the syslog: http://pastebin.com/bvYvMuLY

On line 5 it says: "Nov 20 19:00:00 BRAIN tvheadend[712]: pass: /mnt/media/TV-Aufzeichnungen/RTL HD/Schwiegertochter gesucht/Schwiegertochter gesucht2016-11-2019-05.ts: Unable to change permissions -- Die Operation ist nicht erlaubt. " -> The operation is not allowed. That error is also thrown on files which are played fine with kodi.

And then there is: Nov 20 19:42:38 BRAIN systemd[1]: Time has been changed. A Thousand times this message occurs. But i think that has nothing to do with the corrupted recording, because this message is everywhere in the syslog.
Reply



Logout Mark Read Team Forum Stats Members Help
Problem skipping some recordings from TVH0
This forum uses Lukasz Tkacz MyBB addons.