Kodi doesn't see my music files
#1
I have a windows 10 system using Jarvis 16.1.
When I add a source I see all the folders ie.. flac, hi-rez etc.
All the album titles are there but inside the album folder there is nothing ?
I have all kinds of music files from dsd to flac to mp3.
All my movies and concerts are working fine.
When I look in the folder from windows all the files are there but Kodi doesn't seem to see them
What could the problem be ?
Win7/64/ML03/i3_2120/ASRock H77_Pro4-m/120GB OCZ SSD/8GB_Ram/2TB_WDGreen/Lite-On BD/Iogear GKM571 keypad/Inteset CIR Remote/Marantz AVR/Panasonic Plasma
Reply
#2
There's an awful lot of information missing there...

Are your files on the same system as the Kodi client? If not, shared how?

Are you talking about Library mode, or File mode?

Do you have any permission control, especially if the files are on a different system?

... and so on. Please describe your setup and/or post a debug_log (wiki) if you're scanning them into the library.
Reply
#3
The files are on an external hard drive connected directly to the computer via usb.
The concerts and movies are on the same hard drive.
When I scan the movie and concert folder, I can see the scanning progress and titles in the box at the top of the screen.
However the music folder scans very quickly (seems to fast for the amount of files) and I don't see any of the titles in the progress box.
I think it's file mode but I'm not certain what exactly that is but like I said earlier the movies and concerts are all good and are being scanned from the same external hard drive.
If I go through the file manager I can find the songs and play them but If I go Music>Files>Add videos>H:\Music and say OK I get a quick scan and the folder is there Music>Beatles>Abbey Road but then nothing...
Win7/64/ML03/i3_2120/ASRock H77_Pro4-m/120GB OCZ SSD/8GB_Ram/2TB_WDGreen/Lite-On BD/Iogear GKM571 keypad/Inteset CIR Remote/Marantz AVR/Panasonic Plasma
Reply
#4
All these files are tagged correctly ?

Oh and it should be Music>Files>Add Music>H:\Music , then answer Yes to 'Do you want to add the media from this source to your library'
Learning Linux the hard way !!
Reply
#5
Not very complete information, but it sounds like your naming convention for the folders / files is off.
Also try it the way black_eagle describes. That was actually my first thought...
Reply
#6
Need debug log. Kodi has a default list of file extensions that are considered music files, including archives. These file-types are opened during a music library scan and metadata tags read. All can be followed in the debug log.

scott s.
.
maintainer of skin  Aeon MQ5 mods for post-Gotham Kodi releases:
Matrix see: Aeon MQ5 Mod Martix release thread
Leia see: Aeon MQ5 Mod Leia release thread
Reply
#7
Recently hit an issue with files not being scanned because the user had a "." at the beginning of a folder name. Kodi takes that as a hidden file/folder and skips it.

More likely is files not tagged, or simply not saying yes to scanning. But debug log to understand your issue - turn on logging, add the music source, say "yes" to "Do you want to add the media from this source to your library?". Paste a link to the log here.
Reply
#8
Thanks for all the replies !
Turns out I had to rename the music folder as well as the folders inside the music folder.
Re scanned and all is great !

Thanks again !
Win7/64/ML03/i3_2120/ASRock H77_Pro4-m/120GB OCZ SSD/8GB_Ram/2TB_WDGreen/Lite-On BD/Iogear GKM571 keypad/Inteset CIR Remote/Marantz AVR/Panasonic Plasma
Reply
#9
(2016-11-30, 17:17)rtate Wrote: Turns out I had to rename the music folder as well as the folders inside the music folder.

Could you share what was wrong with the original naming? Was it the "." at the start issue, or something else?
Reply



Logout Mark Read Team Forum Stats Members Help
Kodi doesn't see my music files0
This forum uses Lukasz Tkacz MyBB addons.