•  Previous
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 237
  • Next 
 
Thread Rating:
  • 7 Vote(s) - 4.86 Average
Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2016-12-17, 15:25)Milhouse Wrote: I've uploaded a new debug-enabled build #1216x: RPi2

It would be good for anyone experiencing crashes to try it and produce a more detailed crashlog.
I installed debug enabled build and whilst I have been unable to provoke a full kodi crash yet, I have experienced video lock ups where audio continuing with live streams.

Noticed issue with both itv live stream and bbc live streams which use different add-on. In my case I am usually able to stop the live stream from playing and try another that may/may not work correctly.

Attached is kodi.log when managed to catch bbc live stream video pause/lock whilst audio continued etc. Will leave debug-enabled build installed tomorrow and see if I can provoke another crash...


---edit----

Tried to play itv stream, where video frame pauses immediately the streams starts, I then provoked a crash via ssh with "kill -SIGSEGV $(pidof kodi.bin)" command

kodi crashlog
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
Reply
(2016-12-17, 18:53)doldi Wrote: Angel
....but this would'nt help - display appears always with [email protected] after reboot or new start.
( in google cache was milhouse link present: https://drive.google.com/file/d/0B2rgZ0B...5aaFU/view )

Can you check your changes in config.txt

When you do it by the terminal in LE then you have to mount rw before

mount -o remount,rw /flash
nano /flash/config.txt

Maybe a debug log will give a hint what happen
Reply
New LibreELEC.tv Krypton build #1217: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.9.0 #1 Sat Dec 17 21:37:18 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Dec  9 2016 17:52:15
Copyright (c) 2012 Broadcom
version 40f32e4ad457a5e9dc91288ebccb13e23d986e4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161217213612-#1217-gf119807 [Build #1217]

# Kodi version
(18.0-ALPHA1 Git:17.0-beta7-7581c4a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (f119807a, changelog) and tip of XBMC master (a182513e, changelog) with the following modifications: Build Highlights:
  1. remove the use of IAddonInterface class
  2. remove the use of template's from add-on interface
Build Details:
  1. LibreELEC.tv:
    • kodi: update to 17.0-beta7-7581c4a (PR:1063, 4 commits, 28 files changed)
    • remove virtualbox support (PR:1064, 2 commits, 12 files changed)
    • linux: fixed Geniatech T230C patch (PR:1065, 1 commit, 3 files changed)
    • dvb-firmware: update to 1.2.0 (PR:1066, 1 commit, 1 file changed)
    • xf86-video-nvidia-legacy: linux 4.9 fix (PR:1068, 1 commit, 1 file changed)
  2. XBMC:
    • CMake: Fix TexturePacker installation directory (PR:11144, 1 commit, 1 file changed)
    • [depends] libjpg-turbo 1.5.1 (PR:11103, 1 commit, 2 files changed)
    • [addons] remove the use of IAddonInterface class (PR:11198, 1 commit, 22 files changed)
    • [PVR][video] Consolidate implementation of "Play", "Mark watched", "Mark unwatched", "Resume from" context menu items (PR:11115, 9 commits, 42 files changed)
    • [PVR] trac17040: fix crashes on pvr manager deinit/reinit. (PR:11143, 6 commits, 19 files changed)
    • [addons] remove the use of template's from add-on interface (PR:11182, 6 commits, 71 files changed)
  3. pvr.dvbviewer:
    • Implement support for transcoding (51c92983)
  4. pvr.iptvsimple:
    • add channel number tag (PR:92, 2 commits, 1 file changed)
  5. pvr.mythtv:
    • 5.0.5 (PR:96, 2 commits, 3 files changed)
  6. newclock5:
    • Commits no longer in build:
      • CMake: Fix TexturePacker installation directory (2e46cb88)
      • VideoPlayer: adapt decoder API to ffmpeg 3.2 (73f2b19e)
      • VideoPlayer: rework after ffmpeg 3.2 adpation (87c8cdcf)
      • MMALCodec: Basic fixup to new ffmmpeg API (9e522b17)
      • MMALRender: More updates to ffmpeg API (cc36e2ac)
      • hack: retroplayer: fixme (6a56642c)
      • MMALFFmpeg: Fixup to new API (baa25431)
  7. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2016-12-17, 23:08)fightnight Wrote: Hi, I'm having issues with https requests with latest builds.

I'm not sure why. Only happens with libreelec.

Could be a certificate issue. When did it start, which build? Can't tell anything from your log - upload a full debug log.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2016-12-18, 00:12)herrmeier01 Wrote:
(2016-12-17, 18:53)doldi Wrote: Angel
....but this would'nt help - display appears always with [email protected] after reboot or new start.
( in google cache was milhouse link present: https://drive.google.com/file/d/0B2rgZ0B...5aaFU/view )

Can you check your changes in config.txt

When you do it by the terminal in LE then you have to mount rw before

mount -o remount,rw /flash
nano /flash/config.txt

Maybe a debug log will give a hint what happen

Hi, here is my config:
GNU nano 2.5.3 File: /flash/config.txt

gpu_mem=350
gpu_mem_256=128
gpu_mem_512=160
gpu_mem_1024=350
over_voltage=4
over_voltage_sdram=4
sdram_schmoo=0x02000020
max_usb_current=1
arm_freq=1300
core_freq=500
sdram_freq=500
gpu_freq=500
force_turbo=1
dtparam=sd_overclock=100
decode_MPG2=0x123456789
decode_WVC1=0x123456789
hdmi_force_edid_audio=1
hdmi_ignore_cec_init
hdmi_mode=31

...think that problem is in current builds. I'm able to switch on 1080p - ok - but if i go to 50Hz in the refresh rate - Kodi switch to "desktop", and set 50Hz - only a disfigurement? ;-) Picture is as far as good @ 1080p/60Hz - hmm, but my TV is an older Sony only 50Hz.
Reply
(2016-12-17, 16:10)metaron Wrote: I have been having problems seeing video/audio with the occasional H264 recorded video files via PVR (mythtv backend). This seems to affect about 1 in 10 HD video recordings made from BBC1 HD in the UK. It has been hanging around for a couple of months or so and causing great frustration when I come to get my weekly strictly fix. Mythfrontend plays them fine as does mediaplayer (on an x86 gentoo linux box)

Scenario: Select the recorded file from the list of recordings and select 'play' from the context menu.
Results: 'playing' icon shows with elapsed time starting to count, but fullscreen video never appears.
To get video: via sidebar, select fullscreen video, then press select and via video settings adjust de-interlace (to any available setting).
Kodi shows 'seeking' for a short period, then playback commences (flawlessly!)

I've tried with OMX acceleration enabled (my preferred solution), and only MMAL acceleration enabled - no difference
I've tried disabling the demuxer in pvr.mythtv - no difference
I've tried pausing and re-starting fullscreen video and skipping forward/back and fastforward/rewind - no video appears
I tried setting de-interlace to 'off' by default. Same issue.
Only changing deinterlace method once 'playback' has started causes any video to appear.
After setting 'sync playback to display' to true (had reset itself to false) and 'Adjust display refresh rate to 'Always' (had reset itself to blank) I brought the fault back...

It seems to be something to do with switching refresh rate as by setting a different starting refresh rate in System Settings->Display->Refresh rate and then initiating playback of the suspect file the fault disappeared with 7.90.009 and I can't get it to come back!

I can't seem to make it happen at all with #1216 so maybe one of the recent tweaks fixed it.
After all this investigation I hate to leave it 'unfinished' without some idea if it will come back again or not, but fingers crossed it won't.
Reply
Since #1217 entering or leaving a folder in PVR Recordings has got incredibly slow (on RPi). Not seen when reverting to #1216.
Reply
(2016-12-18, 13:08)doldi Wrote:
(2016-12-18, 00:12)herrmeier01 Wrote:
(2016-12-17, 18:53)doldi Wrote: Angel
....but this would'nt help - display appears always with [email protected] after reboot or new start.
( in google cache was milhouse link present: https://drive.google.com/file/d/0B2rgZ0B...5aaFU/view )

Can you check your changes in config.txt

When you do it by the terminal in LE then you have to mount rw before

mount -o remount,rw /flash
nano /flash/config.txt

Maybe a debug log will give a hint what happen

Hi, here is my config:
GNU nano 2.5.3 File: /flash/config.txt

gpu_mem=350
gpu_mem_256=128
gpu_mem_512=160
gpu_mem_1024=350
over_voltage=4
over_voltage_sdram=4
sdram_schmoo=0x02000020
max_usb_current=1
arm_freq=1300
core_freq=500
sdram_freq=500
gpu_freq=500
force_turbo=1
dtparam=sd_overclock=100
decode_MPG2=0x123456789
decode_WVC1=0x123456789
hdmi_force_edid_audio=1
hdmi_ignore_cec_init
hdmi_mode=31

...think that problem is in current builds. I'm able to switch on 1080p - ok - but if i go to 50Hz in the refresh rate - Kodi switch to "desktop", and set 50Hz - only a disfigurement? ;-) Picture is as far as good @ 1080p/60Hz - hmm, but my TV is an older Sony only 50Hz.

Are you sure 1080p50 was working in earlier builds?

Your config.txt looks ok. Option "max_usb_current=1" is not needed with actual firmware.

Check the used configuration:
# vcgencmd get_config hdmi_mode
hdmi_mode=31

Check the active mode:
# tvservice -s
state 0x12000a [HDMI CEA (31) RGB lim 16:9], 1920x1080 @ 50.00Hz, progressive

You can try to switch the mode manually;
Try if this is working with your TV:
# tvservice --modes=CEA
# tvservice --explicit="CEA 31 HDMI"

You can also check the supported modes of your display:
# tvservice -d edid.dat
# edidparser edid.dat
Reply
1) Regarding Video/pausing with audio continuing issue, I have noticed that once this issue has occurred with an add-on providing Live streams; it subsequently appears to affect all other live streaming and Live TV via DVB-T with same symptoms. (Catch-up streams are NOT affected?)

2) With quite recent addition of PR:11143 in build #1212b and later I thought it might be worth testing again to see if kodi is more stable/reliable with two PVR back-ends (Filmon & Tvheadend42) running at same time.

Running #1216 (debug build) as soon as started second pvr back-end by enabling it (pvr.filmon) Kodi crashed.

Not unexpected, seen this behavior before, and been advised to delete tv and epg databases whenever changing between pvr back-end addons.
(Not aware of way to do this whilst enabling and disabling pvr back-ends in Kodi GUI and fully appreciate will loose user defined channel arrangements in kodi's channel manager)

Kodi crashlog

Note: Once kodi recovered from crash both PVR back-ends enabled and working in tandem, will now see how reliably they work together after initial hiccup of enabling a second PVR when one already running.
(Will play around with channel manger in kodi to arrange favorite mix of channels from two pvr back-ends)
rPi 3, SanDisk Ultra 8Gb SD & Milhouse LE TestBuild (Kodi 18) -> Onkyo AV -> Philips 42" LCD TV
Reply
@herrmeier01 , many thanks for your support.
here little info:
I am shure, that 1080p50 was working in earlier builds.

pi3:~ # tvservice -s
state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

pi3:~ # tvservice --modes=CEA
Group CEA has 15 modes:
...btw : HDMI:EDID CEA mode (16) 1920x1080p @ 60 Hz with pixel clock 148 MHz has a score of 273832

pi3:~ # edidparser edid.dat
HDMI:EDID best score mode is now CEA (31) 1920x1080p @ 50 Hz with pixel clock 148 MHz(score 5336040)

pi3:~ # tvservice -s
state 0x12000a [HDMI CEA (31) RGB lim 16:9], 1920x1080 @ 50.00Hz, progressive
Reply
@doldi welcome...

To be sure. When your Pi just startup (no video playback, no TV ect.) then Kodi use 1080p60 mode?
Do you have the option "change resolution = always" active in the video settings? Actually Kodi should switch the resolution automatic for match the source. I use the same settings here with #1213x. As lang as I have no Blu-Ray playback activ my mode is always 1080p50.

That's strange, maybe some developer or power user can have a look at this when you add a debug log. At the entry post there is a nice how-to for creating debugs in part 9.
Reply
(2016-12-18, 16:45)metaron Wrote: Since #1217 entering or leaving a folder in PVR Recordings has got incredibly slow (on RPi). Not seen when reverting to #1216.

Anyone else seeing this?

Candidates are:
[addons] remove the use of IAddonInterface class (PR:11198, 1 commit, 22 files changed)
[PVR][video] Consolidate implementation of "Play", "Mark watched", "Mark unwatched", "Resume from" context menu items (PR:11115, 9 commits, 42 files changed)
[PVR] trac17040: fix crashes on pvr manager deinit/reinit. (PR:11143, 6 commits, 19 files changed)
[addons] remove the use of template's from add-on interface (PR:11182, 6 commits, 71 files changed)

I believe PR:11143 was actually in previous builds, so one of the other 3.
@milhouse - if we are sure this is a regression then reverting these 3 PRs one at a time might identify it.
Reply
New LibreELEC.tv Krypton build #1218: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.9.0 #1 Sun Dec 18 22:01:10 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Dec  9 2016 17:52:15
Copyright (c) 2012 Broadcom
version 40f32e4ad457a5e9dc91288ebccb13e23d986e4a (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161218220000-#1218-g9459bcb [Build #1218]

# Kodi version
(18.0-ALPHA1 Git:17.0-beta7-7581c4a). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (9459bcba, changelog) and tip of XBMC master (6e9c2741, changelog) with the following modifications: Build Highlights:
  1. Rename add-on function structures, remove try/catch
  2. pvr.myth updates
  3. libcec: don't add defines
Build Details:
  1. LibreELEC.tv:
    • system-tools: bump file package (PR:1062, 1 commit, 3 files changed)
    • linux: drm/i915: Fix setting of boost freq tunable (PR:1069, 1 commit, 1 file changed)
    • busybox: add getedid script (cce01587)
    • moonlight: bump moonlight-common-c and PKG_REV (9459bcba)
  2. XBMC:
    • [addons] rename add-on function structures (PR:11199, 9 commits, 33 files changed)
    • [addons] remove try, catch from CAddonDll (PR:11201, 1 commit, 2 files changed)
    • [gui] remove old code for viewtype parsing (PR:11114, 1 commit, 3 files changed)
    • Update Chrous2 and scrapers (PR:11207, 2 commits, 38 files changed)
    • [win] define __SSE__ and __SSE2__ for the whole platform (PR:11099, 1 commit, 2 files changed)
    • PVR] Refactor and fix "play minimized" settings handling. Fixes trac 17145. (PR:11203, 2 commits, 13 files changed)
  3. pvr.mythtv:
    • 5.0.6 (PR:100, 3 commits, 4 files changed)
    • 5.0.7 (PR:102, 2 commits, 3 files changed)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1072: libcec: don't add defines for hardware that should be disabled
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Hi Guys,

Just a heads up, I've been having a problem with the mediaportal PVR crashing on start up, gets to 75% Everytime, freezes and then reboots, it Started with #1217.
I'm currently back on #1216 as in the middle of watching something, but will upgrade and post debug logs asap..
Also appears to be happening in the latest Windows nightly...

Best wishes

Bucky
Reply
(2016-12-18, 21:21)popcornmix Wrote:
(2016-12-18, 16:45)metaron Wrote: Since #1217 entering or leaving a folder in PVR Recordings has got incredibly slow (on RPi). Not seen when reverting to #1216.

Anyone else seeing this?

Candidates are:
[addons] remove the use of IAddonInterface class (PR:11198, 1 commit, 22 files changed)
[PVR][video] Consolidate implementation of "Play", "Mark watched", "Mark unwatched", "Resume from" context menu items (PR:11115, 9 commits, 42 files changed)
[PVR] trac17040: fix crashes on pvr manager deinit/reinit. (PR:11143, 6 commits, 19 files changed)
[addons] remove the use of template's from add-on interface (PR:11182, 6 commits, 71 files changed)

I believe PR:11143 was actually in previous builds, so one of the other 3.
@milhouse - if we are sure this is a regression then reverting these 3 PRs one at a time might identify it.

Yes, PR11143 had been in the builds since #1211b.

Here are some test builds with selected reverts (based on Kodi, newclock5 and LE master as per #1217):

#1218j: RPi2 Reverted PR11182
#1218k: RPi2 Reverted PR11198
#1218l: RPi2 Reverted PR11182 and PR11198
#1218m: RPi2 Reverted PR11115
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •  Previous
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 237
  • Next 



LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.867