•  Previous
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 238
  • Next 
 
Thread Rating:
  • 7 Vote(s) - 4.86 Average
Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
Hi
How do I get it to play iso files by clicking on the file
in version 18, you could just click on the file, also played it, but after the update, so it opens the iso file AUDIO_TS AND VIDEO_TS
where do I find the setting in which it plays the file not open it
Reply
(2017-01-13, 03:17)Milhouse Wrote:
(2017-01-13, 00:34)weppa Wrote: I had the same issue with a DualShock 4 controller, ended up removing device to prevent reboot loop.

(2017-01-13, 00:35)radekson5 Wrote: Without connected joystick - boot works fine. But when I connect joystick, kodi freezes and restarts to animation boot loop.

And this issue only started with #0112? That seems a little odd... or was it also present in earlier builds (can you identify the first problem build)?

First build that crashes/bootloops with connected controller (xbox 360 wire) is #0110.

Seems plausible:
Quote:Firmware (Jan 10):
firmware: Rebase usb/net booting in preparation for move to master - proper
firmware: Rebase usb/net booting in preparation for move to master
https://github.com/raspberrypi/firmware/...f57ddbe727
Reply
(2017-01-15, 11:19)guldfisken1982 Wrote: Hi
How do I get it to play iso files by clicking on the file
in version 18, you could just click on the file, also played it, but after the update, so it opens the iso file AUDIO_TS AND VIDEO_TS
where do I find the setting in which it plays the file not open it
Open the context menu on the ISO file and select Play. Which update are you referring to, when did this behaviour change?

Also, is your MCE remote working now without the workaround?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-01-15, 15:13)fraz0815 Wrote: First build that crashes/bootloops with connected controller (xbox 360 wire) is #0110.

Seems plausible:
Quote:Firmware (Jan 10):
firmware: Rebase usb/net booting in preparation for move to master - proper
firmware: Rebase usb/net booting in preparation for move to master
https://github.com/raspberrypi/firmware/...f57ddbe727

Thanks for confirming #0110. Looking at the crashlogs the crash is happening in VFS code, and there is a VFS change in #0110 (PR8966) - it's the only Kodi change other than spelling changes. Also this same crash is happening on LE Generic (x86) which would rule out RPi firmware.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-01-15, 19:53)Milhouse Wrote:
(2017-01-15, 11:19)guldfisken1982 Wrote: Hi
How do I get it to play iso files by clicking on the file
in version 18, you could just click on the file, also played it, but after the update, so it opens the iso file AUDIO_TS AND VIDEO_TS
where do I find the setting in which it plays the file not open it
Open the context menu on the ISO file and select Play. Which update are you referring to, when did this behaviour change?

Also, is your MCE remote working now without the workaround?
I take the first # 1130, 01-Dec-2016: RPI / RPi2 - Release mail (Kodi 18 alpha 1)
Then I just hit ok, on an iso file on my remote, then plays the movie,
with # 0114, 14-Jan-2017: RPI / RPi2 - Release post (New firmware (total_mem fixes); PR: 1176: remove and rework codi patches; PR: 1179: lirc: fix lircd-uinput @ .service)
I have to press the menu and play, you can make it so you only have to click ok, the iso file to play it?

I have another problem with my remote, windows remote control.
I have DVBLink pvr client, when I'm on wifi, and select a TV channel to display the channel, so it also works fine, but my remote control switches off, so I can not use it, but I take as my tastertur and turn off the channel again, so does the remote control again...
if i use the lan cable and watch TV and the remote works fine
must be something with DVBLink pvr client to do, everything else works
Reply
(2017-01-15, 20:18)guldfisken1982 Wrote: I take the first # 1130, 01-Dec-2016: RPI / RPi2 - Release mail (Kodi 18 alpha 1)
Then I just hit ok, on an iso file on my remote, then plays the movie,
with # 0114, 14-Jan-2017: RPI / RPi2 - Release post (New firmware (total_mem fixes); PR: 1176: remove and rework codi patches; PR: 1179: lirc: fix lircd-uinput @ .service)
I have to press the menu and play, you can make it so you only have to click ok, the iso file to play it?

What I meant was for you identify the first build that has this ISO playback issue - this is crucial as it narrows down the number of possible changes to a much more manageable number (ie. those in a single build).

As it happens, the first build with this ISO playback issue is #0110, so it might be VFS/PR8966 related. Since #0110 pressing "Play" "OK" on an ISO will navigate into the ISO folder rather than begin playback (reproducible on LE RPI and Generic, and also Ubuntu Kodi master).

Ping @ironic_monkey (notspiff)

Edit: Correction - if you press "Play" (on a remote control) then playback of the ISO will begin (rather than be navigated into). However if you press Enter/Select/OK on the remote while the ISO is selected, then this will - since #0110 - navigate into the ISO folder rather than begin playback (as happened in all builds prior to #0110).

(2017-01-15, 20:18)guldfisken1982 Wrote: I have another problem with my remote, windows remote control.
I have DVBLink pvr client, when I'm on wifi, and select a TV channel to display the channel, so it also works fine, but my remote control switches off, so I can not use it, but I take as my tastertur and turn off the channel again, so does the remote control again...
if i use the lan cable and watch TV and the remote works fine
must be something with DVBLink pvr client to do, everything else works

Did this problem start with #0114? Or did it start with an earlier build? Please identify the first build when this problem starts.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0115: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.9.3 #1 Sun Jan 15 21:03:58 GMT 2017 armv6l GNU/Linux

# vcgencmd version
Jan 14 2017 13:03:37
Copyright (c) 2012 Broadcom
version ddb0018638eb8803bbb8f6dda5c39cff4995b3fb (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170115210256-#0115-gb488908 [Build #0115]

# Kodi version
(18.0-ALPHA1 Git:4d93228). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (b4889086, changelog) and tip of XBMC master (22cf5fa4, changelog) with the following modifications: Build Highlights:
  1. New firmware (default to using total_mem=1023)
  2. New AddonsDB schema v27
  3. Add support for SMB File Rename if same share
Build Details:
  1. Firmware (Jan 14):
    • firmware: bootcode: Default to using total_mem=1023
  2. LibreELEC.tv:
    • kodi: update amltiming patch (PR:1178, 2 commits, 2 files changed)
    • added lnbp22.c patch for more power (PR:1118, 1 commit, 1 file changed)
  3. XBMC:
    • Add support for SMB File Rename if same share (PR:11446, 1 commit, 1 file changed)
    • [cmake] Cdio is unconditionally required (PR:11443, 1 commit, 1 file changed)
    • [addons] webinterface.default 2.4.1 (PR:11458, 1 commit, 33 files changed)
    • fixed: make news available when browsing add-on repositories (PR:11455, 1 commit, 1 file changed)
  4. peripheral.joystick:
    • Fix Continuous Integration (PR:76, 0 commits, 0 files changed)
    • [windows] fix CreateDirectoryA & RemoveDirectoryA are not a member of… (PR:75, 0 commits, 0 files changed)
  5. kernel 4.9.y:
    • New commits in this build:
      • ARM64: Fix build break for RTL8187/RTL8192CU wifi (beafd6c1)
      • ARM64: Enable RTL8187/RTL8192CU wifi in build config (784cf16f)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Wink 
(2017-01-15, 22:48)Milhouse Wrote:
(2017-01-15, 20:18)guldfisken1982 Wrote: I take the first # 1130, 01-Dec-2016: RPI / RPi2 - Release mail (Kodi 18 alpha 1)
Then I just hit ok, on an iso file on my remote, then plays the movie,
with # 0114, 14-Jan-2017: RPI / RPi2 - Release post (New firmware (total_mem fixes); PR: 1176: remove and rework codi patches; PR: 1179: lirc: fix lircd-uinput @ .service)
I have to press the menu and play, you can make it so you only have to click ok, the iso file to play it?

What I meant was for you identify the first build that has this ISO playback issue - this is crucial as it narrows down the number of possible changes to a much more manageable number (ie. those in a single build).

As it happens, the first build with this ISO playback issue is #0110, so it might be VFS/PR8966 related. Since #0110 pressing "Play" "OK" on an ISO will navigate into the ISO folder rather than begin playback (reproducible on LE RPI and Generic, and also Ubuntu Kodi master).

Ping @ironic_monkey (notspiff)

Edit: Correction - if you press "Play" (on a remote control) then playback of the ISO will begin (rather than be navigated into). However if you press Enter/Select/OK on the remote while the ISO is selected, then this will - since #0110 - navigate into the ISO folder rather than begin playback (as happened in all builds prior to #0110).

(2017-01-15, 20:18)guldfisken1982 Wrote: I have another problem with my remote, windows remote control.
I have DVBLink pvr client, when I'm on wifi, and select a TV channel to display the channel, so it also works fine, but my remote control switches off, so I can not use it, but I take as my tastertur and turn off the channel again, so does the remote control again...
if i use the lan cable and watch TV and the remote works fine
must be something with DVBLink pvr client to do, everything else works

Did this problem start with #0114? Or did it start with an earlier build? Please identify the first build when this problem starts.

my mistake, thought I had tried pressing play, but nothing happened,
just tried again and begin to play the movie :-D

I have tried with all builds, It's the same happens with the turn off the remote control.
Have also tried with kodi 16, the same problem, so it must be DVBLink pvr client addon, there is something wrong with.
Reply
Hi,

i hope now i m right here with my audio Problem. I will hear Dolby atmos, but at my receiver comes only multichannel pcm 7.1. that is not the right Signal.
But i can only set to DTS, AC3...what is wrong?
Reply
Regarding ISO playback/navigation changes, reverting this commit:

https://github.com/xbmc/xbmc/pull/8966/c...fdc4473038

fixes the issue.

I'll revert this commit in future builds until such time as it is fixed upstream.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-01-16, 00:25)cacheman25 Wrote: Hi,

i hope now i m right here with my audio Problem. I will hear Dolby atmos, but at my receiver comes only multichannel pcm 7.1. that is not the right Signal.
But i can only set to DTS, AC3...what is wrong?

The Pi can't passthrough HD audio - it will convert to 8 channel PCM:
(2016-09-12, 16:14)popcornmix Wrote: No passthrough of HD audio (dts-hd/truehd) on Pi.
It can decoded losslessly to 8 channel PCM and output that through hdmi.

Also, Dolby Atmos won't be decoded as there's no support for that audio format in Kodi yet. You'll only be getting the Dolby TrueHD audio component (same for DTS-X where you'll get DTS-HD MA).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
indeed. that commit was never supposed to land in the first place. it highlights serious hacks in the handling of iso files. originally isos were treated as filedirectories, then that code was disabled (by not identifying them as such) and hacks for dvd/bd added instead. this bit me while adding sacd iso support, so i had to hack the hack.
Reply
(2017-01-16, 00:25)cacheman25 Wrote: Hi,

i hope now i m right here with my audio Problem. I will hear Dolby atmos, but at my receiver comes only multichannel pcm 7.1. that is not the right Signal.
But i can only set to DTS, AC3...what is wrong?

If you want something that supports Atmos i recommend looking at this thread http://forum.kodi.tv/showthread.php?tid=221407

You'll probably be looking at purchasing an intel NUC with a Windows + Kodi install.
Reply
@milhouse i have to ask. are you 100% certain add-ons are built against updated headers? reason i ask is that the only way i can see the vfs addon pr interacting with the joystick handling is through VFSDirEntry, as its definition changed in the vfs pr. either that or the bt is completely broken (stack is stomped, so it is a possibility in theory..)
Reply
(2017-01-15, 23:22)Milhouse Wrote: [*]firmware: bootcode: Default to using total_mem=1023

so I can remove total_mem=1023 from config.txt ?
Reply
  •  Previous
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 238
  • Next 



LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.867