•   
  • 1
  • 57
  • 58
  • 59(current)
  • 60
  • 61
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
New LibreELEC.tv Leia build #0207: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.9.8 #1 Tue Feb 7 21:58:48 GMT 2017 armv6l GNU/Linux

# vcgencmd version
Feb  3 2017 17:32:26
Copyright (c) 2012 Broadcom
version 12dfe2223aa88c5d7ce0e701e9fb7746914decc3 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170207215743-#0207-g8e51cee [Build #0207]

# Kodi version
(18.0-ALPHA1 Git:4c792db). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (8e51cee4, changelog) and tip of XBMC master (4c792dbb, changelog) with the following modifications: Build Highlights:
  1. RPi kernel udpates. Sync options.
  2. Include media_build patch for pctv452
Build Details:
  1. LibreELEC.tv:
    • eventlircd: use default initial-repeat delay for gpio-rc-recv (PR:1271, 1 commit, 1 file changed)
    • kodi: set MALLOC_MMAP_THRESHOLD_=524288 for 64bit cpus (PR:1286, 1 commit, 1 file changed)
    • add new retroplayer emulators (PR:1284, 4 commits, 4 files changed)
    • fix lirc cross-compilation and non-working left/right keys (PR:1281, 3 commits, 4 files changed)
    • tbs-linux-drivers: remove drivers (PR:1291, 1 commit, 2 files changed)
    • kodi: update to 4c792db (PR:1292, 4 commits, 8 files changed)
  2. XBMC:
    • Remove generated file (PR:11627, 1 commit, 1 file changed)
  3. kernel 4.9.y:
    • New commits in this build:
      • config: Enable regulator support (fe1a6c3d)
      • BCM270x DT: expose 3.3V and 5V system rails (d318e9c9)
      • BCM270x DT: Consolidate audio card overlays (5de60e06)
      • ASoC: Add driver for Cirrus Logic Audio Card (42fef811)
      • config: enable Cirrus Logic Audio Card (14665270)
      • Merge pull request #1810 from HiassofT/cirrus-rpi (a5204ea3)
  4. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I am using #0206 with my Samsung Smart TV and CEC suddenly is working instantly for me again without the need to reselect kodi each time after input source switching.
Is there something CEC related in build #0206 what has not been in build #0205 and previous?

If yes: congratulations, then whatever you've done fixed it for me Smile Absolutey no need to read the text beneath!

---- if not ----

If not, then - I know this will sound very odd - the only thing, what I have done since I use this build what I have not done while using previous builds, is that today I played on my PS4 and pressed "Tools" -> "Anynet+ (HDMI-CEC)" (talking about Samsung remote and TV menu) as if I would have to select kodi once again. Reason why I did this, is just because I have been curious if my PS4 would show up as CEC device in my TVs menu, now that I had to use this menu dozens of times to reselect kodi after input source switching.
Of course my PS4 didn't show up, but when I saw there was still "kodi" in the list, I pressed the onscreen button named "refresh". There are two onscreen buttons to the right of the CEC devices list, "refresh" and "abort", or in my German GUI it is "Aktualisieren" and "Abbrechen" and I used the refresh function rather frequently, because often after a new testbuild with altered "Pulse Eight CEC Adapter" or if I had changed some CEC options in libreelecs menu on my own I had to refresh this list to regain remote functionality, even if "kodi" was showing up. But I never before used this refresh function with another source than kodi until I for fun tried to connect my PS4 to the TVs remote.

Well, what can I say... I now can watch Amazon Prime and Youtube via Samsung Smarthub or switch the TV's input source to another HDMI input or internal "TV" and switch back to libreelec as often as I want and instantly am able to use the remote with libreelec without having to reselect kodi as source. My TV still says "Disconnecting Anynet" as ever (free translation from German) when using the smarthub, but right after terminating Amazon prime or Youtube and switching back to libreelec I can use the remote with it.

I know all that doesn't make much sense but I swear that's all what I did today what might be different from the other days...Huh Maybe refreshing the devices list while another source than kodi was active has somehow resetted my TV's or AVR's way to handle active CEC devices?
Reply
(2017-02-08, 03:46)MMXT Wrote: Is there something CEC related in build #0206 what has not been in build #0205 and previous?

Not to my knowledge.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Okay, then I hazard a guess: the problem when many of us had to reboot whole libreelec system until CEC could be used again after switching sources seems to be fixed for most (all?) of us since several builds. The remaining issue (we Samsung users have to tell the TV to use "kodi" as device to control via CEC after using Smarthub or other input) is suddenly fixed for me now without further changes to libreelec's CEC, so this might be our not so smart Smart TV's and not something with libreelec itself.
Reply
Have you turned your TV off at the mains for 30 seconds, and then tested with #0206+ again?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Samsung have cec problem, my samsung tv js9090 working after upgrading to tv firmware v1840
Search on google samsung anynet problem (your tv model)
Reply
(2017-02-07, 21:36)Milhouse Wrote: @raptorjr is this with stock Estuary? Which is the last build that prompts correctly?


This is an add-on feature. Please ping the pvr.mythtv maintainer to make him aware of the problem. @janbar
Reply
(2017-02-08, 08:50)ksooo Wrote:
(2017-02-07, 21:36)Milhouse Wrote: @raptorjr is this with stock Estuary? Which is the last build that prompts correctly?


This is an add-on feature. Please ping the pvr.mythtv maintainer to make him aware of the problem. @janbar
The feature worked with krypton rc1. I didn t checked again. The dialog box is opened when kodi set the recording as watched. So not related with replay the show. Kodi set the recording as watched after show has been watched and so after playback was stopped. Probably it is very slow on the PI and the delay for kodi to set the recording is long enougth to make trouble. Also it could show your hardware is overloaded.
Seems a dead lock occurs when box has been opened during the retry playing. I know to have similar issue with xbmc in previous release. What I can do to avoid this situation is to check if playback runs before trying to open the dialog.
Reply
Still the same cec problem with switching the tv off via cronjob. The last version that worked (mostly) was #0113. Tested all versions up to #0207.
But: after switching off Kodi didn't react on TV remote commands anymore until rebooting. When rebooting the TV always switches to "on". That's annoying.
Nevertheless: Milhouse version of Kodi is still my favourite one...
Reply
(2017-02-07, 23:28)niedi_74 Wrote:
(2017-02-07, 23:24)Milhouse Wrote:
(2017-02-07, 22:48)niedi_74 Wrote: good evening,

i want inform you guys that the pctv452 patch is not working ... just test it with the last version 205/206 ....

test it on new setup with the LibreELEC-RPi2.arm-7.95.2.img and its working fine and got /dev/dvb ...

after upgrade to the milhouse its not appear anymore

http://sprunge.us/MGOU

cheers

niedi


The pctv452 patch had only been pushed to the libreelec-8.0 branch and not master. It's been pushed to master now, and will be in tonight's #0207 build.


thanks for the update !

its working, many thanks
Reply
(2017-02-07, 23:42)Milhouse Wrote:
(2017-02-07, 22:55)guldfisken1982 Wrote: hey
I'm really new to this, I have raspberry pi 3, with your codi.
I've run every update that has been. I've pasted the code
dtoverlay = lirc-RPI
in config.txt
so my media center remote control works, but after # 0205, 05-Feb-2017
goes on a rampage, so I had to turn off the raspberry.
But the version of 204 works fine, and the former.
Do not read if there are others who have the same problem, my English is not good, then use google translate

Can you re-install build #0205 and, assuming you have the same issue, can you run the following commands and paste the results:
Code:
dmesg | pastebinit
journalctl -a | pastebinit
Thanks.

I do not know just where I should insert the commands? I'm not very good at this Rofl
after I installed the 205/206 can not I install 204 afterwards, so it works, I have to format the SD card, and start over.
That's when I reach into live TV "DVDLINK PVR CLIENT", it is that it continues to press a button on the remote control, I can not do anything but restart raspberry.
Reply
(2017-02-08, 11:07)guldfisken1982 Wrote: I do not know just where I should insert the commands? I'm not very good at this Rofl

You'd use ssh (username root, password libreelec). Download PuTTY if you are using Windows. Although if you haven't already enabled ssh and Kodi is no longer working then I guess you're screwed.

(2017-02-08, 11:07)guldfisken1982 Wrote: after I installed the 205/206 can not I install 204 afterwards, so it works, I have to format the SD card, and start over.
That's when I reach into live TV "DVDLINK PVR CLIENT", it is that it continues to press a button on the remote control, I can not do anything but restart raspberry.
That's why you need ssh, and then you'd be able to recover the system even when Kodi isn't working.

To be honest if you're not able to login to LibreELEC using ssh then you shouldn't be using these test builds.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
@guldfisken1982 you could try uploading the latest logfile zip from the logfiles samba share, as that might contain sufficient information. If you're not sure how to do it then maybe someone can help you later.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-02-08, 11:28)Milhouse Wrote:
(2017-02-08, 11:07)guldfisken1982 Wrote: I do not know just where I should insert the commands? I'm not very good at this Rofl

You'd use ssh (username root, password libreelec). Download PuTTY if you are using Windows. Although if you haven't already enabled ssh and Kodi is no longer working then I guess you're screwed.

(2017-02-08, 11:07)guldfisken1982 Wrote: after I installed the 205/206 can not I install 204 afterwards, so it works, I have to format the SD card, and start over.
That's when I reach into live TV "DVDLINK PVR CLIENT", it is that it continues to press a button on the remote control, I can not do anything but restart raspberry.
That's why you need ssh, and then you'd be able to recover the system even when Kodi isn't working.

To be honest if you're not able to login to LibreELEC using ssh then you shouldn't be using these test builds.

have tried to run the commands with putty, but it did not work, do not know what it is to do :-D
this is not something I have to mess with.
I have just run with 204, so no update
Reply
(2017-02-08, 11:52)Milhouse Wrote: @guldfisken1982 you could try uploading the latest logfile zip from the logfiles samba share, as that might contain sufficient information. If you're not sure how to do it then maybe someone can help you later.

I grab the log file after updating to 205
but I can not upload zip files through here
Reply
  •   
  • 1
  • 57
  • 58
  • 59(current)
  • 60
  • 61
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712